My particular workaround for error 0xf9617590 in the NFC process

Discussion in '3DS - Tutorials' started by singinwhale, Oct 22, 2017.

  1. singinwhale

    singinwhale Newbie

    Oct 18, 2017
    First of all small background. I once had a working Menuhax with ReiNAND and an EmuNAND (11.3E) on my N3DSXL 9.2 (European) but at some point games stopped launching on the system. I am talking about legit cartridge games here. The system kept saying "An Error Occurred" with no code or anything and rebooted. I tried going through the whole EmuNAND setup again but it still gave me that message. So I put the 3DS aside for a while until I heard of the new B9 way of hacking the 3DS. After some research I went to and went through the hacking process using soundhax, godmode9 and Luma3DS. Which worked great. Now I ran into the error you see in the image. AR Game and CIAs like FBI, SysDowngrader, Anemone3DS etc. are completely fine but my Monster Hunter 4 Ultimate cartridge or even the Homebrew Launcher CIA throw this error.
    Error Image
    An error occurred (ErrDisp)
    Error type: generic
    Process ID: 40
    Process name: nfc
    Process title ID 0x0004013000004002
    Adress: 0x001005b4
    Error code: 0xf9617590
    Process ID is not always the same I have seen others like 41, 43, 46 etc.

    Things causing this error: (that I've tested)
    launching Monster Hunter 4 Ultimate from cartridge
    launching Friendlist
    launching Mii Lobby
    launching Homebrew Launcher
    launching EShop
    connection test after creating a new connection on connection failure in System Settings

    Things NOT causing this error (that I've tested):
    launching a NintendoDS cartridge (Metroid Prime: Hunters)
    launching AR Games
    launching DS Download Game
    launching Browser
    launching Mii Maker
    launching Settings
    launching FBI
    launching Nintendo 3DS Sound
    launching Nintendo 3DS Camera

    My setup is New 3DSXL European on 11.5.0-38E with Luma3DS and godmode9.

    As far as I could tell it is a problem with the NFC module, but I didn't know where to start debugging so I went to the Nintendo Homebrew Discord ( and asked for help. Huge thanks to the user ihaveahax (I think he is called ihaveamac here in the forums) for helping me there. I am documenting the process here so others can benefit from my issue.

    As you can see the error occurs in a title with the ID 0004013000004002, however New3DS system titles normally have a 2 instead of a 0 as their 9th (counting from left to right) hex-value so the title on New3DS should look like this:
    instead of this:
    After trying to find the title causing this error in FBI's title list we found that the title was missing!
    The title for New3DS (0004013020004002) was there but the one the 3DS was trying to launch (0004013000004002) was not.
    I was then sent a CIA containing the Old3DS' NFC title that has the suiting TitleID (I am probably not allowed to link it here but here is the SHA1: E799CEF15A768F33C261BDB9C2E7847511813288). After installing that CIA games were launching normally again!
    Now hold on though before you jump for joy, I should tell you why this is a workaround and not a fix:

    1. The 3DS always thinks there is a software update.
    I think this is because we installed a new system title and now it thinks the system software was "changed". Now this by itself is not that bad right? We can just dismiss this notice. But that causes new issues.
    2. You can't access EShop anymore. Because EShop won't launch if the 3DS thinks there is a software update and uninstalling the old3DS nfc title will break EShop again. You see the issue?
    3. You can't update games anymore. If EShop doesn't work we can't use normal game updates either. You still can update if you find the updates' CIA files but those are quite hard to find sometimes. Also, if you have a friend with the same game he can download and dump them for you.
    4. I'm sure there is other broken things. I am pretty sure I didn't fix the root cause for this issue and that root cause might have other side effects. My 3DS still randomly crashes when I try to turn it off, for example.

    I hope I could help some people. Sadly I did not find the original cause for this issue.
    I also tried doing a CTRtransfer with one of the default images on the page but that did not fix the issue either.

    Maybe some devs can look at this and find what is causing this issue.

    After fixing this I still had another issue where I could not accept the EULA to go online (Games said: "this service is not available in your region"), but there are plenty of tutorials and solution threads where you can find the solution to that particular issue.

    EDIT: Clarified the missing title ID.
    Last edited by singinwhale, Oct 23, 2017
  2. Tenshi_Okami

    Tenshi_Okami GBAtemp Maniac

    Nov 3, 2015
    Puerto Rico
    my friend had this same error 2 days ago, it only happened on Smash(only place where i tested)

    I fixed it by CTRDowngrading to 11.2
  3. Bu2d85

    Bu2d85 GBAtemp Maniac

    GBAtemp Patron
    Bu2d85 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 6, 2014
    United States
    If you’re not a dev and don’t plan on posting bugs on github, disable the arm11 exception handlers (or something like that) in the Luma configuration settings.

    You will stop seeing these errors.

    That setting is for debugging purposes.
  4. PabloMK7

    PabloMK7 Red Yoshi! ^ω^

    Feb 21, 2014
    Yoshi's Island
    As far as I know, trying to update will fix your problem, so what about ctrtransfering to 9.2 and then updating?
    Is the n3ds version of the title even installed?
  5. singinwhale

    singinwhale Newbie

    Oct 18, 2017
    Yes, The N3DS version is installed normally and I did a CTR transfer to both 11.2 and 11.5 as well as a normal downgrade to 9.2 using SysDowngrader. None of that fixed the issue for me.

    I do post bugs on github but I am not sure where with this one because this does not seem to be a CFW related bug to me.

    Disabling exception handlers does nothing to change the situation.
    Last edited by singinwhale, Oct 23, 2017
  6. NinjaShuriken

    NinjaShuriken Newbie

    Feb 10, 2018
    Um hey I gotta have that CIA I might cry because I'm dying not being able to use my 2ds almost completely discord me at NinjaShuriken#7092
    If you could it would mean the world to me please:sad::cry:
    Last edited by NinjaShuriken, Oct 3, 2018
  7. singinwhale

    singinwhale Newbie

    Oct 18, 2017
    The workaround that I described was for the New3DSXL and not the 2DS, or are you on a New 2DS?
  8. NinjaShuriken

    NinjaShuriken Newbie

    Feb 10, 2018
    Yes I do have New 2ds XL but I found the file and it gives me a new error even so I could try to install ur file and see if it works. Thanks anyways