My nintendo 3DS plays a strange sound in the homebrew

Discussion in '3DS - Homebrew Development and Emulators' started by BlueFox gui, Feb 4, 2016.

  1. BlueFox gui
    OP

    BlueFox gui SOMEONE

    Member
    1,767
    2,201
    Feb 4, 2016
    Brazil
    NAS TERRAS DE HUE BR
    Hello wish someone would answer me if it happens to any of you , my 3ds plays a strange sound when opening any application on homebrew something like a whistle followed by a small hiss and open the application normally , but it never happened before just came to ask if this is normal is already happened to someone .
    So can someone help me?
    sorry if my english is bad.
     
  2. HappyzLife

    HappyzLife ( ͡° ͜ʖ ͡°)

    Member
    198
    74
    Sep 9, 2015
    Italy
    I'M EVERYWHERE
    I'm so curious, can you please record and upload a simple audio? :)
     
    DarkFlare69 likes this.
  3. Xenosaiga

    Xenosaiga That one guy that doesn't give a shit anymore

    Member
    1,478
    838
    Oct 9, 2015
    United States
    The Shadows
    Tagging @keanutah since he knows exactly what it is since I brought it to his attention in his Blackjack 3DS
     
  4. MasterFeizz

    MasterFeizz GBAtemp Advanced Fan

    Member
    888
    826
    Oct 15, 2015
    United States
    It happens when you exit a homebrew and it doesn't clean up the csnd service, when you enter another app that uses the csnd service the dirty buffers cause the hiss and pop.
     
    Xenosaiga likes this.
  5. Xenosaiga

    Xenosaiga That one guy that doesn't give a shit anymore

    Member
    1,478
    838
    Oct 9, 2015
    United States
    The Shadows
    THIS.

    That is exactly what it was but I didn't know how to put it as I didn't quite understand it myself.

    @BlueFox gui, what homebrew did you launch just before the hissing started?
    Not the one that the hissing started on but the one you was using just before it started.
     
  6. BlueFox gui
    OP

    BlueFox gui SOMEONE

    Member
    1,767
    2,201
    Feb 4, 2016
    Brazil
    NAS TERRAS DE HUE BR
    I use MENUHAX and I opened the port of the Quake game before opening another application.
     
  7. MasterFeizz

    MasterFeizz GBAtemp Advanced Fan

    Member
    888
    826
    Oct 15, 2015
    United States
    Awkward... I thought I fixed it, maybe I haven't pushed the changes.
    Edit: I did fix it, are you force closing quake?
     
    Last edited by MasterFeizz, Feb 4, 2016
  8. Xenosaiga

    Xenosaiga That one guy that doesn't give a shit anymore

    Member
    1,478
    838
    Oct 9, 2015
    United States
    The Shadows
    That's another issue. If force closing it aka using L+R+down+B then the app won't call the closing arguments or whatever they are called.

    It's a dirty dirty dirty bug that's in *hax 2.5 itself.


    Use @mashers grid launcher. Iirc he implemented a check system that force closes the csnd service before his grid launcher will launch.

    https://gbatemp.net/threads/release-homebrew-launcher-with-grid-layout.397527/
     
  9. keanutah

    keanutah GBAtemp Regular

    Member
    173
    130
    Sep 18, 2015
    United States
    Yeah it's definitely related to CSND not being cleaned up properly by the homebrew.