My new Maxtor 1tb external is dead after 1 night?

Discussion in 'Wii - Hardware, Devices and Utilities' started by mayhem69, Jul 28, 2009.

  1. mayhem69
    OP

    Newcomer mayhem69 Member

    Joined:
    Feb 15, 2009
    Messages:
    18
    Country:
    United States
    I am not quite understanding this WBFS stuff . All i did was use partition magic on my 1tb Maxtor external. Then i used WBFS to format half the partition. Transferred about 20 games. Everything was going great, games were loading no problem. Then today when i got home from work, the drive did not work, it's dead according to the tech. Did i do something wrong here? Or what didn't i do?
     
  2. dudenator

    Member dudenator King of the Carts

    Joined:
    Mar 7, 2009
    Messages:
    471
    Location:
    Alberta
    Country:
    Canada
    Did you spill juice on it lol. Try formating it see if that works if not return it.
     
  3. DSGamer64

    Member DSGamer64 Canadian, Eh?

    Joined:
    Nov 9, 2007
    Messages:
    2,931
    Location:
    A cold cold place
    Country:
    Canada
    Maxtor = junk, I had an 80GB drive that died after 6 months of very little use, imo, their drives are shit.
     
  4. Elritha

    Member Elritha GBAtemp Addict

    Joined:
    Jan 24, 2006
    Messages:
    2,037
    Country:
    Canada
    Agreed, maxtor are a piece of junk. Had to send back one before.

    By dead what do you mean exactly. Have you tried hooking it up to your pc and formatting it, is it even detected?
     
  5. PettingZoo

    Member PettingZoo yesss

    Joined:
    Oct 5, 2008
    Messages:
    1,707
    Location:
    in the trap
    Country:
    Australia
    You have to watch out for 1tb externals these days, I've seen many low price ones going around now and they look pretty shonky to me.
     

Share This Page