My MAGIC-NS stops working if I let it plugged on the switch.

Discussion in 'Switch - Console, Accessories & Hardware' started by kazekun, Feb 10, 2018.

  1. kazekun
    OP

    kazekun GBAtemp Regular

    Member
    2
    Nov 11, 2009
    Alright so I only received the item on friday, and I am not sure if Its me doing something wrong, or if the item is defective as it is.

    So i bought an Magic-NS to use exclusivly with my switch, after it arrived, i plugged to the pc, everything was fine, lights on, updated the software to 1.19 no problems here, I take it to the switch, made it work with the controllers try it out and worked great.
    So heres where my problems start, when my switch goes to sleep mode, after I turn it on, the MAGIC-NS doesnt work at all, no lights on the leds, no response, the funny thing is, when I bring it back to pc, it also doesnt work, the computer doesnt even recognise it, but after i replug it a couple times on the pc, or just let it out of the switch for a while and plug on the pc it seems to work fine, then all I have to do, is bring it back to the switch and its working again, and while it works, it seems to work flawlessly max i tried was about an 1hour session, but it did so without any problem...

    Sooo, is my item defective or am I missing anything here?
     
  2. isoboy

    isoboy GBAtemp Advanced Fan

    Member
    4
    Dec 23, 2016
    United States
    These posts lately about defective Magic-NS adapters makes me slowly realize I may have just gotten lucky with a working one. It blinks all the time and when I play in the dark it's even annoying until I just turn the dock a little bit so I block the led light. A couple of times I've also had my DS4's battery drained when I picked it up so it must've kept the connection or something. Weird.
     
  3. YTElias

    YTElias Ashley

    Member
    3
    Aug 23, 2017
    Germany
    Germany
    what is a Magic-NS
    never heard of it
     
  4. Uumas

    Uumas GBAtemp Advanced Maniac

    Member
    6
    Sep 17, 2016
    Finland
  5. Uumas

    Uumas GBAtemp Advanced Maniac

    Member
    6
    Sep 17, 2016
    Finland
    If the light bothers you why not keep it inside the dock?
     
  6. YTElias

    YTElias Ashley

    Member
    3
    Aug 23, 2017
    Germany
    Germany
  7. Uumas

    Uumas GBAtemp Advanced Maniac

    Member
    6
    Sep 17, 2016
    Finland
    If you want to use controllers you already have instead of buying new ones. Or you just don't like the joycons/switch pro controller.
     
    Yoni Arousement likes this.
  8. isoboy

    isoboy GBAtemp Advanced Fan

    Member
    4
    Dec 23, 2016
    United States
    I'm just noticing the red led sometimes. All I have to do is turn the dock like twenty degrees or something. It's nothing. Also I'm not using the official shitty dock. I use the BETTER small 3rd party one so the usb adapter sticks out.
     
  9. epickid37

    epickid37 ( ͡° ͜ʖ ͡°)

    Member
    5
    Jan 4, 2017
    United States
    mushroom kingdom
    Can you downgrade the software?
     
  10. blackberrylime

    blackberrylime Newbie

    Newcomer
    1
    Mar 23, 2018
    United States

    I'm having the same issue. It does seem to eventually come back to life after being plugged in to the computer a bunch of times. Very curious to know if anyone finds out why it does this...
     
  11. camilord

    camilord Newbie

    Newcomer
    1
    Apr 1, 2018
    Colombia
    i was having the same issue, but I think that i found the answer (partially), i just realized that when you unplug the mayflash dongle before shutting down (or put in sleep mode) your pc or switch, this issue doesnt appear, hope this works for you. On the other hand i know, its so annoying to unplug the dongle all the times that you have to shutdown or sleep your switch.

    Please tell me if this work for you

    PS: Sorry for my english
     
    Yoni Arousement and Fritte like this.
  12. Fritte

    Fritte Newbie

    Newcomer
    1
    Apr 2, 2018
    Germany
    Odered my MAGIC-NS on Amazon two weeks ago and have the same issue.
    But the solution of camilord seems to work quite well, thanks.
     
    camilord likes this.
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice