My Edge card just died in the weirdest way.

Discussion in 'NDS - Flashcarts and Accessories' started by biggyfred, Apr 10, 2008.

  1. biggyfred
    OP

    biggyfred Newbie

    Newcomer
    9
    0
    Mar 15, 2008
    United States
    Mods, if this is in the wrong place, please move it for me. I couldn't decide where something like this should go. Thanks.

    Just for some background, my DS lite is less than two weeks old. Having a friend that wanted a card as well, I purchased two Edge cards, along with 4 2GB Kingston cards. That's my setup.

    I have used the DS at most, 3 or 4 times, no longer than a half hour. The Edge card never came out of the DS once it went in. Anyways, tonight I thought I'd sit down for my first hardcore gaming session with it. Was going to put in a couple of hours. Boot it up, no problems. Played a game for 45 mins, no problems. I realized that it was night in game and that I hadn't set the time settings correctly since I swapped a battery out. Turned off the DS, turned it back on, forgetting to take out the Edge card.

    Instead of booting back into the Edge, it hangs on that opening warning screen. Weird. I power up and down. It hangs at a different spot on that same screen. 4 or 5 times this happens, then it suddenly boots fine. I power off, take out the Edge, and set the time. Put the Edge back in, and it doesn't work at all now. No DS Cart detected.

    I put my friend's Edge card in my DS. Boots fine.
    Put my Edge card in my friend's DS. Doesn't boot.
    I swap out my microSD for theirs in their Edge and put it in my DS. Boots fine.
    I swap out my microSD for theirs in my Edge and put it in my DS. Doesn't boot.
    Do the same two last steps above in their DS. Boots with their Edge, not with mine.

    Connections look fine on the 'faulty' Edge, certainly no kind of scoring or uncleanliness that would cause concern. In fact, it looks exactly like the working Edge, cept it, you know, doesn't work. On a whim, I tried the 'paper trick'. Didn't work.

    Anyone have any insights on this one? I tried a couple of searches, but couldn't find anything. Thanks in advance.
     
  2. cupajoe

    cupajoe Have a cup of joe!

    Member
    1,143
    0
    Aug 25, 2007
    United States
    Minnesota
    That's odd. Try seeing if the connections are dirty inside the slot 1.
     
  3. biggyfred
    OP

    biggyfred Newbie

    Newcomer
    9
    0
    Mar 15, 2008
    United States
    The slot 1 connections are about as clean as they come on both the Edge card and inside the DS.

    Anyone crack one of these suckers open before? I emailed the store I bought from and asked if they would take it back if I try to open it and fix it myself so we don't have to go through the hassle of a return, still waiting for a response.

    More suggestions in any form are still appreciated...
     
  4. shinset

    shinset Advanced Member

    Newcomer
    58
    0
    Feb 12, 2006
    just got 10 EDGE one of them have the same issue as you at first

    bug on nintendo warning screen
    white screen

    I've to eject edge , remove micro SD and reinsert everything back 2 times before it works

    maybe the micro sd slot has bad contact (not sure you can unmount the slot since its soldered)

    I hope its not a faulty one !
     
  5. biggyfred
    OP

    biggyfred Newbie

    Newcomer
    9
    0
    Mar 15, 2008
    United States
    Welp, it goes back to them tomorrow. They said cracking it open would violate the warranty. I'd donate it to science and take up close pictures while trying to solve the seemingly at-issue micro-sd slot, but I'm broke and can't afford another one.

    Thanks for the views fellas. This little chip is going to the big chip heaven in the sky.
     
  6. Elisa_

    Elisa_ GBAtemp Fan

    Member
    362
    0
    Apr 5, 2008
    Wow, it died weirdly.
     
  7. jalaneme

    jalaneme Female Gamer

    Member
    6,248
    195
    Nov 27, 2006
    London
    you get what you pay for, buy a cylco ds it's the real card and not a clone...
     
  8. SavageWaffle

    SavageWaffle GBAtemp Maniac

    Member
    1,123
    1
    Jan 13, 2008
    United States
    New York