My CycloDS 1.4 firmware impressions

Discussion in 'CycloDS' started by Dsparil, Jun 20, 2008.

  1. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States
    EDIT: I figured out that my issues were solved by loading a game into NOR for the first time. Even after erasing the NOR, it was still detecting my New3in1.


    I hate to say it because I love my CycloDS dearly and appreciate the hardwork Team Cyclops has done, but I believe that 1.4 needed more development time before being released.

    Here is my configuration:
    White CycloDS 1.1
    Firmware 1.4 Final
    Transcend Class 6 4gb microSDHC
    White New3in1

    Test 1: GBA
    I loaded up my favorite GBA game "Super Mario Advance 4 - Super Mario Bros. 3", but I got a warning stating that 1MBit savs does not work(Nothing was stated in the readme about this). It loaded the rom anyways but corrupted the save file, and the game would not continue after that.

    I was disapointed, but I proceeded to try another game: I loaded up "Super Mario Advance 2 - Super Mario World", and it worked flawlessly. I restarted the game to make sure it would load my saved game, and it worked.

    Test 2: Rumble
    I loaded up Star Fox Command and felt a slight vibration as the rom finished loading, but after I started playing, the game would not vibrate. I thought that maybe it would be an issue with that specific game, so I tried out Super Princess Peach to find out that the result was one and the same.

    Test 3: NDS Browser
    My result was that the NDS Browser does not work.

    Test 4: GBAExploader Compatibility
    It still works flawlessly, but you have to make sure that rumble is enabled in the CycloDS menu, or enabling rumble support with GBAExploader won't work.

    Conclusion:
    The newer model of the EZ Flash 3-in-1 is having issues with the 1.4f firmware, but at least it's compatible with GBA roms, so that's a good sign. However, since games that use 1MBit saves doesn't work unpatched and because the newer model of the EZ Flash 3-in-1 doesn't work with Rumble and NDS Browser, I will stick with GBAExploader until these issues are solved in a future firmware.

    For people that have an older model of the EZ Flash 3-in-1, I'm sure that this firmware is nice, but you may still want to stick with GBAExploader if you do not want to patch games that uses 1MBit saves.



    Copy of Changelog:

     
  2. gratefulbuddy

    gratefulbuddy amateur lunatic

    Member
    802
    0
    Apr 4, 2007
    United States
    on the wheel
    Thats is your misinterpretation. Previously, the 3n1 wouldn't be recognized when launching the Opera browser after having been reset from a rumble game. Now this should work correctly. It does not mean you have to start a rumble game, then soft-reset, then launch the opera browser.
     
  3. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States

    Thanks for pointing that out (I did not beta test, so I didn't know what this was about)
     
  4. budrow66

    budrow66 GBAtemp Regular

    Member
    194
    0
    Jun 1, 2007
    United States
    T.N.
    Also the GBA function is in beta stages, GBAExploder didnt do 1 mb sav either when it started...
    Give it time.
     
  5. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States
    If that was my only issue, I wouldn't mind patching those games that uses 1MBit saves. However, I am hopeful that the new 3in1 will be fully supported in a future firmware update.
     
  6. gratefulbuddy

    gratefulbuddy amateur lunatic

    Member
    802
    0
    Apr 4, 2007
    United States
    on the wheel
    According to GBA EXPLoader v0.57 one of my 3n1s is a [New3n1]. Using Cyclo v1.4, Opera works fine (auto-detects for ram), and the rumble function works appropriately.
     
  7. Chrono_Tata

    Chrono_Tata GBAtemp Advanced Fan

    Member
    851
    0
    Jan 26, 2008
    Thailand
    Works fine for me. You sure you enabled it in-game? [​IMG]
     
  8. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States
    Works fine when I use it with GBAExploader, so that's not the issue.

    edit: yes, I checked.

    Are your sure your 3-in-1 is the new model?
     
  9. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States
    It doesn't work for me. Is your New3in1 black or white?
     
  10. Rock Raiyu

    Rock Raiyu Clock Up

    Member
    5,066
    38
    Jul 14, 2007
    United States
    Walking the path of heaven
    I'm just having problems loading up some homebrew. Sometimes I get a white screen, but sometimes I don't but some homebrew where I need to connect to wi-fi don't work.
     
  11. Chrono_Tata

    Chrono_Tata GBAtemp Advanced Fan

    Member
    851
    0
    Jan 26, 2008
    Thailand
    I got it only 3 weeks ago, so it should be the new model.
     
  12. gratefulbuddy

    gratefulbuddy amateur lunatic

    Member
    802
    0
    Apr 4, 2007
    United States
    on the wheel
    Black. But it seems that something may be wrong on your end. Not just some different and unsupported hardware model/revision that no-one else has, but a malfunction/break/bad install/wrong setting.
     
  13. PS3sixty

    PS3sixty Member

    Newcomer
    33
    0
    May 28, 2008
    United States
    I'm also having trouble with the Cyclo GUI's GBA feature. I tried Advance Wars, Street Fighter Alpha 3, F-Zero Maximum Velocity, Mario Kart Super Circuit, and they all play fine but my saves are gone the next time I boot up the system (even though I can see the .sav files in the GBA_SAVE folder). I'm talking about the PSRAM mode btw (only NOR mode loads the saves). Super Mario World and Top Gear Rally loaded the saves fine in PSRAM though.

    Also, the Cyclo manual says that the saves are compatible with GBA ExpLoader, but why aren't they loading when using Cyclo to launch GBA games? Is there something I need to do to load saves?

    I'll just stick to using GBA ExpLoader since it works perfectly.
     
  14. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States
    I'm sure there is nothing wrong on my end especially since GBA ExpLoader works perfectly. Also, the fact that GBA games are working on my end demonstrates that it's partially working. There must be some hardware differences between the black and white New3in1.

    I'll post youtube videos since you're not taking my word for it.
     
  15. johnchan

    johnchan Advanced Member

    Newcomer
    88
    0
    Aug 15, 2007
    I have a new 3in1 and both rumble and opera work for me. Dsparil, do you have rumble enabled in the cyclo settings menu? This is required in order for it to work.
     
  16. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States
    If you read my post, I have to have rumble enabled in the CycloDS menu for rumble to even work with GBA ExpLoader.

    I'm going to try to reflash this once more as a last ditch effort.
     
  17. Papayo

    Papayo Advanced Member

    Newcomer
    65
    1
    Feb 14, 2007
    Right over there -->
    I have a new white 3 in 1 and it's working absolutely great. Rumble works just fine, although it's not really all that enjoyable. The browser works great too (make sure you're using a clean rom).

    I'm still using ExpLoader for GBA, since I've had a few problems with the Cyclo one.
     
  18. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States
    I found the solution to my problem. The only thing I had to do was load a rom to NOR(I had it blank before) for the first time, and now my CycloDS will automatically detect my New3in1 in rumble enabled games and the NDS Browser.

    I wonder if it will still work if I clean the NOR again.

    edit: Even if I clean the NOR, my CycloDS still autodetects it.
     
  19. gratefulbuddy

    gratefulbuddy amateur lunatic

    Member
    802
    0
    Apr 4, 2007
    United States
    on the wheel
    Glad to hear you got it working.
     
  20. Dsparil
    OP

    Dsparil Member

    Newcomer
    33
    0
    Apr 25, 2008
    United States

    Thanks for the help. Now I'm stuck with deciding to wait until 1MBit saves are supported by keeping GBA ExpLoader, or just patch the games and get rid of GBA ExpLoader altogether. [​IMG]