My apps don't appear on the homebrew channel

Discussion in 'Wii - Hacking' started by Oui, Nov 30, 2018.

  1. Oui
    OP

    Oui Member

    Newcomer
    1
    Feb 14, 2017
    Switzerland
    Geneva
    Hi, I've recently bought a new SD card for my Wii but after transfering the exact same files i had in my previous SD card (which worked perfectly fine), my applications didn't show up. I've tried to follow several tutorials and threads, but nothing changed.
    Any idea on how to fix my problem ?
    Thanks in advance.
    EDIT : The SD card is formated to FAT32
     
    Last edited by Oui, Nov 30, 2018
  2. Jitoku

    Jitoku GBAtemp Guru

    Member
    2
    Feb 26, 2018
    United Kingdom
    That sd card does not work. Very easy
     
    GodLLama likes this.
  3. GodLLama

    GodLLama Member

    Newcomer
    1
    Nov 28, 2018
    Germany
    Use usb
     
  4. Oui
    OP

    Oui Member

    Newcomer
    1
    Feb 14, 2017
    Switzerland
    Geneva
    I've tried to use my previous SD card (which, as I said, used to work fine), but it didn't work either

    I'll give this a try asap
     
  5. jeannotte

    jeannotte GBAtemp Advanced Fan

    Member
    4
    Jun 15, 2016
    France
    Hello,

    Watch if your SD cards are not locked in writing, the little "LOCK" on the side of the SD card
     
  6. Illuminaticy

    Illuminaticy GBAtemp Fan

    Member
    4
    Oct 6, 2018
    United States
    Press 2 on HBC and select SD
     
  7. Oui
    OP

    Oui Member

    Newcomer
    1
    Feb 14, 2017
    Switzerland
    Geneva
    it's not locked

    doesn't work either
     
  8. Hardy_Heron

    Hardy_Heron Member

    Newcomer
    1
    Mar 6, 2017
    Chile
    Valparaíso
    Directories are ok?
    apps/yourapp
     
  9. robyspy

    robyspy Advanced Member

    Newcomer
    2
    Sep 18, 2018
    Italy
    to remove any doubt, the Homebrew Channel shows what I copy in the "apps" folder
     
  10. Illuminaticy

    Illuminaticy GBAtemp Fan

    Member
    4
    Oct 6, 2018
    United States
    If you're formatted to Fat32, and your old SD still works, then the new SD does not work
     
  11. robyspy

    robyspy Advanced Member

    Newcomer
    2
    Sep 18, 2018
    Italy
    @Illuminaticy true, but the problem could also be a micro sd with adapter, these are less compatible than SD.
    if I remember correctly, only the FW 4.3 reads SD SDHC
     
    Last edited by robyspy, Nov 30, 2018
  12. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    21
    Oct 27, 2002
    France
    Engine room, learning
    system menu version is only relevant when using the system menu. (SD menu, managing channels or savegames, etc.)

    The homebrew channel doesn't rely on the system menu's version, it has its own SD card driver.
    be sure it's SD or SDHC, not SDXC. (though, it might work too. Or maybe only WiiU is compatible with XC cards)

    if it's not SDXC, and it's correctly using FAT32, it's either a file system issue (wrong location, folder, etc.), or the card is not compatible, but it's very strange. maybe it's a fake SD?
     
    Last edited by Cyan, Nov 30, 2018
  13. Illuminaticy

    Illuminaticy GBAtemp Fan

    Member
    4
    Oct 6, 2018
    United States
    System menu version doesn't matter for homebrew channel. His SD is fake, not compatible, or he has wrong file paths.
    Edit: Cyan already said what I said, just faster then me lol.
     
    Cyan likes this.
  14. Oui
    OP

    Oui Member

    Newcomer
    1
    Feb 14, 2017
    Switzerland
    Geneva
    i actually said that my old SD doesn't work anymore... thus i think it is a problem with my files, but they seem to be correct (SD/apps/[...])

    i really doubt it's fake... and i'm pretty sure my file paths are correct
     
  15. Illuminaticy

    Illuminaticy GBAtemp Fan

    Member
    4
    Oct 6, 2018
    United States
    Does it show on the wii system menu?
    The only things you can do; Format again, add ONE thing into /apps. Try BOTH SD cards. Reset wii. Reinstall homebrew channel. Test with a USB device.
     
  16. Oui
    OP

    Oui Member

    Newcomer
    1
    Feb 14, 2017
    Switzerland
    Geneva
    so i've tried to add only one app first and it worked ! then i added all my other apps and everything went fine :)
    thanks for your help and for your time !
     
    Illuminaticy and Cyan like this.
  17. Illuminaticy

    Illuminaticy GBAtemp Fan

    Member
    4
    Oct 6, 2018
    United States
    Weird, glad it worked! Enjoy!
     
Loading...