Multiple Partition problems with NAND emu

Discussion in 'Wii - Hacking' started by kukupo, Dec 15, 2009.

  1. kukupo
    OP

    kukupo Member

    Newcomer
    39
    0
    Sep 30, 2008
    United States
    So I've been trying to get both NAND emu and USB loader to run off the same HDD for a while now and I never managed to get it to work.

    I have a Seagate 500GB External HDD (according to the compad list should work) which has three partitions. One is formatted to NTFS for regular use, one is formatted to WBFS for USB Loader use, and one is formatted to FAT32 for NAND use. At the moment the thing that works is the NTFS and the WBFS partitions. The NAND on the other hand never worked even once no matter how much I tried it.

    I dumped my NAND using SimpleFS 0.2 and moved all 8 folders into the root of my NAND drive. I then set the partition as ACTIVE on windows disk management. However, whenever I use WAD manager 1.5 to install anything onto the NAND I get a error ret -1. I can never get pass this part no matter what I try.

    Also while using Triiforce it gives me this

    reading folder /title/00010001 failed
    error getting the title list

    Then a code dump.

    I ran out of ideas what I can do so can anyone help me out?

    (The NAND dump is good cause this works on my flash drive but I want to be able to run everything off my HDD. Also wad2nand will not work because I can't access the usb anyways using Triiforce. Also I am running cIOS38 rev 14)


    I fixed my problem, all I had to do was mount the usb HDD using a seconary app (in my case NeoGamma). After doing that and going back to Triiforce, it can finally detect the FAT32 partition. The only problem is I can't install using WAD manager so I used Showmiiwad instead. If anyone know a way so I don't have to mount the USB HDD everytime let me know.
     
  2. kukupo
    OP

    kukupo Member

    Newcomer
    39
    0
    Sep 30, 2008
    United States
    BUMP
     
  3. abel009

    abel009 GBAtemp Regular

    Member
    253
    9
    Nov 24, 2008
    Mexico
    dude i have the same problem, but i i can't get it to work [​IMG] [​IMG] [​IMG]
     
  4. kukupo
    OP

    kukupo Member

    Newcomer
    39
    0
    Sep 30, 2008
    United States
    Well after over 2 weeks of trying I finally found a way for this to work. For some reason the only way I got it to detect the FAT32 partition was after I mounted the USB drive. (I actually went back to Wii Menu after loading a game from the USB using NeoGamma) After that I just decided to run Triiforce for the heck of it and amazingly it worked. However, the only way I can get VC/Wiiware to work is by using wad2nand. (WAD manager doesn't work still) Does anyone know a way so I can run it without having to mount the USB everytime?
     
  5. Skizzo

    Skizzo Banned

    Banned
    475
    0
    May 1, 2009
    United States
    Are the partitions in the order you listed? If so, you could try making the first partition FAT32 (and ACTIVE of course).

    Any reason why you aren't using cIOS rev15?
     
  6. rAiN mAn 2o0o

    rAiN mAn 2o0o GBAtemp Regular

    Member
    179
    0
    Apr 21, 2009
    United States
    I have the same problem.. here is my setup...
    cIOS38 rev15
    80 gb haddrive with 4gb fat32 partition at end of drive.. rest of drive is WBFS
    sdfs usb version fails
    use sdfs sd version... then copied ripped NAND from sd to HD (with a lil help from pc)

    wad manager 1.5 mod fails
    triforce mrc fails
    even FTPii .19 fails!

    have tried diff hard drives with same result. location of the fat32 partition does not seem to matter either.

    RESULT: IT doesn't work when you have multiple partitions of wbfs and fat32. I got tired of foolin around with it... maybe I will mess around with it some more if sNEEK ever comes out.

    if anybody has any pointers... feel free to enlighten me
     
  7. bazamuffin

    bazamuffin RESIDENT DILF

    Member
    2,036
    63
    Feb 1, 2009
    Shmashmortion Clinic
  8. abel009

    abel009 GBAtemp Regular

    Member
    253
    9
    Nov 24, 2008
    Mexico
    help plz