Moving from menuhax to arm9loaderhax. I have few questions.

Discussion in '3DS - Homebrew Development and Emulators' started by Bros.Life, Feb 12, 2017.

  1. Bros.Life
    OP

    Bros.Life GBAtemp Regular

    Member
    181
    20
    Apr 12, 2015
    United States
    Hi guys!

    I have a New3DS with SysNand at 9.2 with menuhax and EmuNand at 11.2. I'm considering move to ARM9LH. However, I'm bit confused.

    1) Do I need just to follow this guide? https://3ds.guide/installing-arm9loaderhax

    2) Do I need to delete something from my SDCard (menuhax files) before starting?

    3) I don't need put my SysNand at 11.2 to use the newest arm9loaderhax method, right?

    4) Is there any chance of bricking? I mean, not by mistakes, but for the system itself. Is it chance bigger than downgrading, for example?

    Thanks a lot guys!
     
  2. Exavold

    Exavold GBAtemp Advanced Fan

    Member
    996
    1,055
    Nov 9, 2015
    France
    .
     
    Last edited by Exavold, Feb 12, 2017
  3. addi33

    addi33 GBAtemp Advanced Maniac

    Member
    1,659
    714
    Sep 12, 2016
    Gambia, The
    wrong he has to start from the beginning of 3ds.guide
     
    Exavold likes this.
  4. sprong

    sprong Member

    Newcomer
    37
    6
    Jul 30, 2007
    United States
    follow 3ds guide, it has a section towards the end for people with pre existing emunand. just make sure before you start following the guide that you delete your menuhax by changing your theme on your sysnand.
     
  5. Dracari

    Dracari GBAtemp Maniac

    Member
    1,405
    387
    Apr 5, 2009
    United States
    *shakes head start from the beginning juste because your on 9.2 doesnt mean you can skip anything, you need to start at the beginning to downgrade to 2.1 to get your OTP and then install A9LH. as long you follow closely and dont try to take shortcuts your fine.
     
  6. Bros.Life
    OP

    Bros.Life GBAtemp Regular

    Member
    181
    20
    Apr 12, 2015
    United States
    I didn't try to take shortcuts. I misunderstood. I thought I could start from that part.

    Why I cannot downgrade the EmuNand instead of SysNand to get the OTP file? One is copy of the other, it should work, no?
     
  7. Dracari

    Dracari GBAtemp Maniac

    Member
    1,405
    387
    Apr 5, 2009
    United States
    its been explained why in the past but i cannot remember Why but what we'd get from Emunand is no good.
     
  8. Bros.Life
    OP

    Bros.Life GBAtemp Regular

    Member
    181
    20
    Apr 12, 2015
    United States
  9. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    The OTP gets locked very early on in boot. Below 3.0, it does not get locked, so we can access it on sysNAND. If you boot a firmware below 3.0 in emuNAND, the system has already gone through boot up (on the updated sysNAND) and locked the OTP. Getting it on emuNAND does not work because sysNAND will already have booted and locked it.
     
  10. Bros.Life
    OP

    Bros.Life GBAtemp Regular

    Member
    181
    20
    Apr 12, 2015
    United States
    Thanks for your explanation! My question now is about the SafeA9LHInstaller.
    I'm confused because someone has helped my brother yesterday to upgrade his N3DS from menuhax to A9LH. I asked him for the steps he did , and it seems he didn't go to 2.1 to get the OTP. He just launched SafeA9LHInstaller on SysNand, and after restored the EmuNand to SysNand.

    That's because I'm confused.
     
  11. Quantumcat

    Quantumcat Dead and alive

    Member
    10,520
    5,553
    Nov 23, 2014
    Australia
    Canberra, Australia
    He must have had a9lh already and was updating it.
     
  12. HexOverflow

    HexOverflow GBAtemp Meme Lord

    Member
    121
    152
    Jan 12, 2017
    United States
    Userland
    Just follow the guide and you'll be ok and listen to what it says like "dont put your 3ds to sleep on 2.1 if you use a n3ds"
     
  13. Bros.Life
    OP

    Bros.Life GBAtemp Regular

    Member
    181
    20
    Apr 12, 2015
    United States
    If he had, he wasn't using. Because he had EmuNand.

    Yeah, you're right. I know. It's just because I like to understand what I'm doing.