Hacking Most NSPs random freeze

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
Hello everybody.
I recently bought an unpatched switch model and proceed with creating an emunand and install atmosphere (1.3.2)
I'm on firmware 14.1.1
Last sigpatches installed, the CFW runs fine.
I've got a problem with NSPs though; (files are from a reliable source and the SD is not a fake one)
When playing with some games (Botw, Mario, ecc) after some times the game freeze and the famous message "software was closed because an error occurred" appears.
From that point on, I can try launch the game again multiple times but it will always freeze no later then couple of minutes, sometimes reportin the corrupted data error (checking for corrupted data reports no corrupted data found).
The only way to "fix" it and play again is by turn the switch off and do RCM+fusee injection again.

Anyone can help with this?

Thanks!
 

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
Hello everybody.
I recently bought an unpatched switch model and proceed with creating an emunand and install atmosphere (1.3.2)
I'm on firmware 14.1.1
Last sigpatches installed, the CFW runs fine.
I've got a problem with NSPs though; (files are from a reliable source and the SD is not a fake one)
When playing with some games (Botw, Mario, ecc) after some times the game freeze and the famous message "software was closed because an error occurred" appears.
From that point on, I can try launch the game again multiple times but it will always freeze no later then couple of minutes, sometimes reportin the corrupted data error (checking for corrupted data reports no corrupted data found).
The only way to "fix" it and play again is by turn the switch off and do RCM+fusee injection again.

Anyone can help with this?

Thanks!
No one?
 

pinbi7

Well-Known Member
Member
Joined
Apr 4, 2004
Messages
553
Trophies
0
XP
1,704
Country
Canada
it's hard to tell ,have you tried a different set-up? do original games do the same thing? have you tried xcis? or nsz?
 

Omegapsy

Well-Known Member
Member
Joined
Feb 20, 2012
Messages
121
Trophies
0
XP
547
Country
United States
It sounds like you have a dying SD card. At least that was the culprit for me when I dealt with this. Just get a new card and start over. If that doesn't solve your issue then you probably have much bigger issues at hand.
 

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
It sounds like you have a dying SD card. At least that was the culprit for me when I dealt with this. Just get a new card and start over. If that doesn't solve your issue then you probably have much bigger issues at hand.
I'm sure is not the SD card..
I'm starting to think it's the CPU =(
 

Rikua

Well-Known Member
Member
Joined
Dec 2, 2014
Messages
201
Trophies
0
Age
34
XP
1,541
Country
United States
I'm sure is not the SD card..
I'm starting to think it's the CPU =(
Unless you've ran your SD through h2testw, do not be so sure its not the SD card. I bought an SD off of Amazon that looked and acted 100% legit, don't know if it was a fake or it just failed within the week I owned it, but h2testw showed me the truth. If it were a CPU crash, I'd imagine the whole system would shutdown, but I could be wrong.

EDIT: I should note that my switch was doing the exact thing yours is doing but on 12x firmware. Changing to a new SD solved my issues.
 
  • Like
Reactions: PREO and impeeza

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
Unless you've ran your SD through h2testw, do not be so sure its not the SD card. I bought an SD off of Amazon that looked and acted 100% legit, don't know if it was a fake or it just failed within the week I owned it, but h2testw showed me the truth. If it were a CPU crash, I'd imagine the whole system would shutdown, but I could be wrong.

EDIT: I should note that my switch was doing the exact thing yours is doing but on 12x firmware. Changing to a new SD solved my issues.
I will try h2testw
To do a backup of the SD, can I just copy everything in it on a PC or should I use some specific app?
 

randy_w

Well-Known Member
Member
Joined
Feb 27, 2021
Messages
347
Trophies
0
Age
32
XP
713
Country
United States
if it's partition based emummc you need to back up the emummc partition with hekate and copy everything on fat32 partition to pc, then repartition the card and test it with h2testw for corruptions.
 

impeeza

¡Kabito!
Member
Joined
Apr 5, 2011
Messages
1,856
Trophies
1
Age
44
XP
3,165
Country
Colombia
if it's partition based emummc you need to back up the emummc partition with hekate and copy everything on fat32 partition to pc, then repartition the card and test it with h2testw for corruptions.
You also can use emutool for windows to backup a raw partition emuNAND, or dd on linux
 

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
Ok guys,
I've tried a few experiments and I can tell you this:

- it's not a ìn SD issue, even with no SD in, the original cartridge of BOTW (a working one, run smooth on a second Nintendo Switch) crashes after some time
- it's not an overheating problem, I played the BOTW cartridge for about 15 min, then put the switch in sleep mode for a whole day to let it cool down, and then - after 5 or 6 min - the game closed because an error occured (the switch was cold as hell). Same error of the NSP on the emunand and same behaviour of the Switch afterward.
 

Kouta928

Member
Newcomer
Joined
Feb 20, 2021
Messages
11
Trophies
0
Age
29
XP
117
Country
Brazil
Try updating atmosphere or using a different kind of set up, did you test the original game with the system booted into the original firmware to see if it still happens? I've had some strange problems before that was fixed with a simple cfw update. Btw, do you have the backup of the original nand? That might save you if nothing else does, once I installed android on my switch and after a while using it, something went quite wrong and corrupted a lot of files but the nand backup saved my ass
 

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
Try updating atmosphere or using a different kind of set up, did you test the original game with the system booted into the original firmware to see if it still happens? I've had some strange problems before that was fixed with a simple cfw update. Btw, do you have the backup of the original nand? That might save you if nothing else does, once I installed android on my switch and after a while using it, something went quite wrong and corrupted a lot of files but the nand backup saved my ass
the problem manifest also on OFW switch with no SD inserted (so no ATMO nor anything) with an original cartridge
 

Zkajavier

Well-Known Member
Member
Joined
Sep 13, 2009
Messages
334
Trophies
0
XP
1,146
Country
Costa Rica
If you have a separate Sysnand, with no CFW, where this is happening as well. This can be a problem with the Emmc. Your console storage might be dying and might need physical repairing.

If it's only when there is CFW, then it sounds like a sysmodule is crashing and causing games to crash. Maybe remove/disable them all and try again? SaltyNX can sometimes get wonky if not updated/installed right for instance.
 

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
If you have a separate Sysnand, with no CFW, where this is happening as well. This can be a problem with the Emmc. Your console storage might be dying and might need physical repairing.

If it's only when there is CFW, then it sounds like a sysmodule is crashing and causing games to crash. Maybe remove/disable them all and try again? SaltyNX can sometimes get wonky if not updated/installed right for instance.
That's the first one for sure
the problem is I can't ship it to Nintendo for repairs because they'll just replace it with a non software hackable one
and not knowing exactly what is the damaged part, I cannot do the repai myself / give it to someone =(
 

randy_w

Well-Known Member
Member
Joined
Feb 27, 2021
Messages
347
Trophies
0
Age
32
XP
713
Country
United States
Have you tried to initialize the console? Also try to update to latest firmware.
I once worked on a weird oled console which won't enter OFW at all, always hang at switch boot logo. Even if it enters system, I can't really do anything as it will just throw me an error and ask me to reboot. Did a system initialization in maintenance mode and it's good as new.
Doubt it's an emmc issue, but you can check your emmc life in hekate, go to console info - emmc. You can see the estimated life and reserved use data.
Also can you try another less demanding game? If it only freezes in demanding games like zelda, then it's 100% a hardware issue.
 
  • Like
Reactions: PREO

PREO

Member
OP
Newcomer
Joined
May 15, 2022
Messages
13
Trophies
0
Age
32
Location
Italy
XP
17
Country
Italy
Have you tried to initialize the console? Also try to update to latest firmware.
I once worked on a weird oled console which won't enter OFW at all, always hang at switch boot logo. Even if it enters system, I can't really do anything as it will just throw me an error and ask me to reboot. Did a system initialization in maintenance mode and it's good as new.
Doubt it's an emmc issue, but you can check your emmc life in hekate, go to console info - emmc. You can see the estimated life and reserved use data.
Also can you try another less demanding game? If it only freezes in demanding games like zelda, then it's 100% a hardware issue.
I did initialize the console and the last firmware is on.
Tried a couple f less demanding games (e.g. Diablo III on cartridge on OFW without SD card inserted and THPS 1+2 NSP on cfw) and both of these run without crashes
Tried also Fall guys and it crashes

Any idea on what chip / part could be responsible for this behaviour?
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: Did someone mention me? I r troll! Lol