Monkey Island 1 repeatable crash

Discussion in 'Wii - Hacking' started by Pho8, Jul 21, 2008.

  1. Pho8
    OP

    Pho8 Member

    Newcomer
    21
    0
    Jul 21, 2008
    United States
    When entering the "fork" (the one with the Sword Master) I get booted back to the HBC's main screen. Anyone else having this issue or know how to fix it? Even stranger, I can follow the shopkeeper all the way to the Sword Master, but if I go in any other time then it crashes. After a long time searching I've found that other people experience crashes at two other spots, but no mention of this one. Which leads me to an even more important question. Can MI1 be ran on the Wii without crashing?

    I've tried the latest ScummVM (rev 33083) and also the older version from the Homebrew Browser (rev 32565) and they both crash at the same place.

    Bonus question: Why does the Homebrew Browser say I can update ScummVM to 32565 when I currently have 33083?
     
  2. Neversoft

    Neversoft GBAtemp Regular

    Member
    236
    3
    Aug 25, 2006
    Could be a bug in the port of ScummVM, the Wii version isn't officially adopted yet although there is a forum for it on the official site: http://forums.scummvm.org/viewforum.php?f=16

    It might also be worth grabbing ScummVM for the PC and testing the dump that you're using, in case it isn't a bug in the port.

    Bonus answer: Because the HBB is manually updated by the author instead of it being dynamic, so he probably hasn't spotted the update. It's also a bit flaky at spotting pre-installed apps in the homebrew folder.

    Do I win a prize? [​IMG]



    ::EDIT:: Now I REALLY want a prize [​IMG] http://forums.scummvm.org/viewtopic.php?t=5811
     
  3. Arm73

    Arm73 GBAtemp Addict

    Member
    2,042
    224
    Mar 4, 2006
    Italy
    Switzerland
    I don't know about this, but I had a similar problem with Broken Sword II, in fact upon leaving a certain are the game would crush and bring me back to the homebrew channel.
    What I did it's a workaround (until an update comes along which solves the problem), basically I saved just before the point in question, and I transferred that save to my PC, continuead from there with ScummVM for the PC ( the save files are interchangeable),saved right after and went back to the Wii.
    I know it's not pratical but at least it's a solution.
    I assume being Monkey Island playable on the DS build you could do the same with the DS.
    At least you'll be able to proceed.......
     
  4. Pho8
    OP

    Pho8 Member

    Newcomer
    21
    0
    Jul 21, 2008
    United States
    Those are the two crashes I mentioned reading about in the OP. Strange thing about those two crashes is, mine didn't crash at the tent cutscene. I haven't gotten far enough to see about the other one.
     
  5. Pho8
    OP

    Pho8 Member

    Newcomer
    21
    0
    Jul 21, 2008
    United States
    Update for anyone interested:

    I went through the whole game with rev 33083 and it only crashed when entering the "fork". Nowhere else. Swapping to the PC did work to get around it though.

    Thanks for your help Neversoft and ARM73.
     
  6. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    Odd.... I'm playing Monkey Island too and was able to play past that point.

    Try changing the config, I changed mine before playing and it hasn't crashed at all.
     
  7. Pho8
    OP

    Pho8 Member

    Newcomer
    21
    0
    Jul 21, 2008
    United States
    In the name of research (and because it's accesible at the beginning of the game) I'd give it a shot. What config changes would you be referring too?
     
  8. dread123

    dread123 GBAtemp Regular

    Member
    130
    0
    Dec 9, 2006
    manchester uk
    wii version has been officially ported and supported for a little while now mate, at least since the last revision [​IMG]
     
  9. teq

    teq GBAtemp Maniac

    Member
    1,232
    0
    May 13, 2008
    United States
    Basically change all of the options to the optimum setting.

    ie: Render mode set to Wii, Audio set to 48khz output, etc.
     
  10. Pho8
    OP

    Pho8 Member

    Newcomer
    21
    0
    Jul 21, 2008
    United States
    I changed the render mode to wii and the audio to 48khz but still get booted to the HBC when entering the fork. As I'm the only one who seems to have an issue at that spot I suppose it could just be written off as an anomaly for now.