?
  1. Yes!

    755 vote(s)
    82.5%
  2. No, and I won't report what went wrong because I am a troll

    54 vote(s)
    5.9%
  3. No, and I posted what went wrong

    106 vote(s)
    11.6%
  4. 915 voter(s)
  1. JoostinOnline

    JoostinOnline Certified Crash Test Dummy
    Member

    Joined:
    Apr 2, 2011
    Messages:
    11,002
    Country:
    United States
    You know quite well that 4.2+ kills certain kinds of homebrew. I'm not getting into this with you again.
     
  2. tueidj

    tueidj I R Expert
    Member

    Joined:
    Jan 8, 2009
    Messages:
    2,569
    Country:
    No, I don't know. 4.2+ kills the twilight hack and DVDX which are both redundant, what other homebrew are you talking about?
     
  3. DeadlyFoez

    DeadlyFoez XFlak Fanboy
    Banned

    Joined:
    Apr 12, 2009
    Messages:
    5,920
    Country:
    United States
    I think joostin is referring to the extra region checks, but I would not see how that would affect homebrew anyways because all channels for homebrew that I have seen are always region free anyways. I personally have always seen that as an argument to stay on 4.1 as being a rather moot point.
     
  4. Colabear

    Colabear Member
    Newcomer

    Joined:
    Sep 12, 2009
    Messages:
    28
    Country:
    United States
    After updating to 4.7.1, I can no longer run the program. When I click on the icon for ModMii, it opens my text editor and shows the file name as ModMii.bat. I did not have this problem before updating. Do I need to compile the new version or something before I can execute it?

    I am on Windows 7.
     
  5. Hielkenator

    Hielkenator GBAtemp Psycho!
    Member

    Joined:
    Feb 7, 2010
    Messages:
    4,210
    Country:
    Netherlands
    Building a forwarder.dol and not specifying the 3rd path and pressing enter results in Modmii shutting down without warning...

    BTW Dutch translation is a bit slow at the moment...Hope to have it up to date by next week..
     
  6. XFlak

    OP XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,777
    Country:
    Canada
    sounds like you have your windows configured to open batch files in notepad instead of running them

    on windows 7 go to:
    Control Panel\All Control Panel Items\Default Programs\Set Associations
    look for ".bat", what does it say?

    a solution for a similar situation was posted here:
    http://www.sevenforums.com/general-discuss...html#post494232

    Download and run the reg file and reboot, then it should work.
     
  7. XFlak

    OP XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,777
    Country:
    Canada
    it wasn't just the 3rd path, it was any path. Thanks for reporting this problem, it's fixed in v4.7.2 beta (as well as one other small bug brausm08 discovered). I plan on adding one new feature to v4.7.2 before releasing it... so prolly < 1 week (2 weeks tops)
     
  8. Hielkenator

    Hielkenator GBAtemp Psycho!
    Member

    Joined:
    Feb 7, 2010
    Messages:
    4,210
    Country:
    Netherlands
    Cool, I'll try to keep up with you then! lol!
     
  9. Digital1980

    Digital1980 GBAtemp Fan
    Member

    Joined:
    Jan 8, 2008
    Messages:
    499
    Country:
    United States
    WoW! XFlak, this is AMAZING work!


    everything is working great so far except when I set the theme Uneek DI with your setup wizard it does not show when i load uneek, did I miss a step?

    So far everything else seems to be working, switch2uneek is nice!!
     
  10. Colabear

    Colabear Member
    Newcomer

    Joined:
    Sep 12, 2009
    Messages:
    28
    Country:
    United States
    You were correct; the association was set to .bat.

    The solution offered did not work for me. It gave an error saying some items could not be loaded or moved. It's all good thou as you pointed me in the right direction and I was able to find the reg patch file I needed on the MS knowledge page for windows 7 file association issues. It is back up and running now.

    Thanks again for your help and this great program.
     
  11. XFlak

    OP XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,777
    Country:
    Canada
    r u saying the theme was not installed to your emulated nand when you selected one?
    Can u tell me what steps reproduce the error and I'll look into it

    @Colabear, can u link to the page with the working reg patch in case others ever need to fix a similar problem? thx!
     
  12. Colabear

    Colabear Member
    Newcomer

    Joined:
    Sep 12, 2009
    Messages:
    28
    Country:
    United States
  13. Digital1980

    Digital1980 GBAtemp Fan
    Member

    Joined:
    Jan 8, 2008
    Messages:
    499
    Country:
    United States
     
  14. XFlak

    OP XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,777
    Country:
    Canada
    whoa, u saying u are having to manually use the sneek installer? ModMii should be use autoit to do all that stuff automatically. Not sure if I'm understanding this right. Anyways, everything is working for me on this end. Can u try performing windows updates then try again?
     
  15. Usuario-X

    Usuario-X Advanced Member
    Newcomer

    Joined:
    Nov 25, 2010
    Messages:
    56
    Country:
    United States
    Howdy XFlak
    Thank you for the new release 4.7.1

    Unfortunelly, I have a bug report.
    Running XP, when I launch modmii.exe a system error window appears telling it doesn't know what program to execute modmii.lnk.
    A workaround for this is to copy modmii.bat to the same folder as modmii.exe.

    Out of curiosity, what are you using to convert the batch file to .exe?
    If upx was causing the false alarms, why did you keep compressing the modmii.exe using it? - Here's a tip. Some av detects the upx signature in the executable and tags it as virus. Simple solution. Edit the upx0 and upx1 section names to wii0 and wii1 for example.

    Good luck on that [​IMG]
    and by the way, since your batch file is public now, you better hide well the easter egg [​IMG]

    A sugestion here..
    Add a way to add custom wads to the copy_to_sd_\wad folder. For example if a wad file exist in "cwad" folder it will be copied to the copy_to_sd\wad folder. I keep using uloader and I have to manually copy it everytime I mod a wii.

    Once again, thank you for the new release.
     
  16. ChrisLuther

    ChrisLuther Member
    Newcomer

    Joined:
    Sep 28, 2010
    Messages:
    40
    Country:
    I would have to say the batch file is no more public than it was before. The only difference now is that it is in the support folder rather than the users temp folder. I would suspect that a lot of users will just use the .exe file and won't care about any of the other files/folders.

    I would imagine than if anybody had really looked before they would have found the batch file with ease.

    Seeing the batch file for myself did take me back to the days of DOS though.

    I don't know if it's just happening to me but I can't build themes anymore.
    Using 4.7.0 I can build both the Red and Green themes. Using 4.7.1. I can't build any. It fails the MD5 checksum.

    Been through the batch file and changed the commands so I can see what's happening. It seems to download all the parts fine and then builds the theme fine but then just retries, then after retrying gives up and skips the download.
     
  17. temp4746

    temp4746 Advanced Member
    Newcomer

    Joined:
    Apr 5, 2009
    Messages:
    84
    Country:
    Iceland
    ModMii version 4.7.1 is downloading Configurable USB Loader badly, the usb-loader folder is all messed up, the files in this folder seem to get extracted in a flat fashion meaning that all the files and folder are in the root of the usb-loader folder for example all the theme folder are at usb-loader/%themename% instead of usb-loader/themes/%themename% and all their graphics files are at the root of the usb-loader directory likly overwriting each other.

    BTW, the credits screen is awful I can't belive you did something like, heck it's one of the worst nag screens I have seen ever simply for the amount of time it takes to get through it. Having to constantly wait to press Enter and the large amount of screens ridiculous! This is not the way to get people to donate. It will likly convince people to not donate due to how evil this nag screen is.

    Stll thanks for this tool it helped me mod my wii alot. now if you can only fix the usb loader thing so I can set up usb loading on my wii.

    EDIT: Also how would one go about updating CFG using ModMii? (Once that bug is fixed)
     
  18. ChrisLuther

    ChrisLuther Member
    Newcomer

    Joined:
    Sep 28, 2010
    Messages:
    40
    Country:
    Any new versions should be downloaded when you run the USB loader wizard again. Are you aware that CFG has a built in update program? You'll need to be connected to the internet.
     
  19. XFlak

    OP XFlak Wiitired but still kicking
    Member

    Joined:
    Sep 12, 2009
    Messages:
    10,777
    Country:
    Canada
    From v4.5.5 Changelog
    [*]After verifying downloads, if a "CUSTOM_COPY_TO_SD" or a "CUSTOM_COPY_TO_USB"
    folder is detected where ModMii.exe is saved, users will have the option to
    copy the contents of the folder to its respective device. This is useful for
    more advanced users who want to customize and automate how ModMii configures
    their devices by quickly copying over additional apps, wads, or other files.

    One of these days I'm gonna have to create a massive read me file with all of ModMii's random features, lol.


    @temp4746,
    I'll look into the cfg usb-loader problem, thx for reporting it. And you are welcome to share your opinion on the credits, but don't expect to make me regret my decision. It's 45 seconds to get through it, if you don't like it, hit enter a bunch of times and go grab a coffee, when you get back the credits will be finished. Besides, for too long I've felt like a lot of people give me all the credit for what ModMii can do, the main reason for this change was to give credit where credit is due. And if you think this act is discouraging donations, I have concrete numbers that show the opposite trend. Since the change, I have been getting a lot of $1 donations ($0.66 after paypal fees) and a few donations for larger amounts too (before this change I was getting almost no donations, probably 5-10 in 1.5 yrs). I hope that others in my credits have noticed a spike in the frequency of their donations too. If you want to read more arguments supporting this decision, try reading the last few pages of this thread. You'll see that there are more ppl voicing their support of this change than those upset like yourself. I really don't want to start repeating myself, but I will if I have to... but I'd say the best argument is I (and others on my credits list) have spent thousands of hours to make your life easier, the least you can do is spend a minimum of 45 seconds reading my credits. If you don't like it, $1 is not a lot to pay to avoid seeing the credits. Besides, if u read the 4.7.0 changelog, you'll see I made a lot of changes to speed up cIOS creation... so your downloads probably finish a couple of minutes quicker despite having to wait 45 seconds to see the download log. Anyways, you're one of the few people upset with this change, and even you are waiting for a ModMii update so you can continue using it... to me that shows that even those most upset about the change will continue to use ModMii... so in a way, u r encouraging me [​IMG]
     
  20. temp4746

    temp4746 Advanced Member
    Newcomer

    Joined:
    Apr 5, 2009
    Messages:
    84
    Country:
    Iceland
    Ok fine I guess I can live with the credits screen but just so you know, when I tried pressing enter a log of times when I tried the use loader wizard it hit enter on the final download log page and returned to the first page of the credits.

    BTW which hermes cios that ModMii generates should I use for guitar hero games when using USB Loading?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Official, Windows, Support