Model dumping question [Emulator related]

Discussion in 'PSP - Hacking & Homebrew' started by Dan_Tsukasa, Mar 1, 2015.

  1. Dan_Tsukasa
    OP

    Dan_Tsukasa GBAtemp Regular

    Member
    171
    41
    Oct 14, 2014
    Tokyo Japan
    Hey Guys.

    So, the PSP section of the forum doesn't appear to have an emulators section like the other sections do, so excuse me if this isn't the best place.

    As some of you might know, JPCSP has a dump to OBJ feature, which from my understanding appears to be a port of Lamb, a model dumped somebody wrote a long time ago for the PSP.

    There were various issues with Lamb, its dumping wasn't too reliable, some games it grabs everything, another time it'll grab nothing, little consistency but apparently it worked eventually.

    JPCSPs OBJ dumping feature has the same issues, some games it won't dump anything at all, even if the games are in 3D. For example the Kiseki series, or the trials in the sky series. Nothing gets dumped from these for some reason.

    So I thought I'd try PPSSPP with NinjaRipper, which has never failed me in the past, but once again these games nothing gets dumped at all, just an empty obj file and textures (so at least I know it is reading it correctly), this happens regardless of the settings.

    Just to point out, I have tried the DX9 PPSSPP backend, I'm not accidentally trying it in OGL constantly.

    Would anyone be able to explain why this is, what is it about those games that causes this to happen but work fine in other games?

    At first I thought 'well perhaps the models aren't really modelled at all and its not 3D' so I took apart the files from Ao no Kiseki and saw the .msq files (metaseqioa), these open with no problems at all and are in full 3d, so this confirms its not just a strange rendering trick or anything and that the models really are 3d and not faked.

    I'm really curious as to why this is, is it something to do with the way the models are written to RAM, as I assume both JPCSP and PPSSPP + Ninja Ripper simply rip based on the current frame in RAM.