Modded PAL PS1 plays NTSC games with weird rainbow colours.

Discussion in 'Sony PlayStation 1 & 2' started by ZeroInfinity, Jul 23, 2017.

  1. ZeroInfinity
    OP

    ZeroInfinity Member

    Newcomer
    10
    0
    Mar 27, 2016
    Australia
    So, yeah, my modded SCPH-1002 PS1 plays NTSC games with what I can only describe as a rainbow gradient across the screen, along with the colours just generally being f***ed up:
    Pictures
    My TV is picking it up us an NTSC signal. So I guess the PS1 is trying to output NTSC? But just... in rainbow? Could it be something to do with the modchip?
    Now, I was mostly content using a bootdisc to play my imports. But I was just curious, is there some kind of fix for this? It would be convenient to not have to use the bootdisc every time I want to play a game and it would be nice to have the games playing at NTSC speed (although, this doesn't bug me too much.)
    Just as long as the solution isn't a pain in the ass.
     
  2. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,956
    Jun 9, 2007
    Antarctica
  3. ZeroInfinity
    OP

    ZeroInfinity Member

    Newcomer
    10
    0
    Mar 27, 2016
    Australia
    It's connected with AV cables.
    I'm not able to use a SCART cable. None of my TVs have a SCART port. I don't think I've even ever come across a TV with a SCART port. They're pretty uncommon in Australia for some reason.
    It looks like it isn't going to be a simple fix... Oh well. I guess I might just have to stick with using my bootdisc.
     
  4. ZeroInfinity
    OP

    ZeroInfinity Member

    Newcomer
    10
    0
    Mar 27, 2016
    Australia
    Wait a minute. I just realized something. On my old TV my PS1 played NTSC games in black and white. When I tried to find a fix to make the games play in colour, one of the solutions was to use the console on a HD TV, since HD TVs can accept both PAL and NTSC signals, or something like that, which my old TV couldn't... If that makes sense... I'm bad a explaning s**t. I could be remembering wrong.
    Since I'm using a HD TV now... shouldn't there be no issues playing NTSC games in proper colour? I get the felling it is something to do with the mod chip...