WIP Modchip Software: Simple-UF2 with SWITCHBOOT. Save fuses without AutoRCM

Discussion in 'Switch - Backup Loaders & Modchips' started by mattytrog, Dec 18, 2018.

  1. Sasori

    Sasori GBAtemp Addict

    Member
    9
    Jan 28, 2015
    United States
    I installed this months ago before you redid this thread. Iirc it was the old method 2

    It seems to boot successfully when I put my tx dongle in which is odd. The trinket flashes twice than and goes to hekate
     
  2. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    OK. What version are you using?

    For old method 2 (I thought I`d successfully buried that), use Trinket_method 3 asnd let me know what happens. I`d advise changing your chip wiring. Old method 2 is severely outdated now. Things have moved on to better ways of doing it :)
     
  3. Sasori

    Sasori GBAtemp Addict

    Member
    9
    Jan 28, 2015
    United States
    How would I check what version I’m using? Like i said it’s been months since I’ve touched this aha

    It may have been method 1 but It’s been so long. I am still using Auto RCM which I’m happy to see really isn’t needed anymore!

    — Posts automatically merged - Please don't double post! —

    Alright to make matters weirder once my switch charged up a bit (about 20%) it’s functioning again..at least it’s working
     
    mattytrog likes this.
  4. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Method 1 with autoRCM... I would say you don`t have any straps fitted. That limits your options.

    Boot to OFW or CFW, double-press reset, plug into PC so trinketboot pops up...

    In theory, any Trinket version should do it. Use a method 3 (mine or legacy) file.

    If it boots to Hekate with no SD inserted, then it flashed correctly. If your payload.bin refuses to boot, then that is a problem with that payload.bin.

    I`m thinking your chip isn`t being updated correctly. Double-check your download is OK.
     
  5. josete2k

    josete2k GBAtemp Regular

    Member
    3
    Apr 24, 2009
    New 0.9.4 tested on RCM-X86 dual boot.

    Before, if I had the switch docked and I powered up with POWER and VOL+ it was in RCM forever.

    Now, if I pull off the console from the dock, it autolaunchs my payload.bin form SD (or hekate if sd is not presento, of course).

    I think this is the new feature and it's working as espected, isn't it?


    Just one question, what's the case that the modchip will make a safe shutdown instead of a payload injection?
     
    Last edited by josete2k, Jan 10, 2019
  6. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    That is the idea, yes. The aim is preventing RCM when we don't want it.
    Very strange though reading your post...
    Dual boot users are or should be unaffected. It will boot and reboot just the same as a stock console.

    If you haven't got the vol+ strap fitted, it shouldn't boot to RCM. As in dual boot.

    Something not making sense to me there sir!
     
  7. josete2k

    josete2k GBAtemp Regular

    Member
    3
    Apr 24, 2009
    Vol+ and POWER make the console to enter in RCM mode in the dual boot MODE. Same as the full install (the autorcm by hardware)



    Before if I had the console fitted in the dock:

    -Normal boot ok.

    -VOL+ and POWER make to enter in RCM mode and even if release the dock I needed to launch a payload (or press 15 seconds power in order to shutdown the system).


    Now this issue is fixed.
     
  8. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Ahhh...

    I see. Sorry my brain isn't working correctly.

    Very good sir! I'm glad it is working correctly :)
     
  9. ZerOneX

    ZerOneX Member

    Newcomer
    1
    Dec 29, 2015
    Canada
    mattytrog, not being able to flash my trinket....

    i am seeing the drive TRINKETBOOT, but when I drag and drop Trinket_Rebug_Both.uf2 inside the folder, nothing happens...

    already renamed to current.uf2 and same behavior... nothing happens...

    it is the first flash... I am using my pc with windows10.

    thank you in advance

    best regards,

    ZerO
     
  10. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    That is a bad download :)
     
    ZerOneX likes this.
  11. ZerOneX

    ZerOneX Member

    Newcomer
    1
    Dec 29, 2015
    Canada
    Gonna dig into it... thank you very much man. Appreciate your reply.
     
    mattytrog likes this.
  12. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Ok )

    Had this the other week. Spent ages pissing around with different things. Ended up being a bad download.
     
  13. ZerOneX

    ZerOneX Member

    Newcomer
    1
    Dec 29, 2015
    Canada
    you were exactly/precisely right.... we cannot click and save as... the file will have 68kb.... we should download the RAW one... then it will have 20kb....

    hope that can help someone....

    thank you one more time....

    moving forwarding now....
     
    mattytrog likes this.
  14. SassyCultist

    SassyCultist Newbie

    Newcomer
    1
    Jul 21, 2018
    United States
    I flashed Simple UF2 V094 to my R4S dongle and it does not seem to be working. The light on the dongle continuously flashes blue then red.
     
  15. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    The uf2 does act differently. Does it actually send the payload?
     
  16. josete2k

    josete2k GBAtemp Regular

    Member
    3
    Apr 24, 2009
    Hi again.

    I have dual boot but as I'm not going to go for OFW in a few weeks I've just installed autorcm.

    If I plug the power adapter when the console is powered off, nothing happens (I assume that it's in RCM mode) and it autoloads the payload when I unplug the cable from the console. Nice.

    Now I'll test the power off feature.
     
  17. SassyCultist

    SassyCultist Newbie

    Newcomer
    1
    Jul 21, 2018
    United States
    It does not seem to ever send the payload.
     
  18. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    Hmmm...

    Ok I'll have a look when I get home
     
    peteruk likes this.
  19. josete2k

    josete2k GBAtemp Regular

    Member
    3
    Apr 24, 2009
    Ok, in 6 hours drain battery has been 0%.

    Good job.
     
    mattytrog likes this.
  20. mattytrog
    OP

    mattytrog Not on my watch.

    Member
    10
    Apr 27, 2018
    United Kingdom
    0.9.5 is coming. Nothing special just a bugfix.

    Changelog:

    ***Affects users of the new USB strap
    Removed delay from pulling out USB to sending payload - There was an issue where some users reported that upon fitting the strap, the SXOS boot menu booted every time.

    I put the delay in to allow for damaged / faulty USB cables or if the cable was pulled out slowly. But it isn`t an issue. It isn`t needed.

    So, removing the delay.

    Thanks to @popy for testing and bringing it to my attention.

    Being updated as we speak.
     
Loading...