MMM keeps asking for "IOS capable of homebrew"?

Discussion in 'Wii - Hacking' started by robsterinside, Apr 7, 2014.

  1. robsterinside
    OP

    robsterinside Newbie

    Newcomer
    4
    0
    Apr 7, 2014
    Mexico
    Juarez
    Hi everyone! I'm sort of new here, so I'm not quite sure of where to post my question, but it all started using ModMii, so I guess I'll give it a try here.
    It all began a couple of years ago, when I softmodded my then 4.1U wii and ocasionally installed some apps. No big deal.
    Some months ago, my brother updated the wii to 4.3U. Most things kept working fine, but I didn't use HBC apps until quite recently.
    Yesterday I found out about GC Action Replay App for HBC, and was eager to try it on MK Double Dash. Tutorials for it's installation were pretty clear, indications were:

    1. Install a patched version of MIOS (Wii GC Mode), using MIOS Patcher.

    2. Open Action Replay after inserting the GC game and an unofficial memory card.

    I was unable to install the MIOS and kept getting the next error:

    "ES_AddTitleStartReturned: -2011
    You need to use an IOS with trucha bug.
    Up to system menu 4.2 you can get one with Trucha Bug Restorer.
    MIOS installation failed..."

    I looked everywhere for an IOS with trucha bug, but found none for 4.3U.

    Then I tried the next method, suggested by a gbatemp member in another thread. I quote:

    "To quote a thread on GBAtemp that helped me solve the problem:
    Just change your IOS to one that doesn't check for game titles.
    Launch Multi Mod Manager, load IOS36 as your IOS, go to IOS manager, hit 1 to install a cIOS, choose 36 as your base IOS, then choose slot 236, and say YES to all 4 patches (including the version patch).
    Then reload IOS236, then retry installing your cMIOS
    That SHOULD solve the problem. It worked for me, I'm on 4.3U
    After this I was able to use Action Replay App"

    I tried using that method, then MMM indicated me that the wad "IOS36 is not capable of homebrew" just after saying YES to all patches...

    MMM KEEPS ASKING FOR AN IOS CAPABLE OF HOMEBREW AND WITH TRUCHA BUG.

    I investigated for hours and wasn't able to find any mentions about that specific topic.

    I THEN decided to rehack my wii, using ModMii. Everything went fine. It reinstalled and updated all my IOSes and HBC, installed Priiloader, and "IOS236 Installer v5 MOD.
    I thought that by rehacking the wii, all the IOSes would be ready for patching.


    The thing is: AFTER rehacking the wii, HBC was updated, and everything looks cleaner and runs smoother. But I'm still unable to install the MIOS patch. Almost every IOS patching app, and MMM keeps asking me for "a IOS capable of homebrew." I know there must be some steps I'm missing. Any ideas? I really looked for clues, keywords on Google, but nothing clear or useful comes up. :( Please be kind enough to guide me to the right thread, or to someone who can help me solve this issue. I'm completely baffled. I followed ModMii's guide step by step. Why are my IOSs not capable of homebrew? Or where do i get one with trucha bug?
     
  2. jonthedit

    jonthedit GBAtemp Advanced Maniac

    Member
    1,691
    438
    May 30, 2011
    Bangladesh
    For Other Tempers on the DarkTheme who can not read the OP's post...
    DarkTemp

    Sounds like all is nearly well! Just a few missing cIOS(s).
    I PM'd you a video I made a while back to get you fully updated.
    If you do not want to bother with the video here is what you need to do:
    Get SysCheck :download: (Here) or download it through ModMii as shown in the video I PM'd you.
    Then use ModMii to scan the .csv file and it will tell you the appropriate updates needed.
     
    robsterinside likes this.
  3. robsterinside
    OP

    robsterinside Newbie

    Newcomer
    4
    0
    Apr 7, 2014
    Mexico
    Juarez
    Yes!!! Finally! Turns out I just had to patch IOS236 instead of IOS36, found out thanks to SysCheck! I then used IOS263 Installer/Uninstaller and then MIOS Patcher. Thank you very much. :D
     
  4. robsterinside
    OP

    robsterinside Newbie

    Newcomer
    4
    0
    Apr 7, 2014
    Mexico
    Juarez
    I also used Wad manager to install 4 IOSes that came with an USB Loader package I found online. Apparently, these 4 wads made the difference.
     
  5. jonthedit

    jonthedit GBAtemp Advanced Maniac

    Member
    1,691
    438
    May 30, 2011
    Bangladesh
    Hmm.. Packages bundled with a loader are typically frowned upon (for copyright reasons).
    But in this case I would say they might be outdated. After you installed those 4 wads you should then run a sysCheck and see if there is a newer version of those 4 you installed.