Hacking Migrating SXOS to Atmosphere

Abstract3000

Well-Known Member
OP
Member
Joined
May 24, 2007
Messages
105
Trophies
0
Location
Salem, OR
Website
Visit site
XP
558
Country
United States
So trying To Migrate My current SXOS to Atmosphere due to the unfortunate fact Team Xecuter is not coming back.

I have an Erista Switch, SXOS 3.0.5 on Emunand fw 10.1.0, SysNand on fw 5.1.0. Emunand FW has been manually updated with ChoiDujourNX every update. The MicroSD contains the "Emutendo" directory.

I am trying to Follow a set of Video Tutorial as well as the tutorial located here: https://rentry.co/mys8q to do this, but I keep running into the problem when booting into the Hekate Payload, emuMMC -> emuMMC Migration tool, it does not detect the emunand? I know I have an Emunand as I set the System Background to Black, and when in the Regular System Nand I set the Background to White to tell the differences apart from one another. When loading the Atmosphere Files and injecting the Fusee-Primary.bin it boots back to the Regular Sys Nand I have avoided updating giving me the current version: 5.1.0|AMS M.19.4|S, but when turning off and booting with the Dongle back to the Emunand with the Black Background showing 10.1.0 Clearly indicating there is an Emulated NAND in play.

I would like to migrate to Atmosphere to keep all the games and Saves I already have in place, and if I could Just keep booting it up with the SX Dongle, that would be great. Anyone able to help me move past the emuMMC Migration tool step?

Thanks!
 
  • Like
Reactions: HollowGrams

Abstract3000

Well-Known Member
OP
Member
Joined
May 24, 2007
Messages
105
Trophies
0
Location
Salem, OR
Website
Visit site
XP
558
Country
United States
So digging around allot and it appears there is 2 types of "Emunand" File based and Hidden Partition based, as to why thats the Case if SXOS changed their method of creating it at some point not sure. Though I think I have the "File Based" and from what I can see I need to either just get a new Micro SD Set up atmosphere create an Emunand on it and move all the files over from the Emutendo Directory, or I need to convert the File based to a Partition base and use the emuMMC Migration tool then.... Hopefully I'm in the right direction on this.
 

simsimsim

Well-Known Member
Member
Joined
May 16, 2018
Messages
244
Trophies
0
Age
28
XP
717
Country
Canada
I'm also on SXOS, I'm so used to the system that I'm just gonna stick with it for now even though it won't get updated anymore. Migrating and getting used to atmo seems to be a bit complicated and since I barely play my Switch anyway I see little reason to do it.

Sorry I'm not here to help you since I have no clue myself. But in the future I might benefit from this thread too.
 
  • Like
Reactions: scroeffie1984

x3n0

Well-Known Member
Member
Joined
Mar 22, 2017
Messages
187
Trophies
0
XP
1,200
Country
Netherlands
I will try to convert my sx emu to ams this weekend. Will report back here what works. V1 Switch by the way.
 
Last edited by x3n0,

HollowGrams

Well-Known Member
Member
Joined
Nov 27, 2020
Messages
628
Trophies
0
Age
42
XP
647
Country
United States
So trying To Migrate My current SXOS to Atmosphere due to the unfortunate fact Team Xecuter is not coming back.

I have an Erista Switch, SXOS 3.0.5 on Emunand fw 10.1.0, SysNand on fw 5.1.0. Emunand FW has been manually updated with ChoiDujourNX every update. The MicroSD contains the "Emutendo" directory.

I am trying to Follow a set of Video Tutorial as well as the tutorial located here: https://rentry.co/mys8q to do this, but I keep running into the problem when booting into the Hekate Payload, emuMMC -> emuMMC Migration tool, it does not detect the emunand? I know I have an Emunand as I set the System Background to Black, and when in the Regular System Nand I set the Background to White to tell the differences apart from one another. When loading the Atmosphere Files and injecting the Fusee-Primary.bin it boots back to the Regular Sys Nand I have avoided updating giving me the current version: 5.1.0|AMS M.19.4|S, but when turning off and booting with the Dongle back to the Emunand with the Black Background showing 10.1.0 Clearly indicating there is an Emulated NAND in play.

I would like to migrate to Atmosphere to keep all the games and Saves I already have in place, and if I could Just keep booting it up with the SX Dongle, that would be great. Anyone able to help me move past the emuMMC Migration tool step?

Thanks!


Migrate your emunand with Hekate - Emummc Migrate, select your emummc - Options autoboot = Emummc - Save. Reboot and test.
 

Abstract3000

Well-Known Member
OP
Member
Joined
May 24, 2007
Messages
105
Trophies
0
Location
Salem, OR
Website
Visit site
XP
558
Country
United States
Migrate your emunand with Hekate - Emummc Migrate, select your emummc - Options autoboot = Emummc - Save. Reboot and test.
That's the issue I am having, I have tried that but the Emummc Migrate tool doesn't detect the Emunand, and I belive this is because is file based opposed to hidden partition based but i could be wrong.
 
  • Like
Reactions: HollowGrams

HollowGrams

Well-Known Member
Member
Joined
Nov 27, 2020
Messages
628
Trophies
0
Age
42
XP
647
Country
United States
That's the issue I am having, I have tried that but the Emummc Migrate tool doesn't detect the Emunand, and I belive this is because is file based opposed to hidden partition based but i could be wrong.

Just did a few file based converted to atmos and all went smooth. If you dont have your files based emunand in the right folder hekate wont see it. Leave it how TX SX OS set it up for you.
 

x3n0

Well-Known Member
Member
Joined
Mar 22, 2017
Messages
187
Trophies
0
XP
1,200
Country
Netherlands
Welk it was quite easy. I made a setup on sdsetup.com. copied the folder content of both folders to the root my sx card, also downloaded the latest sigpatches. Ran hekate from the sx options. Used the formentioned migrate tool. Booted emunand and everything worked automagicly :D
 
  • Like
Reactions: Abstract3000

Abstract3000

Well-Known Member
OP
Member
Joined
May 24, 2007
Messages
105
Trophies
0
Location
Salem, OR
Website
Visit site
XP
558
Country
United States
Just did a few file based converted to atmos and all went smooth. If you dont have your files based emunand in the right folder hekate wont see it. Leave it how TX SX OS set it up for you.

Well that's why I opened this thread to begin with, It's not detecting it. Its in the Root of the SD Card in a folder called "Emutendo" it's just how it's always been since i set it up. That's the problem, was wondering had anyone else ran into this issue with the migration tool not detecting the Emunand.

--------------------- MERGED ---------------------------

Welk it was quite easy. I made a setup on sdsetup.com. copied the folder content of both folders to the root my sx card, also downloaded the latest sigpatches. Ran hekate from the sx options. Used the formentioned migrate tool. Booted emunand and everything worked automagicly :D

That's good to hear, hopefully someone with the Same issue as I am having with that migrate tool not displaying the Emunand who has discovered the problem and resolved it will reply, but things are looking bleek this has been up for a few days. I'm thinking Im just going to have to figure out how to set up atmos on a blank memory card with a file based emunand and hope copying the files from the Emutendo directory over will work.
 
  • Like
Reactions: HollowGrams

HollowGrams

Well-Known Member
Member
Joined
Nov 27, 2020
Messages
628
Trophies
0
Age
42
XP
647
Country
United States
Well that's why I opened this thread to begin with, It's not detecting it. Its in the Root of the SD Card in a folder called "Emutendo" it's just how it's always been since i set it up. That's the problem, was wondering had anyone else ran into this issue with the migration tool not detecting the Emunand.

--------------------- MERGED ---------------------------



That's good to hear, hopefully someone with the Same issue as I am having with that migrate tool not displaying the Emunand who has discovered the problem and resolved it will reply, but things are looking bleek this has been up for a few days. I'm thinking Im just going to have to figure out how to set up atmos on a blank memory card with a file based emunand and hope copying the files from the Emutendo directory over will work.

Should be in SX folder like default. Have you moved any emu files around?
 

Abstract3000

Well-Known Member
OP
Member
Joined
May 24, 2007
Messages
105
Trophies
0
Location
Salem, OR
Website
Visit site
XP
558
Country
United States
So after messing around a bit with this I finally figured out why emuMMC Migration tool wasn't recognizing my Emunand. It appears the It only looks at the MicroSD card for the Emunand, not for an additional Partition on the System NAND. I discovered while I did in Fact have the Emutendo Directory on the SD card, my Emunand was actually on the system, therefore when Using the SX Tools to Move the Emunand to SD, the emuMMC Migration tool now recognizes it's presence. Just thought I would post the follow up for anyone else having the Issue. I can't remember why I installed in on the system rather the SD... maybe for space constraints? or was that the only option with the first SX Firmware that offered the Emunand option? If so then that would have been it, as I adopted it right away loving the CFW option on the 3DS.
 
  • Like
Reactions: x3n0

Cabuzzi

Member
Newcomer
Joined
Apr 17, 2009
Messages
12
Trophies
0
XP
125
Country
United States
I hate to resurrect an old thead, but I read this threadd on your issue and saw your fix. The problem is that I have no idea how to tell (or even see) the sysNAND partition and tell if my emuNAND is on there.

From what I remember, I did the file-based emuNAND, but like you, can't remember if there was even a choice of whether to put it on the sysNAND or sdcard (I think would've chosen the latter, if it were a choice).

So now I've followed everything in several guides to get Atmosphere 1.2.5 up and running, and it "seems" to have worked. When I boot into Atmosphere CFW, it shows 8.0.0|AMS 1.2.5|E. I'm not sure what this means, as my emuNAND definitely was not on 8.0 (I believe that's where I left the sysNAND), but the E makes me think I'm in an emuNAND. I can't launch any "installed" games. They all say to insert the game card... but I've installed all of them (using TinFoil, I believe).

Anything you can do to help would be greatly appreciated!
 

sh2dc

Well-Known Member
Member
Joined
Jan 23, 2015
Messages
196
Trophies
0
Age
31
XP
354
Country
United States
Migrate your emunand with Hekate - Emummc Migrate, select your emummc - Options autoboot = Emummc - Save. Reboot and test.
OK I read

https://rentry.org/mys8q


Now I understand it could be super easy



I was use "sx os emunand on file" with switch's SD card


Not hide - partition


So dual boot sx os and ams on same sd card basically cant be done


I won't create any hide - partition emunand or emummc



However

Because I want newest game running so i must use 13.0-13.2 firmware


So I need create another 32 GB ams 13.0-13.2 firmware Emummc( just like sx os emunand ) on another SD card right??



=========


https://rentry.org/mys8q



This guide work on file-based sx os emunand?


If it work

I can just copy my entire SD card emunand to a new SD card

Then I update this new sd card emunand to 13.2?!


This way I can keep one SD card with old sx os ( with all the save/ game / cheat )


Then Migrate sx os emunand 13.2 to ams emummc on new SD card?


I will get 13.2 running on ams

And all the game needs to be reinstall?!


All the save / cheat no longer can be use?!


Right?


==========


Hmm



Sorry for late reply


I must update sx os emunand firmware to 13.2 first


Before use this guide right?

https://rentry.org/mys8q





I use sx os emunand 10-11.0


So once I updated 13.2 firmware on SD card sx os will unable to boot


Then I put all the file from " https://rentry.org/mys8q " said to SD card


I get 13.2 running after use hekate migrate this emunand to emummc?


Right?



All the game/ save locate on old sx os cfw 10-11.0 etc will be gone once I use ams? Right?!
 

Chaosta

Well-Known Member
Member
Joined
Sep 18, 2020
Messages
455
Trophies
0
XP
468
Country
United States
I hate to resurrect an old thead, but I read this threadd on your issue and saw your fix. The problem is that I have no idea how to tell (or even see) the sysNAND partition and tell if my emuNAND is on there.

From what I remember, I did the file-based emuNAND, but like you, can't remember if there was even a choice of whether to put it on the sysNAND or sdcard (I think would've chosen the latter, if it were a choice).

So now I've followed everything in several guides to get Atmosphere 1.2.5 up and running, and it "seems" to have worked. When I boot into Atmosphere CFW, it shows 8.0.0|AMS 1.2.5|E. I'm not sure what this means, as my emuNAND definitely was not on 8.0 (I believe that's where I left the sysNAND), but the E makes me think I'm in an emuNAND. I can't launch any "installed" games. They all say to insert the game card... but I've installed all of them (using TinFoil, I believe).

Anything you can do to help would be greatly appreciated!
throw sd card in pc and and use a partition manager, if its file based you will see it on sd card, if partitioned youll see it in a partition manager
 
  • Like
Reactions: Cabuzzi

Cabuzzi

Member
Newcomer
Joined
Apr 17, 2009
Messages
12
Trophies
0
XP
125
Country
United States
throw sd card in pc and and use a partition manager, if its file based you will see it on sd card, if partitioned youll see it in a partition manager
The card is a 400GB SanDisk card. It's setup with a 32MB partition in the first spot, followed by a 366GB exFAT partition. I checked with both the Win10 disk management applet, as well as Aomei (no hidden partitions). I have two folders under H:\emuMMC:

EF00 (large: 286GB)
SD00 (small: 29.1GB).

I also took a backup of my emuNAND before I started trying to migrate. It's under H:\sxos\backup and is 29.1GB in size (same size as SD00).
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,825
Trophies
1
Age
27
Location
New York City
XP
11,799
Country
United States
OK I read

https://rentry.org/mys8q


Now I understand it could be super easy



I was use "sx os emunand on file" with switch's SD card


Not hide - partition


So dual boot sx os and ams on same sd card basically cant be done


I won't create any hide - partition emunand or emummc



However

Because I want newest game running so i must use 13.0-13.2 firmware


So I need create another 32 GB ams 13.0-13.2 firmware Emummc( just like sx os emunand ) on another SD card right??



=========


https://rentry.org/mys8q



This guide work on file-based sx os emunand?


If it work

I can just copy my entire SD card emunand to a new SD card

Then I update this new sd card emunand to 13.2?!


This way I can keep one SD card with old sx os ( with all the save/ game / cheat )


Then Migrate sx os emunand 13.2 to ams emummc on new SD card?


I will get 13.2 running on ams

And all the game needs to be reinstall?!


All the save / cheat no longer can be use?!


Right?


==========


Hmm



Sorry for late reply


I must update sx os emunand firmware to 13.2 first


Before use this guide right?

https://rentry.org/mys8q





I use sx os emunand 10-11.0


So once I updated 13.2 firmware on SD card sx os will unable to boot


Then I put all the file from " https://rentry.org/mys8q " said to SD card


I get 13.2 running after use hekate migrate this emunand to emummc?


Right?



All the game/ save locate on old sx os cfw 10-11.0 etc will be gone once I use ams? Right?!
Why do you make a new line for each sentence? It makes reading your posts incredibly annoying.
 
General chit-chat
Help Users
    Dark_Phoras @ Dark_Phoras: I think watching these movies just raises the risk of depression