Hacking Mighty Channels

brausm08

Well-Known Member
Member
Joined
Nov 15, 2009
Messages
721
Trophies
0
Age
43
Location
USA - Midwest
XP
222
Country
United States
Bat420maN said:
You guys getting the title list error need to mod the .xml to auto=USB and IOS=whatever one your trying to use. It fixed my issues with the list once I changed up the .xml.
...did a 'proper' modification of the argument lines to the .xml to be like the example on page 1 of this thread (such that i don't have to select REAL/SD/USB for the NAND)...nothing has changed with the hit or miss characteristics of the "ERROR: I can't find title list ret=-1". if i get the error it just cycles back to HBC where i can launch it again immediately. so i did that 10 times....only the sixth and the ninth launch actually loaded through to the channels and didn't gave me that error. this was done on a 8GB A-DATA SD Card....

I'm just now loading a USB stick with a fresh, full NAND dump (FS Dumper) and the same 38 wads (using showmiiwads1.4) to see if that will make a difference. ...will report back...

EDIT: Mighty Channels works beautifully off a USB2.0 thumbdrive NAND.... it is a bit slower to launch however, but that's okay....it works! ...probably will install 249v21[38] as i saw a few posts up it's speedier.

EDIT2: tried to 'Simple FS Dump' my NAND to a USB3.0 HDD, failed (no surprise)...then transferred my current Dump from the thumbdrive to the USB3.0 drive....Mighty Channels gives me -101 error for that...(that doesn't surprise me either, but i thought i'd share)....tried launching a USB3.0 NAND with both v21[38] and v17.
on v21[38], the thumbdrive loaded considerably faster than on v17 (for the USB2.0 thumbdrive, the titles loaded everytime i tried though with either cIOS version)
on v21[38], the SD NAND's gave me a -101 error everytime.....while on v17, the SD(HC) NANDs gave me a -1 error ~75% of the time...

@AyDee (post below mine)....i figured SDHC was the issue after all these tests (which is why i identified the card in all cases--i also identified a 4GB Transcend as problematic too)...i DO hope it will be SDHC compatible on a later version (if possible). i also agree that v17 is the more compatible, but the speed difference with the USB2.0 thumbdrive on v21 was definitely noticable....

the only thing i may try down the road is a NAND on a USB2.0 HDD to see if it's equivalent to the thumbdrive (which it should be)....

i hope all this information that i've been generating is at least a little useful to the developers....
 

AyDee

New Member
Newbie
Joined
Jan 8, 2011
Messages
2
Trophies
0
XP
8
Country
United States
halen said:
Here is the same
..."ERROR: i can't find titles ret=-1" ...

The sd card: 16gb Transcend which has behaved 100% (bootmii, hbc) until now.

My system: cIOS [email protected]

Using beta 4
Bat420maN said:
... this was done on a 8GB A-DATA SD Card....
SDHC is not recommended. Ran into the same errors on my 8GB card.


QUOTE(Bat420maN @ Jan 9 2011, 07:08 PM)
...probably will install 249v21[38] as i saw a few posts up it's speedier.
249v17[38] is most compatible if I'm not mistaken



*Edit-
@brausm08:
Yeah, SDHC (and microSD) support would be nice. & good to know about v21...
My USB2.0 HDD (FAT32) works well except for what I mentioned in post #159 (3 up).
My brother's USB3.0 compatible HDD (FAT32) seemed to work ok too... Didn't have a chance to test, just gave him my nand to try it out and it showed all the titles fine and started up a game.

@Kalidor: USB NAND is already supported...
 

Kalidor

Well-Known Member
Newcomer
Joined
Mar 28, 2010
Messages
71
Trophies
0
Age
52
XP
178
Country
France
Mighty channels work very fine with the rev 17 .

I have tested my crap forwarder ( system menu ) , same results , it's ok for me .

But , the iso forwarders ( create with 3iso studio doesn't work in wiiflow ) , I , continue my test .

Just a question , can you create an usb version for usb nand ?

rolleyes.gif
 

coreduo0099

Active Member
Newcomer
Joined
May 3, 2009
Messages
40
Trophies
0
XP
117
Country
United States
Well, I finally settled in on a Mighty Channels b4 config for a 16GB SDHC / 2TB WD Essentials setup.

First there were lots of compatibility issues with SDHC and nothing works with a HD > 1TB

Compatibility Testing


Config:
Put emulated NAND files with only WiiWare titles on SDHC (I removed all other channels to keep it neat)
To make this work, use cIOS 249 base 57 r21
Use Mighty Channel Forwarder that respects .xml config

Instead of VC Channels I put HBC based emulators on SDHC and emu channel forwarders in real NAND. These use a lot less space than VC titles and work on a SDHC card.
(I put roms on SDHC, but many emus support USB or even SMB network shares as well if you like)

This seems to work effectively as well as a SD card using cIOS 249 base 38 r17 but with SDHC and support for many more legacy console games.

Biggest wish list now is Alphabetical listing of Titles rather than Title ID in order to find Titles easier and many missing Channel "covers"

Thanks Marc for your hard work!
 

Liberty

Well-Known Member
Member
Joined
Nov 22, 2008
Messages
526
Trophies
0
XP
214
Country
Gambia, The
Liberty said:
cIOS Rev17 (Base38) => I can't get title list. ret=-1
cIOSx Rev21 (Base38) => I can't enable NAND emulator. ret=-101
cIOSx Rev21 (Base56) => I can't enable NAND emulator. ret=-101
cIOSx Rev21 (Base57) => I can't enable NAND emulator. ret=-101

I'm lost. WiiFlow and CFGLoader are working without a problem, so does UNEEK.

QUOTE said:
Because backup loaders init the usb drives themselfs, we don't mount the usb drives the cios does that for us. I might take a look in the weekend, but i kinda stopped working on anything for the wii.
Basically we need a USB-drive-init-module. I don't know how this whole USB-initialization is working, but couldn't anyone just have a look on how an open-source-loader like WiiFlow works regarding this issue?
May anyone tell me if this is theoretically possible?
 

wiiLike2Hacks

Active Member
Newcomer
Joined
Mar 26, 2010
Messages
39
Trophies
0
XP
213
Country
United States
I've got a thread over at wiihacks where I keep an updated pack of coverart perfect for Mighty Channels & Triiforce. I've tried using the download feature inside Mighty Channels, but still find that I'm missing quite a few images. Figured I'd share it with you guys, since I'm a newb here and all.
 

Pakatus

Well-Known Member
Member
Joined
Apr 13, 2009
Messages
779
Trophies
0
Age
43
Location
Portugal
XP
129
Country
wiiLike2Hacks said:
I've got a thread over at wiihacks where I keep an updated pack of coverart perfect for Mighty Channels & Triiforce. I've tried using the download feature inside Mighty Channels, but still find that I'm missing quite a few images. Figured I'd share it with you guys, since I'm a newb here and all.


If you really want to help...why not to up them to wiitdb.com?
 

wiiLike2Hacks

Active Member
Newcomer
Joined
Mar 26, 2010
Messages
39
Trophies
0
XP
213
Country
United States
Pakatus said:
wiiLike2Hacks said:
I've got a thread over at wiihacks where I keep an updated pack of coverart perfect for Mighty Channels & Triiforce. I've tried using the download feature inside Mighty Channels, but still find that I'm missing quite a few images. Figured I'd share it with you guys, since I'm a newb here and all.


If you really want to help...why not to up them to wiitdb.com?
You know, I never really thought about that. I'll do that right now, actually.
 

wonderwii

New Member
Newbie
Joined
Jan 12, 2011
Messages
1
Trophies
0
XP
1
Country
United States
mrkazador said:
BryceOne said:
This happens to me on any VC title that uses IOS9.

A few titles include: Donkey Kong Country 1&2, Mario Kart 64, Sonic The Hedgehog, Super Mario Bros & World, Legend Of Zelda Oricana Of Time & Link To The Past, Bonks Adventure.

Try some of these out and see if they do the same thing.


Yep, you're right... Is there a fix?


Any word on this? I have the same issue, thanks.
 

Liberty

Well-Known Member
Member
Joined
Nov 22, 2008
Messages
526
Trophies
0
XP
214
Country
Gambia, The
Liberty said:
cIOS Rev17 (Base38) => I can't get title list. ret=-1
cIOSx Rev21 (Base38) => I can't enable NAND emulator. ret=-101
cIOSx Rev21 (Base56) => I can't enable NAND emulator. ret=-101
cIOSx Rev21 (Base57) => I can't enable NAND emulator. ret=-101

I'm lost. WiiFlow and CFGLoader are working without a problem, so does UNEEK.

QUOTE said:
Because backup loaders init the usb drives themselfs, we don't mount the usb drives the cios does that for us. I might take a look in the weekend, but i kinda stopped working on anything for the wii.
Basically we need a USB-drive-init-module. I don't know how this whole USB-initialization is working, but couldn't anyone just have a look on how an open-source-loader like WiiFlow works regarding this issue?
May anyone tell me if this is theoretically possible?

And may anyone tell me as well what "I can't enable NAND emulator. ret=-101" means?
I'm starving lol ...
 

zimmy28

Member
Newcomer
Joined
Mar 15, 2009
Messages
6
Trophies
0
XP
74
Country
United States
I am trying to run Pokemon Rumble. I got it to load once and tried a few other WiiWare games and everything worked fine. I went to add some more games to my drive and noticed that all the IOS for the menu and such are no longer on the USB drive NAND using ShowMiiWADs 1.4. It only lists the games and nothing else, no default channels either, just games. I put it back and try to play Pokemon Rumble again and it just black screens. I know something is wrong here but I don't know what exactly. I used TriiForce MRC before with no issues. I wonder if I should install that again and see if it re-creates this problem. I'll try that while I am at it I guess.

Running 4.1U, cIOS 249 rev 17, Mighty Channels 4b, USB drive is a 360 GB Seagate FreeAgent GO with auto spin down shut off

PS. I just tested TriiForce MRC and it did the same thing. Weird. It's as if when I connect the drive to the PC to use ShowMiiWads, it craps out the NAND on it. I will try another drive and see if it works next.

PSS. I tried a different USB drive and it does exact same thing. I am lost at what I did to even get it to work the first time. I have my NAND dump saved here, maybe I'll re-extract it again and start over. I don't know if I may have altered a file somewhere and broke something in the process.
 

Inpression

Well-Known Member
Newcomer
Joined
Jun 19, 2007
Messages
58
Trophies
0
XP
253
Country
United States
I've found my sweet spot for Mighty Channels, two separate instances of the loader, one using cIOS 248 rev21, base 56, which works with most, recent, WiiWare games, and another using cIOS 249 rev17, for loading VC games and older WiiWare.

I've also noticed that the default channels and IOS', present in the NAND when I backed it up, seem to have disappeared, but, since it doesn't look like it affects performance, it doesn't bother me much and only frees more space.

Overall, I'm quite happy with Mighty Channels, looks great and improves the compatibility of Triiforce_MRC, so, thanks marc_max, for sticking with it and delivering a great app.
 

Skater4599

Well-Known Member
Member
Joined
May 29, 2008
Messages
965
Trophies
0
Location
United States
XP
1,402
Country
United States
Liberty said:
Liberty said:
cIOS Rev17 (Base38) => I can't get title list. ret=-1
cIOSx Rev21 (Base38) => I can't enable NAND emulator. ret=-101
cIOSx Rev21 (Base56) => I can't enable NAND emulator. ret=-101
cIOSx Rev21 (Base57) => I can't enable NAND emulator. ret=-101

I'm lost. WiiFlow and CFGLoader are working without a problem, so does UNEEK.

QUOTE said:
Because backup loaders init the usb drives themselfs, we don't mount the usb drives the cios does that for us. I might take a look in the weekend, but i kinda stopped working on anything for the wii.
Basically we need a USB-drive-init-module. I don't know how this whole USB-initialization is working, but couldn't anyone just have a look on how an open-source-loader like WiiFlow works regarding this issue?
May anyone tell me if this is theoretically possible?

And may anyone tell me as well what "I can't enable NAND emulator. ret=-101" means?
I'm starving lol ...


I cannot answer fully if its theoretically possible or not, but AFAIK yes it would be possible to do it, but it would have to work almost 100% differently then how it does now, at the moment mighty channels loads "nand emu mode" which is completely built into the cIOS and that mounts the drives and also controls compatibility, rather than relying on libogc, which gets updated often. This is obviously crippled (no 1TB or higher support). But without an almost complete re-write to have the app control that part and only start nand emu when launching a game I dont think its an easy thing to add in, I have not looked much at the source for MC but i think it would be a pretty big overhaul of the program. Again I'm no master coder, I'm actually a computer science student still trying to learn wii coding on my free time. So take this info with a grain of salt, maybe marc_max can chime in with better info...

ret=-101 seems to be a problem with your nand emu itself, I see you tried different cIOS's but have you tried a new nand dump? make sure not to delete any folders... even empty ones, the only time I've ever gotten ret errors was when i deleted a tmp folder cause it was empty, so it needs EVERYTHING just right. Also make sure your xml is not passing an argument to use a different cIOS other than the one you intend
 

Liberty

Well-Known Member
Member
Joined
Nov 22, 2008
Messages
526
Trophies
0
XP
214
Country
Gambia, The
Thanks for your advice and explanatory post, i will check if no folders are missing.
€ No luck, I don't think i'm missing a folder: import, meta, shared1, shared2, sys, ticket, title, tmp
 

freestile

Well-Known Member
Member
Joined
Jan 10, 2011
Messages
176
Trophies
0
Location
https://www.youtube.com/user/freestilesteve
Website
www.youtube.com
XP
319
Country
United States
This is my first experience with this. Never gave triiforce a shot. Jumped into this and its working
wonders. I got all the games I tested with 249 rev 21 to work, but I also have 246[38]-v17, which as suggested on wiihacks and in the liner notes it seems like Triiforce mrc+rev17 is the way too go so I'm thinking I shouldnt have any problems. Wrd up Big Marc. Keep up the good work.


Edit: I added about 6 more wiiware titles and none show up. This is all from the harddrive. Hum?? Wonder why.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    HarvHouHacker @ HarvHouHacker: The tablet on-screen keyboard sucks; I keep mistyping.