Mighty Channels, TriiForce + d2x + nand emulation

Discussion in 'Wii - Hacking' started by WiiPower, Jun 16, 2011.

Jun 16, 2011
  1. WiiPower
    OP

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I to want collect usable error reports for issues with VC/WiiWare nand emulation and try to arrange them into the right group. Basically if it's a loader issue, a cIOS issue, a nand emu issue, a hardware issue or user fault.

    Known issues:
    Nand emulation and Nintendo Wi-Fi Connection:
    In TriiForce R86 using d2x v6, it works with both boot methods on real and doesn't on emulated nand. So it seems to not be a loader or cIOS issue, it could be a nand emu issue or be related to the used device.

    This needs confirmation for sd, sdhc and usb nand separately.

    The Legend of Zelda: Majora's Mask (VirtualConsole):
    This needs to be tested with the latest TriiForce with both boot methods(normal + apploader), as one the latest updates might fix this.

    LostWinds series (WiiWare):
    Freezes randomly when entering a new area with a buzzing noise. Seems to happen more often, the slower the device is[Or it could be that the number of installed titles is relevant on TriiForce up to R87]. 2 reports that TriiForce r88+ reduces the freezes to happen much less often.

    Swords and Soldiers (WiiWare):
    ...

    Liight (WiiWare):
    ...

    Bonsai Barber (WiiWare):
    Might get different results on sd, sdhc and usb.

    Various games:
    - Some games are reported to require the apploader boot method. One of the recent updates to TriiForce might fix this.
    "WAL", //ArtSyle: light trax
    "WDH", //ArtSyle: Rotohex
    "WOB", //ArtSyle: ORBIENT
    "WPR", //ArtSyle: CUBELLO
    "WA8", //ArtSyle: Penta Tentacles
    "WB7", //Midnight Pool
    "WSP" //Pokemon Rumble

    - Some games are reported to only be able to save if there's a savegame on the nand already. In theory booting the game once with the apploader method might fix this.
    Bit Trip Beat
    Bit Trip Core
    Bit Trip Void
    Bit Trip Runner


    When posting, please state what you are using and please always try to test with both boot methods(normal + apploader), on real and on emulated nand. Example:
    TriiForce R86, d2x base IOS56 v6 final, 1 TB usb HDD, normal boot: DOESN'T WORK
    TriiForce R86, d2x base IOS56 v6 final, 1 TB usb HDD, apploader: DOESN'T WORK
    TriiForce R86, d2x base IOS56 v6 final, real nand, normal boot: WORKS
    TriiForce R86, d2x base IOS56 v6 final, real nand, apploader: WORKS
    MC v11.1, d2x base IOS56 v6 final, 1 TB usb HDD, normal boot: DOESN'T WORK
    MC v11.1, d2x base IOS56 v6 final, 1 TB usb HDD, apploader: DOESN'T WORK
    MC v11.1, d2x base IOS56 v6 final, real nand, normal boot: DOESN'T WORK
    MC v11.1, d2x base IOS56 v6 final, real nand, apploader: WORKS

    (that's the expected result for the online stuff btw)

    Note that testing with TriiForce R91 is mandatory, because it received some updates recently which Mighty Channels does not have yet:
    http://code.google.com/p/triiforce/source/...n%2Ftrunk%2FHBC
     


  2. davebaol

    Member davebaol GBAtemp Advanced Fan

    Joined:
    Sep 3, 2010
    Messages:
    913
    Country:
    Italy
    The messagge is the usual "An error has occurred. Refer to Wii manual bla bla bla"
    The only special thing is the red background color.

    Ah the message appears after the health screen and the 1st loading screen just before asking confirmation for date and time.

    I think the error is due to some bad emulation in FFS or FAT modules.
     
  3. Mad Bawler

    Newcomer Mad Bawler Member

    Joined:
    Jun 3, 2011
    Messages:
    18
    Country:
    Germany
    Hi WiiPower!
    First, thank you for the new version of TriiForce and all your work on the other project's!!!!!!
    I have the following problem: TriiForce or Mighty Channel can't find the USB-NAND on my Samsung S2 640 GB.

    Loading...Error: Could not get dir entry count(ret: -101) for:
    '/title/00010001'
    Reading folder /title/00010001 failed
    Error getting the tilte list

    No problem with my SanDisk USB Stick!
    UNEEK and Sorg's NANDEmu boots the USB-NAND without problems.

    And a little question, can you add a theme option in TriiForce?
     
  4. zizer

    Member zizer GBAtemp Addict

    Joined:
    Aug 23, 2010
    Messages:
    2,035
    Country:
    if you have sneek why do you want use triiforce, mightly channel
     
  5. Mad Bawler

    Newcomer Mad Bawler Member

    Joined:
    Jun 3, 2011
    Messages:
    18
    Country:
    Germany
    Sorry ;-), but i like the TriiForce console interface!
     
  6. WiiPower
    OP

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    I'll check if i can get a better error message this weekend. I have no intention of adding themes or doing anything GUI related in TriiForce, because most people use MC anyways. So it makes more sense to adapt the TriiForce changes to MC than for me to write a GUI.
     
  7. Slimmmmmm

    Member Slimmmmmm GBAtemp MoNkEeE

    Joined:
    Nov 1, 2007
    Messages:
    1,687
    Location:
    the land of lol
    Country:
    United Kingdom
    *EDIT*
    If anyone knows any games not in the first post that have problems please post.
     
  8. dancemonkey

    Member dancemonkey GBAtemp Regular

    Joined:
    Jan 14, 2007
    Messages:
    262
    Country:
    United Kingdom
    Mario Golf does the same thing as The Legend of Zelda: Majora's Mask for me. Have not tried with rev 17
     
  9. DEFIANT

    Member DEFIANT GBAtemp Fan

    Joined:
    Dec 9, 2008
    Messages:
    344
    Location:
    Gallifrey
    Country:
    United States
    Ocarina codes do not work in mighty channels v.2bis. It also doesn't work in v11.1. I would love to see this working. I know there's alot mixed feelings about cheating but I feel for completeness it should at least work.
     
  10. Kovani

    Member Kovani GBAtemp Regular

    Joined:
    Jan 4, 2009
    Messages:
    168
    Country:
    Canada
    Here's my testing results for LostWinds after 20 minutes of gameplay for each methods. Please note that I also reached a save point and I restarted the game to see if everything is still working.

    TriiForce R86, d2x base IOS56 v6 final, usb nand, normal boot
    TriiForce R86, d2x base IOS56 v6 final, usb nand, apploader

    After entering a new zone, sometimes the game freeze with a looping sound. However, after a hard reset, I can resume the game.

    TriiForce R86, d2x base IOS56 v6 final, real nand, normal boot
    TriiForce R86, d2x base IOS56 v6 final, real nand, apploader

    No issue at all.

    TriiForce R86, d2x base IOS56 v6 final, sd nand, normal boot
    TriiForce R86, d2x base IOS56 v6 final, sd nand, apploader

    No issue at all.

    I hope my testing were useful. [​IMG]
     
  11. davebaol

    Member davebaol GBAtemp Advanced Fan

    Joined:
    Sep 3, 2010
    Messages:
    913
    Country:
    Italy
    For LW sd nand works and usb nand fails?!?
    This is a big surprise, but rather worrying imo.

    EDIT:
    Also, for usb nand I think I remember that after resuming a game previously crashed the game always crashes when entering the 1st new zone.
    And if you remove the save everything works again like before (I mean, it crashes when entering a new zone but not necessarily the 1st one).
    Also, with usb gecko I've noticed that during zone transition the save is accessed.
    All this makes me think that the save game can become randomly corrupted during zone transitions.
    That's why it's quite surprising that everything works from sd nand.

    So, Kovani, can you check if my memories are correct?
     
  12. WiiPower
    OP

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Yeah it's strange that the sd nand seems to work. But as i told you yesterday, i worry if it's accessing 2 different files at the same time. What kind of crash did you get with your nand logger?
     
  13. IceIceBird

    Member IceIceBird GBAtemp Fan

    Joined:
    Nov 14, 2009
    Messages:
    408
    Country:
    Sweden
    LW on sd nand sometimes also freezes when changing zoones so it's not just a USB thingy. Not so often but it does from time to time. No problem loading the last save though.
     
  14. westt

    Newcomer westt Newbie

    Joined:
    Feb 15, 2011
    Messages:
    2
    Country:
    Japan
    Bit Trip Runner
    MC v11.1, d2x base IOS56 v6 final, usb nand,normal boot: WORKS
    Japanese?blog?Here
     
  15. davebaol

    Member davebaol GBAtemp Advanced Fan

    Joined:
    Sep 3, 2010
    Messages:
    913
    Country:
    Italy
    This is a very good news IMO.
    What do you mean exactly with "No problem loading the last save though"?
     
  16. IceIceBird

    Member IceIceBird GBAtemp Fan

    Joined:
    Nov 14, 2009
    Messages:
    408
    Country:
    Sweden
    I remember some time ago (some d2x rev back) this also was an issue and that we had to remove the old save before we could start the game again. So I just thought of mention it.
     
  17. davebaol

    Member davebaol GBAtemp Advanced Fan

    Joined:
    Sep 3, 2010
    Messages:
    913
    Country:
    Italy
     
  18. IceIceBird

    Member IceIceBird GBAtemp Fan

    Joined:
    Nov 14, 2009
    Messages:
    408
    Country:
    Sweden
    Yes the game can run for a while but can stil freeze when entering a new zone.

    The only time the game freezes is when entering a new zone and only happens randomly.
     
  19. WiiPower
    OP

    Member WiiPower GBAtemp Guru

    Joined:
    Oct 17, 2008
    Messages:
    8,165
    Country:
    Germany
    Davebaol, i meant what issue did you get with your logger that logged to nand emu? It was crashing due to 2 writes at the same time, and i want to know in which way this crashes the game.
     
  20. davebaol

    Member davebaol GBAtemp Advanced Fan

    Joined:
    Sep 3, 2010
    Messages:
    913
    Country:
    Italy
    @IceIceBird
    ok, perhaps I don't remember correctly.

    If file logging is active then you can't even start to play.
    The game crashes as soon as you select the profile.
    Is this what you want to know?
     

Share This Page