MGS2 sons of liberty

Discussion in 'Sony PlayStation 1 & 2' started by 4urentertainment, Apr 26, 2008.

  1. 4urentertainment
    OP

    4urentertainment GBAtemp Regular

    Member
    103
    0
    Sep 8, 2007
    Egypt
    I just downloaded and burned MGS2 with a "multi 5" next to its name. And when i opened it and played, most of the writings are in a weird language while the speech is in english. Is there a language option or smthn? How do i make the writings and subtitles in english?
     
  2. Jax

    Jax Pip Pip Cheerioink!

    Member
    4,131
    285
    Jul 31, 2006
    Portugal
    L.A.V.
    Change the language of the PS2 to english.
     
  3. 4urentertainment
    OP

    4urentertainment GBAtemp Regular

    Member
    103
    0
    Sep 8, 2007
    Egypt
    u mean from outside the game? I'll try that and edit my post later...
     
  4. 4urentertainment
    OP

    4urentertainment GBAtemp Regular

    Member
    103
    0
    Sep 8, 2007
    Egypt
    I checked and it was already english, and still the problem was there, what's wrong?
     
  5. Gaisuto

    Gaisuto Lose 2 Levels.

    Former Staff
    5,925
    2
    Oct 27, 2002
    United States
    Palm Coast
    Multi-5 means there are five language options somewhere in the game. Check the options to see if the Language setting is there.
     
  6. 4urentertainment
    OP

    4urentertainment GBAtemp Regular

    Member
    103
    0
    Sep 8, 2007
    Egypt
    I did, nothing... That's why i made this thread, i cant find a language option.
     
  7. Joe88

    Joe88 [λ]

    Member
    11,672
    2,954
    Jan 6, 2008
    United States
    NYC
    wtf happened to my post???

    anyway the original post I posted was there should be a language in the options or when the game first starts up

    most likely its english by default
    and its PAL
     
  8. Sc4rFac3d

    Sc4rFac3d GBAtemp Advanced Maniac

    Member
    1,629
    3
    Jul 30, 2005
    Netherlands
    When you enter a new area, some of the stuff should be in Russian, that's normal. Unless you mean Codec and stuff is in another language too, then you need to change the language.