Metroid Prime Trilogy Update

Discussion in 'Wii - Console and Game Discussions' started by SpaceJump, Oct 3, 2009.

  1. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,671
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    I have a PAL Metroid Prime Trilogy retail game and when I insert it into the Wii it wants to do an update. My Wii is on 4.1E.

    What does the update do? Is it safe to let it update? I know I can load the game through Gecko OS or NeoGamme, but I'd rather launch it from the disc channel if possible.
     
  2. tj_cool

    tj_cool Site dev

    Supervisor
    9,985
    -1
    Jan 7, 2009
    Belgium
    This planet
    Load it with GeckoOs 1.9.2 the first time and it will search and install the things it needs without updating
     
  3. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,671
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    I already launched it a few times through Gecko 1.9.2 and it still wants to do the update. Do I have to configure something in Gecko?
     
  4. Adr990

    Adr990 To boldly go where no man has gone before!

    Member
    1,470
    146
    Apr 22, 2007
    Netherlands
    The Netherlands
    Use Preloader hacks / Startpatch. [​IMG] It's the best way to block disc updates.
     
  5. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,671
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    Any other way? I don't want to install those.

    What does the update want to install anyway?
     
  6. Eichro

    Eichro Advanced Member

    Newcomer
    66
    0
    Sep 14, 2009
    Brazil
    I BELIEVE the update won't do anything bad to your homebrews since you're on 4.1 and MPT surely doesn't have the 4.2 update. I can't be sure if it's harmless, but it won't update your Wii at least.

    Well, I hope I'm not bothering you to ask that, but why don't you want to install Preloader?
     
  7. MagusDraco

    MagusDraco Advanced Member

    Newcomer
    80
    0
    Oct 25, 2006
    United States
    It probably just wants to install a newer version of the dual layer IOS.
     
  8. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,671
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    Which IOS would that be?
     
  9. tj_cool

    tj_cool Site dev

    Supervisor
    9,985
    -1
    Jan 7, 2009
    Belgium
    This planet
    Not possible since:
    1) 4.1 has all IOS
    2) GeckoOs should've installed it
     
  10. Vidboy10

    Vidboy10 Tsardom

    Member
    2,617
    7
    Dec 15, 2008
    Canada
    Vancouver, B.C
    Can't be possible.
    The 4.2 update just came out a week ago.
    Maybe we should use the Wii Scrubber to see what the kind of update it has.
     
  11. tj_cool

    tj_cool Site dev

    Supervisor
    9,985
    -1
    Jan 7, 2009
    Belgium
    This planet
    Its probably out of region or something
     
  12. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,671
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    I just let it update and everything seems to be as before. Just in case I made a NAND backup before the update [​IMG]
     
  13. eddzy

    eddzy Advanced Member

    Newcomer
    70
    0
    Nov 18, 2008

    What happened when you updated? i have pal metroid prime and i updated to 4.2 and reinstalled cios and it wants to update again? will this be harmful ?
     
  14. SpaceJump
    OP

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,671
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    I didn't notice any difference after updating. Everything is still working.
     
  15. Kaos

    Kaos Good show!

    Member
    558
    0
    Nov 25, 2007
    Melbourne, Australia
    Strange...
    I just got Trilogy a few days ago. My Wii has absolutely no modifications and is running 4.0E.
    I've run the game a few times and it's never asked to update.