Mario Advance 4 problem

Discussion in 'GBA - Emulation' started by MidniteBlaze, Aug 16, 2010.

Aug 16, 2010

Mario Advance 4 problem by MidniteBlaze at 3:54 AM (1,673 Views / 0 Likes) 4 replies

  1. MidniteBlaze
    OP

    Newcomer MidniteBlaze Member

    Joined:
    Mar 11, 2010
    Messages:
    36
    Country:
    Venezuela
    I dumped my SMA4 cart's save to the computer in order to connect SMA4 to an eReader rom so I can upload level cards and restore the save back to the original cartridge. The problem is that every time I try to open the save with no$GBA, it formats my save. I can load it fine with VBA Link, VBA Tradelink, and other different versions of VBA, but No$GBA always deletes the save when I load it.

    I've tried exporting the save with VBA and nothing. Google tells me that VBA saves are compatible with No$ no matter what :S

    Any help would be appreciated, thanks.
     
  2. Ammako

    Member Ammako GBAtemp Guru

    Joined:
    Dec 22, 2009
    Messages:
    6,372
    Country:
    Canada
    Edit NO$GBA.INI

    Change "SAV/SNA type" from "Compressed/Uncompressed" to "Raw"
     
  3. MidniteBlaze
    OP

    Newcomer MidniteBlaze Member

    Joined:
    Mar 11, 2010
    Messages:
    36
    Country:
    Venezuela
    I tried that, but every time I run SMA4 on No$GBA, it keeps saying "formatting saved data". This doesn't happen on VBA, but I noticed that even VBA Tradelink doesn't keep the save after importing unless I use a save state. If I want to keep the save I have to rename the save from .sav to .sa1.

    I'm using Windows 7, if that helps.

    Edit: I gave up and just tried to scan the cards by linking SMA4 to the eReader on No$GBA, but the game won't communicate with the eReader ROM. SMA4 keeps saying "unable to communicate".

    Edit2: After a lot of Googling, I solved the problem. I had to download a specific eReader save to connect it to SMA4.
     
  4. Shugo Takahashi

    Newcomer Shugo Takahashi Advanced Member

    Joined:
    Oct 25, 2006
    Messages:
    80
    Country:
    United States
    I was just about to make this thread, but saw this and decided to post in here.

    I have basically the same issue as this guy. I dumped by SMA4 save for e-Reader content and while VBA runs it just fine, NO$GBA crashes if it tries to load the ROM. The "Game Boy Player" compatibility screen comes up and once it fades, Windows 7 tells me that NO$GBA has stopped functioning.

    I've Googled and Googled and tried all sorts of methods, including the changing save type to "Raw" method. NOTHING works. Would someone please help?

    EDIT: And by the way, does anybody have the e-Reader save needed for this method? MidniteBlaze, maybe? Every link I've found is broken. While I COULD just dump the save from my real e-Reader, I'm guessing it would have the same load problem in NO$GBA as SMA4...
     
  5. Shugo Takahashi

    Newcomer Shugo Takahashi Advanced Member

    Joined:
    Oct 25, 2006
    Messages:
    80
    Country:
    United States

Share This Page