Hardware M92 line 6 0v, 1 short and pulling .46 no power

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
I have checked the m92, p13, and charge port, no shorts besides the one I found.
I did replace the m92 and the dual channel mosfet above it. Still nothing, and this was before I shamefully found the short on that Cap.

I checked battery and it was at 3.8v, plugged in and charged with switch for 15 minutes, checked again and was at 3.92. So I feel it's safe to assume it's charging?

On m92 pin 6 is 0v but pin 5 4.4?
I also have a shorted cap just below the chip I will attach a picture. There are no shorts around p13 and bq, but the ALC chip with the crab on it has a shorted cap and I will attach a photo.

Now just to add on to the amazing dumpster fire here, another chip to the right of ALC has shorted caps and I will attach a pictures if those as well.

Any ideas would be nice. This console is sentimental to me.


Ive been microsoldering a while so im confident with that, but im still very new to actually reading the board and understanding how to follow a component to the issue.

Id like to post pictures but it will not allow me.
 
Last edited by Prophecy1059,

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
I cheched the volatge going through to the m92 and im getting up to 14 in some spots and 4 in others, besides the Pin 6 of course, pin 1 of bq is pulling 14.93. and the batteries charge is going up as we.. But no charging symbol or life coming from device. pins 8 and i think 10 on the charging port are going up and down rapidy on voltage.

Cpu is getting hot with plugged in.
 

jkyoho

Well-Known Member
Member
Joined
Sep 2, 2020
Messages
151
Trophies
0
Age
37
Location
TORONTO
Website
form.jotform.com
XP
503
Country
Canada
If pin6 0v, I would check Pi3usb ic bottom big Cap if that's shorted.
If this cap shorted, remove pi3usb and check it again.
 

Attachments

  • pin6-short.png
    pin6-short.png
    1.1 MB · Views: 67
  • Like
Reactions: Prophecy1059

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
If pin6 0v, I would check Pi3usb ic bottom big Cap if that's shorted.
If this cap shorted, remove pi3usb and check it again.
So that is not shorted unfortunately, nothing around p13 is. The cap just below the m32, it had 3 100k resistors to the left of it is. And that line 6.

Also side note, all the way to the left past the cpu, that area with bunch of caps and small black chip in the middle, I was testing testing shorts and my meter gives off a rumble noise instead of actuakky beeps?! Any idea what's happening lol.

--------------------- MERGED ---------------------------

--------------------- MERGED ---------------------------

--------------------- MERGED ---------------------------

Also this is the area next to the cpu I was talking about, and if I'm seeing 15v while plugged into nintendo charging doesn't that mean I'm getting fast charge? 16296827837317189037567292501425.jpg
 

Attachments

  • 20210822_163209.jpg
    20210822_163209.jpg
    1.8 MB · Views: 55
  • 20210822_162644.jpg
    20210822_162644.jpg
    1.7 MB · Views: 62
  • 20210822_162650.jpg
    20210822_162650.jpg
    1.2 MB · Views: 63

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
If pin6 0v, I would check Pi3usb ic bottom big Cap if that's shorted.
If this cap shorted, remove pi3usb and check it again.

I have access to my thermal cam now, any ideas? its right ontop of screen connector.
 

Attachments

  • 2021-08-23 10-45-30.JPG
    2021-08-23 10-45-30.JPG
    483.4 KB · Views: 66

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
check your lcd fpc connector pins inside if any bent.

upload my lcd connector diode measure for reference
Ohhh my.

So i was able to unbend those pins, one broke, of course. I have a donor board. and all of those shorts disappeared, even the bottom cap beneath the m92 and the ones on the back, now there is something shorted to the left of the fpc connector, not sure if its supposed to be. they look kinda bad.

UPDATE- so ic hecked a known good mb, and thos caps are shorted on it as well, but im pretty sure its not a cap, its a larger one.
 

Attachments

  • 20210823_123139.jpg
    20210823_123139.jpg
    2 MB · Views: 63
  • 20210823_123046.jpg
    20210823_123046.jpg
    1.1 MB · Views: 56
Last edited by Prophecy1059,
  • Like
Reactions: HollowGrams

HollowGrams

Well-Known Member
Member
Joined
Nov 27, 2020
Messages
628
Trophies
0
Age
42
XP
647
Country
United States
Ohhh my.

So i was able to unbend those pins, one broke, of course. I have a donor board. and all of those shorts disappeared, even the bottom cap beneath the m92 and the ones on the back, now there is something shorted to the left of the fpc connector, not sure if its supposed to be. they look kinda bad.

UPDATE- so ic hecked a known good mb, and thos caps are shorted on it as well, but im pretty sure its not a cap, its a larger one.


Best bet to remove and replace.
 

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
LCD Connector if bent pins etc. You can try to bend back too.
I soldered new connector on, the old digi and lcd I'm trying to use is VERY BAD, and slightly torn. when docked it shows up, it is touching but I'm sure the lcd is dead. It only pulls .46 then goes to .09 no shorts on p13 but m92 pin 6 is pulling 12v with charger and pin 5 is pulling 12.4. This is on an Amp reader. So it's still not charging correctly. I did replace m92 but not with a new one, I have some new ones coming in tomorrow. Do yall think it's m92?

When docked i cant get it to respond with joycons. When taken out it doesnt normally respond with joycons but i can touch around the screen and i will hear it touching.
 

Attachments

  • 20210823_155757.jpg
    20210823_155757.jpg
    856.7 KB · Views: 59
  • 20210823_155733.jpg
    20210823_155733.jpg
    1,011.7 KB · Views: 62
Last edited by Prophecy1059,

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
Sooooo, it turns out my amp reader was reading very wrong, tried new reader with same cable and its opulling 1.84, both joycons work after reseating but the switch doesnt disply unless docked, is this just an lcd issue or something more?
 
Problem Solved

Prophecy1059

Member
OP
Newcomer
Joined
Aug 22, 2021
Messages
23
Trophies
0
Age
22
XP
20
Country
United States
LCD Connector if bent pins etc. You can try to bend back too.
Switch is working 100% now, needed to reflow the lcd connector, and run a jumper for the pad that was burnt, works like a charm. Never realized so many issues could be cause by that connector. Thank you Everyone!

If anyone is having same symptoms I did, do the normal and check the fuse infront of usb c, then check m92 line 5 an 6 with charger in, if there is a OL then your problem is either m92or p13, if no issues on m92 check BQ. If you have that same capacitor out that I did, start checking your lcd connector.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Pickle_Rick @ Pickle_Rick: