M3 Real Emulation problems.

Discussion in 'NDS - Emulation and Homebrew' started by Technic, Mar 24, 2008.

Mar 24, 2008

M3 Real Emulation problems. by Technic at 9:57 PM (1,502 Views / 0 Likes) 7 replies

  1. Technic
    OP

    Newcomer Technic Newbie

    Joined:
    Mar 24, 2008
    Messages:
    4
    Country:
    United States
    I just bought the m3 real. I DO NOT have the slot 2 ram expander for it. I am using SNEmulDS and have followed all of the instructions. I have the SNEMUL.CFG and SNEMULDS.NDS in the F:\ and i have the roms in F:\SNES. the program boots up fine but will not find any roms. i tried reformating the microsd card from a FAT to a FAT32 multiple times. I tried putting the rom files in .zip. I tried different Emus also. All of my "back up" games work fine. If someone can please for the love of god help me [​IMG]

     
  2. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    This is a longshot, but it helped a Games N' Music user recently. Try opening the snemul.cfg file and changing the path from "/SNES" to "/SNES/" (just add the extra slash at the end). I have no clue why this worked for him, but hopefully it might help here.

    Otherwise you seem to be doing everything correctly. Just to be sure however, what format are your games currently in?
     
  3. Technic
    OP

    Newcomer Technic Newbie

    Joined:
    Mar 24, 2008
    Messages:
    4
    Country:
    United States
    I have tried adding the / at the end of SNES and still nothing. And the rom files are just the files that they are NOT Zip. i have tried zip files and they do not work eather.
     
  4. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    Even if they're not zip files, they could be any number of other files. In Windows Explorer, go to Tools - Folder Options - View - uncheck "hide extensions for known filetypes"

    Then post what file extension they have.
     
  5. Technic
    OP

    Newcomer Technic Newbie

    Joined:
    Mar 24, 2008
    Messages:
    4
    Country:
    United States
    I did that they just say file. i see the other extensions like .nds or .cfg. what are snes games extension.
     
  6. TheWingless

    Member TheWingless Wafuu~

    Joined:
    Jan 29, 2008
    Messages:
    1,034
    Country:
    United States
    SNES extensions should be .smc.
     
  7. Technic
    OP

    Newcomer Technic Newbie

    Joined:
    Mar 24, 2008
    Messages:
    4
    Country:
    United States
    well that fixed that. they need to be named .smc so does anyone know a good file re namer i really dont want to go through all of these roms and change the name of all of them.
     
  8. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    EDIT: I'm a friggin idiot. Use GoodSNES or something to rename it rather than my suggestion. The command "goodsnes rename inplace" will rename all your games.


    Original post:
    Well yeah, if they don't have any extension SNEmulDS isn't going to recognize them. That would be the issue.

    You could possibly whip together a batch script that will do it. The following will work, though it will do EVERY file in the folder it's run in.
    Code:
    FOR %%F in (*) do COPY /Y "%%F" "%%~nF.smc"
    Put that in Notepad, save it as "go.bat", put it in the folder of SNES games, and double-click it

    Again, this will affect every file in the folder, including the batch file itself. It makes new copies of each file rather than renaming, but it will overwrite old copies without asking, so be careful. I'd suggest running it in a folder containing nothing but your SNES games and then deleting the "go.smc" that's produced.

    I'm sure there are more elegant solutions out there, but I'm too tired to give much more effort at the moment.
     

Share This Page