M3 & Pokemon RTC real time clock

Discussion in 'GBA - Flashing Hardware and Software' started by touchofgray, Dec 27, 2006.

Dec 27, 2006
  1. touchofgray
    OP

    Newcomer touchofgray Newbie

    Joined:
    Dec 7, 2006
    Messages:
    5
    Country:
    United States
    Sorry if this has been asked before, but the search function is not working on phrases, only single keywords, so I'm having trouble finding the answer.

    Just got an M3 mini-SD Perfect for my kid's GBA SP. I grabbed the 1003 (to-date) US releases and loaded a bunch onto the mini-SD card. Just about everything I tried appears to work fine with the exception of (this should be no surprise) Pokemon Saphire, Ruby, and Emerald which all load into a white screen of death.

    0898 - Pokemon - Sapphire Version (U).gba
    0907 - Pokemon - Ruby Version (U) (v1.0).gba
    1986 - Pokemon - Emerald Version (U).gba

    I tried the patch from nofrills and that did not work. Any suggestions? The M3 is supposed to support the RTC (real time clock) so I'm puzzled.

    Are there any other games troublesome on the M3? These are pretty much the ones I anticipated would present a challenge.

    BTW, I extracted most of these ROMs out of an Xbox Xiso file found on demonoid. I don't know if there was a specific patch already applied to these files so that they would work with the emulator for the xbox, and no, I have not tried anything through emulation. Is there a preferred source for clean unpatched ROMs to start with?


    Any suggestions would be greatly appreciated.

    TIA!
     
  2. kazumi213

    Member kazumi213 GBAtemp Regular

    Joined:
    Oct 16, 2006
    Messages:
    293
    Country:
    Spain
    The "clean" CRC for the mentioned Pokemon ROMs are the following:

    0898 - Pokemon - Sapphire Version (U) 554dedc4
    0907 - Pokemon - Ruby Version (U) f0815ee7
    1986 - Pokemon - Emerald Version (UE) 1f1c08fb

    You can verify the CRC by opening the (usually) .zip file into your preferred app and looking to the CRC column. You may need to set view options to see that column. If already uncompressed (you have .gba files) easiest way to check for CRC is to compress all of them to a temporary .zip and then check their CRC.

    After you've verified you've got the clean ROMs, use GBATA (http://www.gbadat.altervista.org/tools.htm) to RTC-patch Ruby and Sapphire (Clock Fix tab). Then try to run these patched ROMs from your M3.

    For Emerald, download http://www.advanscene.com/html/Releases/relfile/trm-pmeu.zip

    Inside there is an .ips file. Apply to Emerald using GBATA (IPS Patch tab) and try to run it from your M3. Not sure if this .ips is designed to fix RTC, but it won't hurt to try.

    By the way, I suggest you to get

    2011 - Pokemon - Sapphire Version (UE) (v1.2) 9cc4410e

    as this is the latest US version available for Sapphire.

    Hope this helps.
     
  3. meteora91

    Newcomer meteora91 Advanced Member

    Joined:
    Aug 12, 2006
    Messages:
    52
    Location:
    Sydney, Australia
    Country:
    Australia
    Hehe, a little stupid thing i did myself.
    For Pokemon Emerald.
    If your card is FAT32, you can just drag the rom onto your sd card and it should run perfectly. If you want real-time save, patch it through the M3 Manager and it runs perfect as well.
     
  4. cenotaph

    Member cenotaph GBAtemp Fan

    Joined:
    Oct 24, 2006
    Messages:
    341
    Country:
    United States
    I've had some problems with the Pokémon games and RTC as well on my M3. Sometimes it works, at other times the game tells me the "battery has run dry" when I boot it -- resetting the DS usually makes this go away.
     
  5. Knab

    Member Knab GBAtemp Fan

    Joined:
    Jul 6, 2006
    Messages:
    306
    Country:
    United States
    also when loading the rom from the m3 use "Start" not "A", "A" gives white screens alot lol i havent found a gba game that loads when you use the "A" button
     
  6. cenotaph

    Member cenotaph GBAtemp Fan

    Joined:
    Oct 24, 2006
    Messages:
    341
    Country:
    United States
    Depends on what filesystem you use. If you use FAT32, starting games by pressing "A" works just fine. If you use FAT16 however, you have to use "start.
     

Share This Page