Hacking Luma 3ds + 3ds latest Update help Required error 009-2920

shanefromoz

Well-Known Member
OP
Member
Joined
Jun 18, 2007
Messages
1,841
Trophies
0
XP
3,271
Country
Australia
Hello all,

I have a 3ds running Luma 3ds which is updated to the latest release.
I go into a game Like Pokemon Ultrasun and it tells me there is a game update waiting.
I try to download update but get error 009-2920.
How can i fix this please without losing my game saves?
Thank you
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KennieDaMeanie @ KennieDaMeanie: Eh I have too many Sony consoles I can already emulate Ps2 on