LoZ Phantom Hourglass problem.

Discussion in 'Other Flashing Hardware & Software' started by Kniteshade, Jun 20, 2007.

Jun 20, 2007
  1. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    Using a DSLinker 8G with latest firmware. Can't seem to save in Phantom Hourglass. It's like the game auto erases the save file, I start playing, I save my progress, I turn my DSLite off, I turn it back on to resume play and my savefile has been reset. Reset as in it has my file there but I'm back at the start. I turn it off again, and on and my savefile is completely gone then.

    Seems to only be a problem with Phantom Hourglass, my other ROMs' savefile on the card are still intact. I'm using Flash 2Mb so it's not the wrong savetype (the other two won't even start up the game).

    Anybody else with the problem?
     


  2. KINGOFNOOBS

    Member KINGOFNOOBS GBAtemp Advanced Fan

    Joined:
    May 28, 2006
    Messages:
    706
    Country:
    United States
    Try deleting your save and game from your DSLinker and putting it back on there. If that doesn't work, it might be your battery, do other games save?
     
  3. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    Nah, no luck.

    My other games on the card save fine, never once had a problem with saves before. Opened FFIII, saved somewhere random, off, on, resume, at the random spot, opened Pokemon D, saved in random spot, off, on, resume, no problems.

    I wiped PH off my card and loaded a untrimmed one on, still the same problem. I noticed it always "scans" (for lack of a better term) the files every time after the title screen. But this is when I save using the Start button and revert back to title screen in game. When I save and turn off the DSL, and resume, there is no "scan" at all; the savefile disappears automatically.

    Is the game working normally for you, KingofNoobs?

    EDIT: Minor update. I noticed the untrimmed ROM doesn't even produce a .Sav file on my card. But a trimmed ROM does. wtf...
     
  4. KINGOFNOOBS

    Member KINGOFNOOBS GBAtemp Advanced Fan

    Joined:
    May 28, 2006
    Messages:
    706
    Country:
    United States
    Yeah it works fine. Hmmm, Try switching the save type to something else then switching back to 2Mbit.
     
  5. go185

    Member go185 GBAtemp Regular

    Joined:
    Jun 18, 2006
    Messages:
    230
    Country:
    your way of saving might be like quicksave in FFIII
     
  6. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    @go185:

    Well isn't it: the Menu down bottom left, the red square, then the top option? And the other way is Start, bottom option to save, then on the next prompt the top is to title screen and the bottom is to continue.

    And yeah, I tried switching savetype and back like KingofNoobs said. Nothing happened except that DSLinker somehow created another .sav file of Phantom Hourglass.
     
  7. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    Update. Seems to be a widespread problem. Other people using the DSLinker are having this problem, people over at the Neoflash boards are having the same problem with their MK5s. Have seen one other person on this board with the same problem as me.

    Which firmware are you using and which version, KingofNoobs?? xD
     
  8. KINGOFNOOBS

    Member KINGOFNOOBS GBAtemp Advanced Fan

    Joined:
    May 28, 2006
    Messages:
    706
    Country:
    United States
    Well I have 2 N-Cards, on this one I am still using the first firmware.
     
  9. thegame07

    Member thegame07 GBAtemp Psycho!

    Joined:
    Oct 16, 2006
    Messages:
    3,860
    Country:
    United Kingdom
    It saves fine for me on a N-card latest firmware.
     
  10. Achilles

    Member Achilles GBAtemp Regular

    Joined:
    Feb 28, 2005
    Messages:
    160
    Country:
    United States
    I've got an N-Card and a DS Fire Link both flashed with the latest DS Linker firmware - the one with the badass new interface. The N-Card has the save issue... the game like resets me back to the beginning or the saved game is just gone. I haven't tried the DS Fire Link, but will test it very shortly and let people know... Is it possible that Zelda uses a 4MBit saved game and these cards are truncating the save?
     
  11. thegame07

    Member thegame07 GBAtemp Psycho!

    Joined:
    Oct 16, 2006
    Messages:
    3,860
    Country:
    United Kingdom
    does the save always disappear because i only saved it at the start of the game just to test it and everythings fine [​IMG]
     
  12. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    I'm starting to think it's a new savetype. Our cards only create 256KB .sav files but I think it needs 512KB ones now, hence why R4 and most Slot 2s are spitting out and needing/looking for 512KB .sav files.

    @thegame07: Nah, actually play deeper into the game, then test out the save. I tested out saving at the start a few times and it does work (psh, 2 out of 10 times. Sigh) sometimes, but it later erases itself.

    I'm gonna wait a few days to see if the DSLinker team will give an update on the issue before looking for a N-Card firmware.
     
  13. zombielove

    Member zombielove GBAtemp Regular

    Joined:
    Jun 3, 2007
    Messages:
    270
    Country:
    Australia
    I just created a game yesterday, walked around a bit then turned it off. Tried it out today and my game was still there. I played from that file and tried saving in-game. Turned it on and off. It was searching for my save file, but didn't find anything. Save disappeared.
     
  14. Scorpin200

    Banned Scorpin200 Iceman

    Joined:
    Jan 14, 2006
    Messages:
    1,098
    Location:
    Maryland
    Country:
    United States
    What are you using i just played the game, and had no problems with saving.
     
  15. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    There's no problem with saving. There's a problem with it disappearing on its own.
     
  16. zombielove

    Member zombielove GBAtemp Regular

    Joined:
    Jun 3, 2007
    Messages:
    270
    Country:
    Australia
    I've got a DS Linker 16GB and using the DS Linker 1.39 firmware.

    @scorpin200 - Have you tried saving in the game and resetting a few times? Mine seems ok for a few saves, then just randomly deletes the save.

    Edit: Kniteshade, I think you're right. A guy on the dslinker forums was saying he tried it on No$GBA and it saves as 512kb flash.
     
  17. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    Wow. Weird. I played straight up til the first dungeon (Fire Island), died a bit after obtaining boomerang. The intro screen popped up and I thought "Ohisht, I forgot about that". But my save file was still there and it loaded from my last save (I saved here and there just for the hell of it along the way). O_O

    Care to try that out, zombielove? Might be just coincidence. This save file problem has led to trying to play the game without dying now.
     
  18. sidneyyoung

    Member sidneyyoung GBAtemp Advanced Fan

    Joined:
    Nov 29, 2006
    Messages:
    895
    Country:
    Bermuda
    I don't have a Ncard or clone, but has anyone tried making a save, then backing it up to PC and appending extra bytes to it to make it 512kb ? then put the save back, but start a new game and hope it holds.
     
  19. Kniteshade
    OP

    Newcomer Kniteshade Member

    Joined:
    Apr 29, 2007
    Messages:
    49
    Country:
    Australia
    How do you do that though? I tried using the R4's .sav (512KB) for the hell of trying anything. Nothing happened. >_>;
     
  20. sidneyyoung

    Member sidneyyoung GBAtemp Advanced Fan

    Joined:
    Nov 29, 2006
    Messages:
    895
    Country:
    Bermuda
    you could try this.. http://www.kibria.de/

    add 262144 bytes for 512kb file

    you never know, it might work
     

Share This Page