LoneWolfDS - Caverns of Kalte v1.5 released

Discussion in 'NDS - Emulation and Homebrew' started by Michoko, Jul 2, 2010.

  1. Michoko
    OP

    Michoko Advanced Member

    Newcomer
    57
    0
    Jan 29, 2008
    France
    Hi!

    Thanks to the feedback from many people after the release of the candidate version of Caverns Of Kalte, I was able to fix some bugs in book 3 and tweak the code so the game works on many linkers now. This is hopefully the final version and is a recommended update! [​IMG]

    So here it is, version 1.5 of Caverns of Kalte. Why 1.5 and not 1.0? Because I decided to make a massive release and relaunch the previous titles too, which will then take advantage of the latest improvements (better engine, all the musics from the different books, different preview icons in the linker menu, enhanced compatibilty...). So in order to synchronize all the versions, I used a common release number.

    By the way, the Spanish version of Book 1 has also been updated.

    You can get all those new files here: http://www.projectaon.org/staff/frederic/index.php

    (as always, please don't host the ROM on your site but use the above link instead, as required by the Project Aon licensed! Thanks!)

    Also, for those who own a DSTwo, adrian_fahrenheit made cool plugins for the first 3 books. You can get them here:
    http://filetrip.net/f12061-DStwo-Lone-Wolf...lug-in-1-0.html
    http://filetrip.net/f12062-DStwo-Lone-Wolf...lug-in-1-0.html
    http://filetrip.net/f12063-DStwo-Lone-Wolf...lug-in-1-0.html

    Please spread the word and have fun!

    Happy downloading! [​IMG]
    Frédéric Calendini

    PS: started working on Book 4...
     
  2. bason230

    bason230 GBAtemp Regular

    Member
    141
    0
    Jun 15, 2010
    In my atelier 8D
    Yay! I've tested them out, they look even more awesome than before!
    Thanks a lot on this, and good luck for the next volume =D
     
  3. Stavros90

    Stavros90 Member

    Newcomer
    21
    0
    Jun 9, 2009
    United States
    This is the first time I've seen this and it's awesome. The interface is simple but pleasing to the eye and I love that atmospheric music. Keep up the good work!
     
  4. kyste

    kyste Member

    Newcomer
    38
    0
    Mar 27, 2010
    France
    Choose-your-own-adventure books on the DS! Awesome. Thanks for the hard work.


    Only thing is, it makes me feel so old now. My 20 years old cousins don't even knwo what those were. [​IMG]
     
  5. saviorkross

    saviorkross Advanced Member

    Newcomer
    78
    5
    Mar 16, 2008
    United States
    'Caverns of Kalte' tested and working well on an original R4 with Wood R4 v1.09. I haven't decided if I'm going to go back and go through from the beginning or not, so I may update later if the first two are working with this version as well.

    Thanks for all the hard work and breathing life into these classics. [​IMG]
     
  6. Michoko
    OP

    Michoko Advanced Member

    Newcomer
    57
    0
    Jan 29, 2008
    France
    Hi,

    Ok, it seems that a few nasty bugs were still present in the previous global release of the books, sorry about that! [​IMG]
    So now they are hopefully fixed, I'm doing a "hotfix release" which, of course, is a recommended download.

    Here's the changelog:
    The files are always present at the usual address: http://www.projectaon.org/staff/frederic/index.php

    Have fun!
    Frédéric
     
  7. Crossborder

    Crossborder Newbie

    Newcomer
    4
    0
    Jul 5, 2010
    Netherlands
    Man, I've been looking forward to this ever since I first came upon your website. I've never seen any of the gamebooks, so many thanks to you for pointing me to them. And for your awesome homebrew, of course!
     
  8. go2_ars

    go2_ars Member

    Newcomer
    17
    0
    Nov 16, 2009
    Hey, it works on Acekard2i now!!!
     
  9. Aaronius

    Aaronius Member

    Newcomer
    16
    0
    Jun 17, 2009
    United States
    Does this work on Wood r4?

    EDIT: LOL never mind. I didn't see the comment [​IMG]
     
  10. Hrip

    Hrip Newbie

    Newcomer
    1
    0
    Jul 11, 2010
    United States
    Moscow
    I'm on AceKard 2i too, but it won't work((
    It's just infinite loading...

    Somebody help me!!

    Test on Original 4.22 and Akaio 1.7, 1.6 and 1.5 - all the same...
     
  11. papavader

    papavader Member

    Newcomer
    22
    0
    Sep 29, 2006
    Canada
    Tried it on IEDGE last night, crashed just before the weapon choosing. Will try to manually DLDI patch it tonight.
     
  12. arogance1

    arogance1 GBAtemp Fan

    Member
    458
    7
    May 17, 2008
    UK
    Crashes on Sakura, not tried with latest release though.
    Haven't manually DLDI patched though, since I have no idea how to do it
     
  13. papavader

    papavader Member

    Newcomer
    22
    0
    Sep 29, 2006
    Canada
    http://gbatemp.net/?showtopic=45157
     
  14. papavader

    papavader Member

    Newcomer
    22
    0
    Sep 29, 2006
    Canada
    Well I tried patching it with the CycloDS evo dldi (since edge is basically the same card) and no dice. Blocks just before the equipment select. Looks like those of use with iEdges are out of luck. Will try on my old G6. If it saves my games... [​IMG]
     
  15. arogance1

    arogance1 GBAtemp Fan

    Member
    458
    7
    May 17, 2008
    UK
    Tried to DLDI patch and the game loads to a white screen, never passes it.

    I used the M3 DLDI patch as there isn't a M3 Sakura specific one.
     
  16. Michoko
    OP

    Michoko Advanced Member

    Newcomer
    57
    0
    Jan 29, 2008
    France
    @arogance1
    Did you try the latest version (v1.51 ?)
     
  17. arogance1

    arogance1 GBAtemp Fan

    Member
    458
    7
    May 17, 2008
    UK
    I tried after the 1st post came out, can't remember if it was 1.5 or 1.51.
    I'll give it another go tonight
     
  18. arogance1

    arogance1 GBAtemp Fan

    Member
    458
    7
    May 17, 2008
    UK
    I have tried Book 4 as well.
    Doesn't work on Sakura, works on Touchpod
     
  19. Michoko
    OP

    Michoko Advanced Member

    Newcomer
    57
    0
    Jan 29, 2008
    France
    Ok thanks for your feedback arogance1.

    Unfortunately, I don't own a Sakura, and since it seems to work on many other linkers, I'm afraid it's specifically related to this model. That will be very difficult for me to find the source of the problem...
    There may be some possible alternatives to try though, like launching LoneWolfDS through a third party program like DSOriganize or HBMenu...
     
  20. arogance1

    arogance1 GBAtemp Fan

    Member
    458
    7
    May 17, 2008
    UK
    With M3 Sakura, you can easily switch to Touchpod.
    So, I have now finished the 1st 3 books, onto book 4 now.

    Thanks