Loco Roco Midnight Carnival PSN- 6.30 required?

Discussion in 'PSP - Games & Content' started by manobon, Jun 30, 2010.

  1. manobon
    OP

    manobon GBAtemp Regular

    Member
    175
    1
    Jul 22, 2008
    United States
    Now that it's at a super cheap price, I was wondering if anyone else has bought Loco Roco Midnight Carnival yesterday (or today), and knows whether or not it requires 6.30 OFW.

    I like supporting the game developers/publishers, and PSN game sales, but I do like my homebrews/HBL.
     
  2. ut2k4master

    ut2k4master Lord Tourettes

    Member
    749
    334
    Feb 20, 2010
    Germany
    i dont think so, atleast it doesnt for europe
     
  3. steve-p

    steve-p GBAtemp Advanced Fan

    Member
    503
    0
    Apr 13, 2009
    most psn needs 5.55

    dont confuse this with the lame release:
    LocoRoco_Midnight_Carnival_USA_MULTi15_PSN_PSP-NRP
    that says "DEMO" on the intro screen!