Loading ROMS from DVD in FCE Ultra GX

Discussion in 'Wii - Emulation and Homebrew' started by PuyoDead, Sep 6, 2009.

Sep 6, 2009
  1. PuyoDead
    OP

    Member PuyoDead Hey! Hey! Oh!

    Joined:
    May 5, 2003
    Messages:
    698
    Location:
    Cincinnati, OH
    Country:
    United States
    So, I'm yet to get this to work properly. Every other emulator I've used loads from DVD fine (SNES9x GX, VBA GX, etc.), yet FCE Ultra GX always says the games directory is inaccessible. I've put them in /NES and tried /fceugx/roms with no luck either way. I also tried changing the load directory in the xml settings to point to the specific directory, but I still get the same error. Again, DVD loading is fine everywhere else (yes, I'm setting load to DVD and yes DVDx is installed properly). Any ideas what I'm doing wrong?
     
  2. pepxl

    Member pepxl GFX W!Z4RD

    Joined:
    Jun 19, 2009
    Messages:
    3,263
    Country:
    United Kingdom
    it should be working fine off a dvd, make sure you have the latest rev, you are best off compiling the source
     
  3. PuyoDead
    OP

    Member PuyoDead Hey! Hey! Oh!

    Joined:
    May 5, 2003
    Messages:
    698
    Location:
    Cincinnati, OH
    Country:
    United States
    Well, I got it from the Homebrew Browser, which was the current version of 3.0.8. But, I went ahead and downloaded it directly from their site and replaced it, yet I still get the same error. I have zero experience with compiling, so I'm hoping it doesn't come to that. But considering the situation, I don't see why this doesn't work.

    edit: are there any limitations to fce ultra gx? Such as the amount of files in a directory, total files on disc, total disc size, etc.
     
  4. Jacobeian

    Member Jacobeian GBAtemp Advanced Maniac

    Joined:
    May 15, 2008
    Messages:
    1,879
    Country:
    Cuba
    if the same DVD works in other emulators, try to reset the settings or delete the xml file manually, it should start from the root of the DVD by default
    if not, be sure it's in the correct data file format (iso9660) and is readable by DVDx (DVD-R or DVD+R with DVD-VIDEO booktype)
     
  5. PuyoDead
    OP

    Member PuyoDead Hey! Hey! Oh!

    Joined:
    May 5, 2003
    Messages:
    698
    Location:
    Cincinnati, OH
    Country:
    United States
    Ok, I finally got it to work! I had used MagicISO before, and I'm not sure where it failed (I built two images to burn, both failed), but it seems FCE Ultra GX didn't like it. It was all set to iso9660 (and with a DVD-R no less), yet it just didn't take.

    I tried imgburn this time, rebuilt everything, and set it to iso9660 + Juliet + UDF (with a DVD-R again). It seems that did the trick. I still don't know what exactly caused it to not work before, but MagicISO is a bit limited in its burning options.
     

Share This Page