list of ps1 games that works on 5.50 gen d3

Discussion in 'PSP - Games & Content' started by don_eno, Apr 1, 2010.

  1. don_eno
    OP

    don_eno GBAtemp Regular

    Member
    124
    2
    Dec 28, 2009
    Greece
    i want to know what ps1 games works without problems on 5.50 gen d3.
     
  2. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
  3. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    Looks like you'll be needing GENder Reassignment!
     
  4. chartube12

    chartube12 GBAtemp Psycho!

    Member
    3,158
    471
    Mar 3, 2010
    United States
    I used to use m33 until they stopped updating it. I went to ofw 5.50 than went back to cfw.I use The lastest Gen. Everything works just as well on it. The compatiblity issues were solved a while ago. Besides Gen comes with the M33 plugin for iso.

    Who wants to patch a game everytime? Plus with the lastest Gen lets you use the psn store. However thats only if you didn't go from m33 to gen. Something from m33 gets left and the store wont work than. Thats why when i switched i went to ofw first than gen.
     
  5. UltraMagnus

    UltraMagnus hic sunt dracones

    Member
    1,967
    0
    Aug 2, 2007
    Portsmouth
    use popsloader, that way you have the compatibility of all versions that came before yours.
     
  6. chartube12

    chartube12 GBAtemp Psycho!

    Member
    3,158
    471
    Mar 3, 2010
    United States
    I nearly forgot. I have popsloader and both cheat plugins installed as well.
     
  7. CrashmanX

    CrashmanX Current project: SD Gundam G Generation Overworld

    Member
    1,215
    152
    Aug 1, 2008
    United States
    @CrashmanX
    Also should a game not work, re-create it using PSX2PSP with the correct Number (SLUS, SUES, etc.)
     
  8. don_eno
    OP

    don_eno GBAtemp Regular

    Member
    124
    2
    Dec 28, 2009
    Greece
    probably the best solution is to test every game and see for myself. please tell me if i can play ff7.
     
  9. Kamina84

    Kamina84 Advanced Member

    Newcomer
    60
    0
    Feb 13, 2009
    United States
    Pretty much. :\ You'll have to experiment with what pops works with what. I can tell you right now, 3.40 pops is completelly useless in Gen D3. Only reason i stayed with D3 for as long as i did was because it was the only Firmware to play GvG Next+ at the time. [​IMG] Stick with M33. It's not like you can log on PSN with GEN D3 either. [​IMG]
     
  10. melvox

    melvox GBAtemp Regular

    Member
    142
    0
    Dec 17, 2008
    I have this guide just view it before you do anything...

    PSP - PSX Compatibility List

    You can just check here.

    EDIT: Oh, wait...it's been posted...sorry...i'll just leave the link here....
     
  11. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    5,484
    751
    Nov 6, 2002
    Portugal
    Proud to be Portuguese but I am in USA.
    5.50 GEN-D3:

    Klonoa Door To Phantomile USA
    Megaman 8 USA

    They works perfectly fine.