Linux + Flash Advance

Discussion in 'GBA - Flashing Hardware and Software' started by solarsaturn9, Mar 17, 2008.

Mar 17, 2008

Linux + Flash Advance by solarsaturn9 at 7:07 PM (1,421 Views / 0 Likes) 7 replies

  1. solarsaturn9
    OP

    solarsaturn9 Newbie

    Hey everyone, I have a dilemma and I'm wondering if anyone else has run into this...

    I have recently switched to Linux ( running Ubuntu Gutsy ) and I have an old Flash Advance 256 card. The problem is the linker I have is so old that it uses the parallel port. I have not been able to find any software or workarounds to support LittleWriter on Linux. I've already tried using Wine but I can't seem to get it to work. I've also tried using VirtualBox but to my dismay it does not support parallel ports. I am stuck.

    I would really rather not buy a USB linker as I do not have any money on me at the moment ( U_U school... ), but I do realize that they are faster. I don't know if any of them support my old Flash Advance. Also, since I'm running Linux I imagine that only the drag and drop type devices would be worth investing in. Reasons why I would much rather just find a solution using what I've got...

    Is anyone in my situation? could anyone offer some good advice?

    Thank you for your time guys! [​IMG]
     
  2. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,716
    Country:
    United Kingdom
  3. Psyfira

    Member Psyfira Credit: 0ml. Insert tea to continue

    Joined:
    Dec 31, 2003
    Messages:
    3,887
    Location:
    England
    Country:
    United Kingdom
    Just been playing around on google, not much out there except this: http://ucon64.sourceforge.net/index.php
    I'll admit to having very little idea of what this program actually does, from the readme it sounds like it can write to / from the cart using a parallel linker but the instructions leave little to be desired. You can probably make more sense of it than I can.
     
  4. solarsaturn9
    OP

    solarsaturn9 Newbie

    Thank you all!

    Ucon is working like a charm!

    Many thanks again!

    EDIT:

    Actually, It appeared to be working... I tried using the slot one to slot two flasher and it didn't work on my card... just froze up... then I tried using uCon and it recognizes and flashes my card but when I go to test the card out on my GB I get a white screen.... =( sad day.... you don't think the slot one to slot two application could have killed my card do you?

    EDIT AGAIN:

    YAY! it works! it seems that the rom I was trying to load before was simply not working... I'll have to check into that...
     
  5. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    My suggestions would have been if2a and the one that flashes a Flash Advance from either Wifi or a slot-1 device. Completely forgot that uCon64 had functions like that.

    Glad you got it working.
     
  6. solarsaturn9
    OP

    solarsaturn9 Newbie

    It will flash roms to my cart.... however I need some more advice...

    when I had windows I used LittleWriter which apparently auto patched everything... So I never knew how fickle the Flash Advance was...

    In any case... some roms that I flash ( ex. Pokemon FR/LG ) result in a white screen. I have tried GBAUtil using crash patch 0 and crash patch 8.... didn't work...

    any suggestions? Thank you!
     
  7. FAST6191

    Reporter FAST6191 Techromancer

    pip
    Joined:
    Nov 21, 2005
    Messages:
    21,716
    Country:
    United Kingdom
    All windows (bar the patches) but wine should not have that much trouble

    GBATA for patching roms:
    http://www.gbadat.altervista.org/tools.htm

    save the few with odd hardware (patches so should not need windows, linux IPS patcher is what you need):
    http://bubbz.pocketheaven.com/?system=gba&section=patch

    Also flash advance toolkit:
    http://www.gameboy-advance.net/rom_tools/f...nce_toolkit.htm

    If you are so inclined trolleydave did some nice work on patching too:
    http://gbatemp.net/index.php?showtopic=60168
     
  8. solarsaturn9
    OP

    solarsaturn9 Newbie

    Thanks again! you guys are amazing!
     

Share This Page