Legit MPT, safe to play in modded Wii?

Discussion in 'Wii - Console and Game Discussions' started by dark42, Aug 29, 2009.

  1. dark42
    OP

    dark42 GBAtemp Regular

    Member
    193
    1
    Nov 13, 2007
    United States
    I have just received my copy of Metroid Prime Trilogy from Amazon. When I put it in my Wii, it wants to do a system update. My Wii is currently on 4.1U and has Homebrew Channel, CIOS, USB Loader, and BootMii installed. Is it safe to let it run its update?
     
  2. Covarr

    Covarr Sentient Cash Register

    Member
    872
    5
    Oct 21, 2005
    United States
    Far East of Eden
    Somehow I doubt this, as 4.1 is the latest version.

    You could install Preloader or startpatch to block updates, or load it through Gecko. In fact, I strongly advise doing this, because eventually they'll release another game that requires a homebrew-blocking update.
     
  3. tj_cool

    tj_cool Site dev

    Supervisor
    9,989
    -1
    Jan 7, 2009
    Belgium
    This planet
    Its true, it asks for update, even on 4.1
    Noone knows what it does so to be sure, install preloader/...
    But it shouldn't region brick or something
     
  4. dark42
    OP

    dark42 GBAtemp Regular

    Member
    193
    1
    Nov 13, 2007
    United States
    Regions are not a problem, my Wii is the US version on 4.1U, MPT is the US version also. I have never changed my Wii's region or anything like that.
     
  5. dark42
    OP

    dark42 GBAtemp Regular

    Member
    193
    1
    Nov 13, 2007
    United States
    Ok, so I got a little impatient and ran it anyway. Works ok, doesn't seem to have broken anything. I even ripped the game to my HDD! However I can't seem to load any of the games from USB loader. It goes to the main menu of the game, but when I select one of the games to play, the Wii crashes and goes to the System Menu! Oh well, I'll play with the disc until Waninkoko updates the USB loader/CIOS.
     
  6. tj_cool

    tj_cool Site dev

    Supervisor
    9,989
    -1
    Jan 7, 2009
    Belgium
    This planet
    Thats normal for MPT
    you have to use alt-dols as explained in all those MPT topics
     
  7. IAmTheRad

    IAmTheRad GBAtemp Regular

    Member
    198
    1
    Aug 7, 2006
    Canada
    Just update block with preloader and game on.
     
  8. SifJar

    SifJar Not a pirate

    Member
    6,022
    892
    Apr 4, 2009
    It wont ask for an update on 4.1. It will ask for an update on 4.1 on a wii which is "softmodded" i.e. loaded up with fail.
    If you have regular 4.1, it will not ask for an update, I can almost guarantee you that.
     
  9. SpaceJump

    SpaceJump Where's my new 2D-Metroid?

    Member
    3,672
    213
    Aug 18, 2005
    Gambia, The
    Zebes
    I have a 4.1E Wii and a retail PAL MPT and it asks me to update. Is it now known what the update does?