Legacy Ninjhax v1.1b rehosted

Discussion in '3DS - Homebrew Development and Emulators' started by zoogie, Jul 7, 2017.

  1. zoogie
    OP

    zoogie simple pimp tool

    Member
    6,576
    8,476
    Nov 30, 2014
    United States
    As some of you know, @smealum 's original ninjhax (4.0-9.2 only) site, http://smealum.net has been down for over a year now. This isn't the biggest of deals since he now has https://smealum.github.io/ninjhax2/ which is up-to-date and superior to the original in every way. Almost.

    Some of you may be nostalgic, curious, want homebrew but don't want to update > 8.1, or whatever strange reason. If that describes you; then here you go:
    http://nhax.gq/

    Hosted at:
    https://github.com/zoogie/ninj1x
    Original Ninjhax Source:
    https://github.com/smealum/ninjhax

    Notes:
    - I had to use a custom domain because Github ended http support for username.github.io. ninjhax requires http.
    - Keep in mind that support for this version is long since over, so don't email smealum. Not like he answers them anyway :P
    - I originally made this for myself last year. Didn't expect to share it but some may find it useful.
    - If you use cfw, you need to use an old luma3ds (< 5.5) because it breaks ninjhax1 with a RO patching feature. Other cfws may work as well. Not tested.
     
    Last edited by zoogie, Jul 8, 2017
  2. hongmieu999

    hongmieu999 Advanced Member

    Newcomer
    73
    10
    Oct 14, 2015
    will check this later !
     
  3. zoogie
    OP

    zoogie simple pimp tool

    Member
    6,576
    8,476
    Nov 30, 2014
    United States
    later = never :P
    This has very niche appeal. I would guess only curious devs or users < 9.0 would even consider using it.
     
    VictorMoreno015 likes this.
  4. hongmieu999

    hongmieu999 Advanced Member

    Newcomer
    73
    10
    Oct 14, 2015
    don't be so mean ! this is a grat project too !
     
    hobbledehoy899 and zoogie like this.
  5. HugaTheFox

    HugaTheFox GBAtemp Advanced Fan

    Member
    576
    139
    Feb 11, 2017
    United States
    Las Vegas
    OMG thank you so much. I use older versions of Fws sometimes this will be helpful
     
    zoogie likes this.
  6. DinckelMan

    DinckelMan Your Favorite Water Mage!

    Member
    257
    156
    Nov 4, 2013
    United States
    Why would you possibly need this at this point?
     
  7. zoogie
    OP

    zoogie simple pimp tool

    Member
    6,576
    8,476
    Nov 30, 2014
    United States
    Read. The. OP.
     
    FateForWindows, WeedZ and Joel16 like this.
  8. SLiV3R

    SLiV3R 3DS Friend Code: 0473-9069-2206

    Member
    2,212
    1,044
    Jan 9, 2006
    Some hb actually works better in 1.1b :)
     
    RosaliinaDaHacker64 likes this.
  9. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,197
    21,577
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    So has this been tested on B9S? I know there's been some older homebrew entrypoints that don't work with B9S.
     
  10. DinckelMan

    DinckelMan Your Favorite Water Mage!

    Member
    257
    156
    Nov 4, 2013
    United States
    That doesn't answer my question ;)
     
  11. zoogie
    OP

    zoogie simple pimp tool

    Member
    6,576
    8,476
    Nov 30, 2014
    United States
    Then you have trouble with reading comprehension.

    If this doesn't interest you, move on. It's not affecting any aspect of your life by merely existing.
     
    HugaTheFox likes this.
  12. HugaTheFox

    HugaTheFox GBAtemp Advanced Fan

    Member
    576
    139
    Feb 11, 2017
    United States
    Las Vegas
    Because some people would love to use this. I would. And people also don't want to update. And that some apps require rohaxs which only Ninjhax 1.1B has
     
  13. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,767
    4,574
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.14.6-1-zen
    Why did you need standard http?
     
  14. zoogie
    OP

    zoogie simple pimp tool

    Member
    6,576
    8,476
    Nov 30, 2014
    United States
    ninjhax itself requires it
     
  15. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,767
    4,574
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.14.6-1-zen
    That's dumb (on Smealum's part.)
     
  16. smealum

    smealum growing up sucks.

    Member
    635
    2,036
    May 1, 2006
    United States
    SF
    over a year? fml i need to get my shit together
     
  17. HugaTheFox

    HugaTheFox GBAtemp Advanced Fan

    Member
    576
    139
    Feb 11, 2017
    United States
    Las Vegas
    Crashes when trying to scan. Trying again but its so hard

    — Posts automatically merged - Please don't double post! —

    Wrong qr. the 3DS will cut to the Browser and say "Address not valid" when runming the exploit
     
    Last edited by HugaTheFox, Jul 8, 2017
  18. hobbledehoy899

    hobbledehoy899 Conniption Master

    Member
    2,767
    4,574
    Nov 13, 2015
    United States
    Kernel Version: Linux 4.14.6-1-zen
    mmm whatcha smea-ayy, ohh
     
    zoogie likes this.
  19. zoogie
    OP

    zoogie simple pimp tool

    Member
    6,576
    8,476
    Nov 30, 2014
    United States
    What exact firmware are you on? I'll see if I can reproduce.

    I should have mentioned some spider/ro combinations just don't work. But that has always been an issue.
    4.5-0-10J never worked either.
     
  20. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,532
    5,476
    Mar 17, 2010
    Norway
    Alola
    While I probably won't need this myself (in fact I hadn't even noticed the site was down)
    I do still own a copy of Cubic Ninja that I'm keeping around in case I ever need it.
    And there's no doubting the value in having a *hax entrypoint that works on firmwares below 9.0.
    And sometimes it's near impossible to get CFW installed on a console because of weird frankenfirms.
    It'll definitely be useful to some people.
    So thanks :D
     
    HugaTheFox and zoogie like this.