WIP ldn_mitm - Play local wireless supported games online

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by Cubuss, Dec 7, 2018.

  1. Cubuss
    OP

    Cubuss GBAtemp Fan

    Member
    9
    Aug 4, 2017
    Netherlands
    High Quality Shitposter
    iirc kosmos has the ldn_mitm already integrated by default,
    You need to enable it via kosmos toolbox to use it i think,
     
    jujuassou likes this.
  2. SG911

    SG911 GBAtemp Fan

    Member
    5
    Dec 20, 2017
    United States
    Bronx, NY
    What do SX OS users do. If you enable the online option in the SX menu, load smash & go to the local wireless & it gives an error?
     
  3. raxadian

    raxadian GBAtemp Advanced Fan

    Member
    5
    Nov 10, 2018
    Argentina
    Try again later?

    Or maybe check you have the network configuration right.

    What's probably happening is that too many people are playing that game. Try with a different game to see what happens.
     
  4. SG911

    SG911 GBAtemp Fan

    Member
    5
    Dec 20, 2017
    United States
    Bronx, NY

    Thanks! Was told, apparently they never updated the local wireless KIP? So smash for SX users, is the only game that doesn't work with. For SX users at least.
     
  5. Cubuss
    OP

    Cubuss GBAtemp Fan

    Member
    9
    Aug 4, 2017
    Netherlands
    High Quality Shitposter
    You tried with latest SXOS beta to, but still same error?
     
  6. SG911

    SG911 GBAtemp Fan

    Member
    5
    Dec 20, 2017
    United States
    Bronx, NY
    Yup! Tried as soon as i saw they dropped a new update. Still same thing. Local wireless works IF i don't turn on the option in the SX options menu, but with it on i always get the same error.
     
  7. Slim45
    This message by Slim45 has been removed from public view by Quantumcat, Jun 20, 2019, Reason: Bickering.
    Jun 20, 2019
  8. SG911
    This message by SG911 has been removed from public view by Quantumcat, Jun 20, 2019, Reason: Bickering.
    Jun 20, 2019
  9. Slim45
    This message by Slim45 has been removed from public view by Quantumcat, Jun 20, 2019, Reason: Bickering.
    Jun 20, 2019
  10. Cubuss
    This message by Cubuss has been removed from public view by Quantumcat, Jun 20, 2019, Reason: Bickering.
    Jun 20, 2019
  11. Slouched

    Slouched Newbie

    Newcomer
    1
    Jun 21, 2019
    United States
    Same thing is happening to me. I think im going to try and use atmosphere instead. Wish me luck!
     
    SG911 likes this.
  12. Jonhy

    Jonhy GBAtemp Regular

    Member
    4
    May 22, 2016
    United States
    It'll work, as long as you aren't on 8.1.0. Apparently, sys modules need to be updated to support that firmware.
     
    SG911 likes this.
  13. SG911

    SG911 GBAtemp Fan

    Member
    5
    Dec 20, 2017
    United States
    Bronx, NY
    Yeah, I was told by someone that SX guys need to update something still. On there end at least so that smash will work. Cause apparently other games work using SX & the local wireless feature. Just not smash.
     
  14. KneeDoctor

    KneeDoctor Member

    Newcomer
    1
    Jun 9, 2019
    United States
    Where do we put the .kip file for SX OS?
     
  15. Jonhy

    Jonhy GBAtemp Regular

    Member
    4
    May 22, 2016
    United States
    SX doesn't support kips. Lan play is built in. It's in the setting somewhere. Same place as FPT transfer and stealth mode toggles.
     
    Cubuss likes this.
  16. oBluEx

    oBluEx Advanced Member

    Newcomer
    3
    Jan 1, 2013
    United States
    Sylvania, Ohio
    Ok so. I wanna say I have everything right.

    I'm using Atmosphere 0.8.8 FW: 0.7.1, booting CFW with the Fusee_Primary. I'm using a fresh install just cause.

    I made a "kips" folder under my atmosphere folder, it sits next to kips_patches. I placed the ldn_mitmv1.2.3 under my new kips folder.

    I also placed the contents of the zip in its correct places.

    My internet settings and Lan program are all perfect.

    Now if i got to Local Wireless in Smash. I'm using 3.0.0 so it should work. How can i tell I'm all setup? Is there a way to tell that kips is working. Under the .nro it says it's on.
     
  17. possessedlaptop

    possessedlaptop Member

    Newcomer
    1
    Jul 27, 2019
    Peru
    Hello everyone, I may need some help.
    I toggled the ldn_mitm option on Hekate Toolbox, asked me to restart, and now I think it's bricked cus I can't get past the Nintendo Switch splash screen.
    I'm using EmuMMC so Sysnand still works fine.

    so far I have replaced the atmosphere, bootloader, config and switch folders to see if it fixes, but nothing so far.
    Could anyone please tell me what to do now?
     
  18. mattyxarope

    mattyxarope Advanced Member

    Newcomer
    3
    Jan 15, 2019
    United States
    Has anyone tried this with Friday the 13th yet? Afaik it doesn't have LAN mode...
     
  19. OddFWGKTA

    OddFWGKTA Newbie

    Newcomer
    1
    Aug 15, 2019
    Chile
    Santiago
    Awesome.

    — Posts automatically merged - Please don't double post! —

    No, that won't work.
     
Loading...