Launch Wii + Wiikey 1 + Softmod + NSMB = no go

Discussion in 'Wii - Hacking' started by Arfman, Dec 23, 2009.

  1. Arfman
    OP

    Arfman Member

    Newcomer
    13
    0
    Jul 30, 2007
    Netherlands
    OK, final attempt to get this working.

    I have a launch Wii, which was fitted with a Wiikey1, which is at firmware 1.9s. I tried NSMB on it, after 1 or 2 levels a black screen pops up which reads "An error has occurred. Please remove the disc and reset your Wii" (not literal as I have a Dutch Wii, so this is my translation). I understood this has to do with Wiikey 1 not being able to run NSMB.

    So I followed the softmodding guide here, which worked like a charm (never done that before). So I now have the HBC, NeoGamma launcher, WAD Manager, a bunch of cIOS stuff (whatever that is), Wii FW 4.2E, in short: the works.

    So then I tried NSMB again, still the same error. I then tried launching via NeoGamma R7, still the same error. I then updated to NeoGamma R8B15, still the same error after a few levels. Burned NSMB again to be sure, didn't help either.

    My question is simple: I still have the Wiikey fitted. Does it need to be removed to avoid detection by NSMB, or have I done something wrong with the softmod? Are there any people with a Wiikey fitted who CAN run NSMB? I get mixed replies in other threads, so I started this thread to finally get an answer.

    Can anyone please shed some light on this?
     
  2. Pete666

    Pete666 GBAtemp Regular

    Member
    228
    3
    Nov 12, 2009
    Canada
    do you use ios249 and the error002 fix???

    I use it in neogamma and my original and backup works #1
     
  3. Hatsu

    Hatsu Someone's been killing, eh?

    Banned
    2,143
    0
    Oct 19, 2009
    __________________ Warn: 50%
    Install the latest IOS53 or get a new ISO. (Search for one fixed by LightYear)
     
  4. mp2609

    mp2609 Member

    Newcomer
    38
    0
    Sep 1, 2007
    UK
    I have a Wiikey fitted and I can run the fixed iso through Neogamma R7 with cIOS rev14 [​IMG]
     
  5. Pete666

    Pete666 GBAtemp Regular

    Member
    228
    3
    Nov 12, 2009
    Canada
    same for me!
    but my original works too!
     
  6. Arfman
    OP

    Arfman Member

    Newcomer
    13
    0
    Jul 30, 2007
    Netherlands
    OK, I don't really know what you guys are talking about [​IMG]
    IOS249 I saw during my softmod process, just like IOS250. I don't know about the error 002 fix though.

    Since I posted this, I have done 2 things and I was able to play NSMB for about 20 minutes. Since it always blackscreened me after about 10, I *think* I fixed the problem. Just to be helpful, here is what I did (man, this Wii hacking scene sure has come a long way since I was "active" in it, softmodding is new to me, IOS stuff is new, it's kinda hard to make up 2 years of negligence in 2 days, but here goes):

    -Use Pimp my Wii 1.32. This found a few missing IOSses, a "stub" one and one that was apparently unpatched for the Trucha Bug. I followed the softmodding guide for dummies to the letter, so I don't really know whether to trust PMW or the softmod guide, but I let PMW fix these alleged errors. Still no dice, NSMB blackscreened me after about 10 minutes.

    -Then I installed NeoGamma R8B12 (so not the latest 15, but 12). Started up NSMB, played for about 20 minutes.

    So either NeoGamma R8B12 fixed my problem, or a combination of NeoGamma R8B12 and Pimp my Wii did the trick (I only tried NeoGamma R8B12 *after* PMW, so no way of telling if only NeoGamma was the solution, unfortunately). There is also a slight possibility that the problem still isn't fixed and I got just lucky once, I will let you know how it fares from here.

    Appreciate the help and hopefully my steps will help some other lost soul out there.
     
  7. Elritha

    Elritha GBAtemp Addict

    Member
    2,037
    1
    Jan 24, 2006
    Canada
    Have you tried to follow the guide here for modchip users?
    One solution the guide mentions is NeoGamma R8Beta15 should be able to run it.