Latest IOSes

Discussion in 'Wii - Hacking' started by TheSuperC, Jan 6, 2011.

Jan 6, 2011

Latest IOSes by TheSuperC at 8:42 AM (2,074 Views / 0 Likes) 2 replies

  1. TheSuperC
    OP

    Newcomer TheSuperC Newbie

    Joined:
    Jan 6, 2011
    Messages:
    2
    Country:
    South Africa
    Hi,

    I am a noob, and any help or advice would be greatly appreciated.

    If I can supply a quick history of my Wii console: I purchased a black Wii (with system menu 4.2E), which I softmodded (by using the GBAtemp guide). After the release of 4.3E, which I upgraded to (by accident), I recently had to re-softmod it (again using the GBAtemp guide). As far as I know, I now have the latest HBC etc.

    Using CFG-USBLoader, I noticed that some games didn't work (black screens and other malfunctions) using IOS250, but my favourite games worked 100% so I never bothered to try other settings and IOSes.

    My trouble started with 'Donkey Kong Country Returns [PAL][English][Wii]-JiMiC'. I played world 1 using IOS250 without any problems. On world 2-5, however, I suddenly started getting a recurring error 'Communications with the Wii Remote have been interrupted'. I found a guide suggesting that I use IOS249. Using IOS249, the error was resolved, but the console would hang upon losing a life. I thought because this is a rather new game, I might have to upgrade my cIOSes.

    Now my question: How do I know which versions of each of the IOS / cIOS files do I need? Is it best to always use the latest?

    In trying to upgrade my cIOSes, I used the following guide: "Custom IOSx Rev 21 Installation Guide".

    In comparing sysChecks, before and after the cIOSx upgrades, the only difference was 'IOS249 (rev 17): Trucha Bug, ES Identify, NAND Access, USB 2.0' changed to 'IOS249 (rev 21): Trucha Bug, NAND Access, USB 2.0'.

    But, when I tried to play Donkey Kong Country Returns again, using the latest IOS249, I got the same problem which IOS250 used to give: recurring error 'Communications with the Wii Remote have been interrupted'.

    I then downgraded back to IOS249 (rev 17) using this guide "How to Use Waninkoko's cIOS Installer". My sysCheck now again reflects 'IOS249 (rev 17)'. My CFG-USBLoader gives an error on startup when loading IOS250, but my games seem to work.

    Have inadvertently broken something else? How can I get all my IOSes (and possibly other files / settings) back the way it was? I am somewhat confused now.

    Please help if possible.

    Thanks and regards,

    TheSuperC
     
  2. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    Hi there,

    When reading the thread title, I was actually going to suggest using syscheck, as that gives a good overview. But it seems you've already done most of the work. [​IMG]

    Lemme just say that custom Input-Output Systems are generally called cIOS'es (numbers >200) and that the term IOS is reserved for the official versions of these things. Just to avoid confusion.
    Now...the 4.3 update has updated pretty much all of your IOS'es (games generally use one of the available IOS'es there). However, if you're using a USB drive instead of discs, those things don't matter, as you'll be using a cIOS to load a game. In modern USB loaders (including your USB loader CFG), you can tell each game which cIOS to use. Which is a good thing, because even though cIOS'es tend to play more than a few games, no one can play all games.


    Second...you need to know that those numbers aren't the cIOS themselves. Look at them as slots to where you can install the actual cIOS. Telling us that you use "IOS250" or "the latest IOS249" isn't telling us much, because it differs on what is installed there. It is better to refer to them as the revisions (rev21, in your case).

    Now...as for your question of "is it always the best of using the latest?"...in general, I have to answer no. Newer doesn't always mean better, and while it may introduce new features or better compatibility, it may also introduce new bugs or things that applications don't (yet) support. "If it's not broke, then don't fix it" is a good way to go about it, especially if you don't know exactly what's going on.


    However...in this case, I have to say: yes. Your posting of syscheck tells me you had rev17 on there. Back then, the installer always took slot 249 to install it, and 250 as well (as a backup). You may have noticed that when trying to install rev21, it asked you for two things (aside from Wad or network installation):

    -the slot. As I said before, this is where to install rev21. 249 is the default, but it is not needed to install it to that slot. If you have a recent version of configurable USB loader, I would suggest taking a number that isn't taken yet (245, 246, 247 or 248). That way, you can keep your current setup unchanged.
    -the base IOS. Well...since rev18, Waninkoko hasn't released a 'single' cIOS anymore, but rather something you could consider a bundle. It may be important to know which base IOS you use for some games, but for most games (including donkey kong country returns), just choose base IOS 56.



    I know it's quite a bit of an explanation, but once you get the hang of it, it's not that hard.
    As for getting things back the way they were...I think you're pretty much there. You upgraded rev17 to rev21 and then back to 17, all in slot 249. I don't know what the error message from configurable loader CFG is (would you mind telling that?), but I guess it is because slot 250 doesn't contain the same cIOS as before.

    What I suggest you do: run the rev21 installer again and install it on slot 248 (provided this slot is empty at this point...check syscheck for that) with base IOS56. Then, open configurable usb loader and check the settings of donkey kong country returns. There should be a setting called "cIOS" or something. Set that to 248 (if you haven't updated configurable usb loader in ages, this is the time to do it).



    PS: I suggest you be careful with which guide you follow. cIOS'es can be upgraded and downgraded without problems, but for most other things, following outdated guides can be quite dangerous.
     
  3. TheSuperC
    OP

    Newcomer TheSuperC Newbie

    Joined:
    Jan 6, 2011
    Messages:
    2
    Country:
    South Africa
    Thank you for help! Much appreciated.
     

Share This Page