Lack of vulernable IOS?

Discussion in 'Wii - Hacking' started by Gamemaster1379, May 29, 2009.

  1. Gamemaster1379
    OP

    Gamemaster1379 GBAtemp Advanced Fan

    Member
    588
    82
    May 5, 2008
    United States
    United States
    I'm having a very strange situation here. I decided that I may as well update to HBC 1.0.3 to regain SDHC computability, so I downloaded the Hackmii v0.2 installer. I ran it, it went through everything just fine--and then it said I was unable to install anything because I lack a vulnerable IOS, and that it won't accept a cIOS--but regardless of the cIOS, I should have a vulernable IOS since I updated from 3.4U to 4.0U using Waninkoko's firmware updater (Which should have kept the IOSes from being patched).
     
  2. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    Have you ever installed CIOSCORP in the past? BootMii doesn't like that since it doesn't feel comfortable running only on custom IOS's. If that's your problem run IOS Downgrader and try the HackMii installer again. You'll have to reinstall CIOSCORP again afterwards, but it's a small price to pay.
     
  3. Gamemaster1379
    OP

    Gamemaster1379 GBAtemp Advanced Fan

    Member
    588
    82
    May 5, 2008
    United States
    United States
    Yeah, I've installed it before. I'm glad I kept the files too so I can reinstall them later on after Bootmii. [​IMG]
     
  4. thc42O

    thc42O Banned

    Banned
    470
    0
    Jan 3, 2009
    Canada
    install ios36 then itll work then install the ios36 from cioscorp
     
  5. Jacobeian

    Jacobeian GBAtemp Advanced Maniac

    Member
    1,881
    122
    May 15, 2008
    Cuba
    isn't it simply a wrong IOS version check that happened when messing up with official IOS (like those "downgrading" tutorials makes you do with IOS35 or 36 ?)

    I mean, I'm on 4.0 and all my IOS are not vulnerable anymore (except cIOS) and did not had any problem installing the new BootMii suite

    maybe they mean "vulnerable" in another (unknown) way, not the wellknown signature vulnerability but a new hole they are used to install channels ?
     
  6. SublimeAndEtc

    SublimeAndEtc GBAtemp Regular

    Member
    123
    0
    Apr 22, 2009
    United States
    West Palm Beach, FL
    The HackMii installer is the only program that can automatically make non-trivial system modifications on all Wiis. It has several different code paths (aka exploits) that it uses to do this; on any given Wii, the Installer will scan your system to find the most appropriate one to use (generally, the most stable or least invasive one).

    If you have recently installed an official update, this may mean that all of our existing exploits have been patched; in this case, please wait patiently for us to update the installer.

    In most cases, however, this means you have installed some sort of "mod pack" which leaves your system in a damaged state that interferes with our system scan. In particular, "cIOSCORP" is known to be problematic because some idiot decided it would be smart to take some old version of IOS, change the version number, and overwrite all other IOSes. Most other "packs" are less destructive, but we do not have time to test them all.
     
  7. ds22

    ds22 GBAtemp Regular

    Member
    269
    2
    Sep 27, 2008
    Netherlands
    Rotterdam NL
    Just run IOS Downgrader v1.0.
     
  8. carbonyle

    carbonyle GBAtemp Fan

    Member
    360
    0
    Jan 9, 2009
    Swaziland
    Switzerland
    I had this problem 5 min ago.. I resolved it myself befor find this thread:)
    Just reinstall originals trucha IOS, like those you can find in old good games like Mario Kart with wad manager.
    It seems Hackmii installer doesn't like CIOSCORP (me too, but it was just to test it [​IMG] )
     
  9. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    TT mentioning Cioscorp in the FAQ's thats funny, I dont really care, but in away i do agree with them, the Mod is OLD and dangerous if you dont understand how to use it. and i dont really understand why people is still using it, but i'm not forcing people to use it. It spread like wide fire through the net.

    edit:

    And being called a idiot well i've been called worse
     
  10. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    It wasn't total idiocy anyway. I thought it was a good learning experience for the community.
     
  11. wolffangalchemist

    wolffangalchemist This is bat country!

    Member
    1,408
    31
    Nov 23, 2008
    United States
    middleofnowhere, AL
    they clearly perposly done that, i bet the next installer won't install if you have even just one cios installed to any of the main ios's.
     
  12. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    Well, it makes sense that they want at least one normal IOS to work with.
     
  13. 9th_Sage

    9th_Sage GBAtemp Maniac

    Member
    1,481
    1
    Apr 30, 2008
    United States
    I doubt they're going to do that. I'm personally glad that their installer is very careful given the kinds of things it is doing could really mess up your Wii if they were done wrong.
     
  14. WiiBlaster

    WiiBlaster GBAtemp Maniac

    Member
    1,189
    0
    Nov 23, 2008
    United States
    I agree i thought it was kindof fun, but sense the Usb Loader, i believe its a good time for it to DIE. [​IMG]
     
  15. Hells Guardian

    Hells Guardian GBAtemp Maniac

    Member
    1,113
    1
    Dec 25, 2008
    United States
    lol the reason is to ensure that all the sanity checks are acurate. It's literally for safety......
     
  16. Col70

    Col70 GBAtemp Regular

    Member
    159
    0
    Feb 2, 2009
    what i dotn understand though is that I installed beta 1 (not to boot 1 but to ios) and tried to 'upgrade' be installing the new beta 2 - but got this error message. surely if I had installed cioscorp it should have allowed beta 1 to install?
     
  17. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    They tightened the sanity checks in Beta 2, that's why.