Hacking Question Kirby Star Allies doesn't boot with update 4.0 but it does with other versions

jesus96

Pinkboi
OP
Member
Joined
Sep 2, 2015
Messages
316
Trophies
0
XP
842
Country
Mexico
Hi i recently brought a nintendo switch and installed kirby star allies with the 4.0 version,at first it got stuck on a loading softlock,then i closed the game and now everytime it says "software closed due to an error" without an error code or something i already tried with different sources for the update but all of them seem to fail,i almost give up for I decided to go back to 1.0 and it booted without problems and last night I found a link for the 2.0 update and for my surprise it worked as well

20210129_013358.jpg 20210129_013455.jpg
20210129_013501.jpg


But the thing is that i can't use 4.0 for some reason and since updates on this game are free content i basically miss stuff,anyone has experienced a problem like this? Is literally the only game that gives me problems :(

Atmosphere 17.1
Sigpatches:Fuse primary latest
Hekate 5.5.3

Also I already checked and deleted any save file and theres no cheats for the game or something since I checked that they can give problems,like I said basically is clean

UPDATE:i menaged to found the 3.0 update and for my surprise it works as well (the f***?) I don't get why 4.0 doesn't work

20210129_233228_1.jpg
 
Last edited by jesus96,
  • Like
Reactions: Space_Invaderx

Space_Invaderx

Active Member
Newcomer
Joined
Feb 25, 2013
Messages
32
Trophies
0
XP
185
Country
United States
I'm having the same issue. Base game (1.0) works, but when I update to 4.0 I get the error. Did you ever resolve this? I could not find any other updates to try.
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,599
Trophies
2
XP
1,819
Country
United States
I'm having the same issue. Base game (1.0) works, but when I update to 4.0 I get the error. Did you ever resolve this? I could not find any other updates to try.
Trying now…

@Space_Invaderx I’m on FW 14.1.1 | AMS 1.3.2. base image worked great…could only find v5 update on tits though. It worked without any issues. Maybe locate v5?
 
Last edited by binkinator,
  • Like
Reactions: Space_Invaderx

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,599
Trophies
2
XP
1,819
Country
United States
I'm having the same issue. Base game (1.0) works, but when I update to 4.0 I get the error. Did you ever resolve this? I could not find any other updates to try.
Trying now…

@Space_Invaderx I’m on FW 14.1.1 | AMS 1.3.2. base image worked great…could only find v5 update on tits though. It worked without any issues. Maybe locate v5?
update: grabbed a copy of some different updates just for kicks. I deleted the base and everything from my system and reinstalled. Did the update to v2 and…

image.jpg

image.jpg

onward…loaded up v4 and

image.jpg

it works…double check the version…

image.jpg

definitely ver 4.0.0

so bottom line: I don’t think it’s anything wrong with the installers or the version of .nsp…

it’s something in your Switch deployment. You’re going to have to go through your install and see what gives…
 
  • Like
Reactions: Space_Invaderx

Space_Invaderx

Active Member
Newcomer
Joined
Feb 25, 2013
Messages
32
Trophies
0
XP
185
Country
United States
update: grabbed a copy of some different updates just for kicks. I deleted the base and everything from my system and reinstalled. Did the update to v2 and…

View attachment 310944

View attachment 310945

onward…loaded up v4 and

View attachment 310958

it works…double check the version…

View attachment 310959

definitely ver 4.0.0

so bottom line: I don’t think it’s anything wrong with the installers or the version of .nsp…

it’s something in your Switch deployment. You’re going to have to go through your install and see what gives…
I appreciate you looking into it.

I am still on FW 13.2.1 / AMS 1.2.6, so I will look at updating and see if that helps.

Thanks again.
 
  • Like
Reactions: binkinator

Space_Invaderx

Active Member
Newcomer
Joined
Feb 25, 2013
Messages
32
Trophies
0
XP
185
Country
United States
I just updated to 14.1.1 CFW / AMS 1.3.2, but still no luck. I have tried doing the game update with several different installers (Goldleaf, Tinfoil, TinWoo, Awoo) and same result. All other games are working fine, it's just this one update that is giving me an issue.

I can remove the update with Tinfoil and the game goes back to v1.0 and works.

I am attempting a complete removal of the game and starting fresh to see if that helps, then I will try to find another source for the update. If you have any other suggestions let me know.
Thanks.
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,599
Trophies
2
XP
1,819
Country
United States
I just updated to 14.1.1 CFW / AMS 1.3.2, but still no luck. I have tried doing the game update with several different installers (Goldleaf, Tinfoil, TinWoo, Awoo) and same result. All other games are working fine, it's just this one update that is giving me an issue.

I can remove the update with Tinfoil and the game goes back to v1.0 and works.

I am attempting a complete removal of the game and starting fresh to see if that helps, then I will try to find another source for the update. If you have any other suggestions let me know.
Thanks.
I’m removing the entire game using the built in Manage Software. Are you doing the same?
 

Space_Invaderx

Active Member
Newcomer
Joined
Feb 25, 2013
Messages
32
Trophies
0
XP
185
Country
United States
I’m at a loss. See if you can find it elsewhere. The place I found it…just worked and I have what amounts to the exact same setup as you at this point.
Same here. I appreciate your help.

I will update if I ever figure it out.

Update: I managed to find the v2.0.0 update and it works, so that will have to do for now (my little one is happy).

Update 2: Success! Found another source and enabled install of unsigned code in TinFoil's option menu (had to enter the old Contra code to pass the trial of the normie, LOL). Kids are enjoying the game as I type. Thanks again @binkinator
 
Last edited by Space_Invaderx,
  • Love
Reactions: binkinator
General chit-chat
Help Users
    Dark_Phoras @ Dark_Phoras: Good morning! Today I managed to wake up in the morning. It is a welcome step