Hacking Just switched to Atmosphere, having a little trouble

echan42

Well-Known Member
Newcomer
Joined
Oct 3, 2013
Messages
64
Trophies
0
Age
30
XP
200
Country
Hi, I just ditched my old cfw and updated to Atmos, I'm loading it with hekate ctcaer since I'm using emuNAND.
I obviously can't run Tinfoil since it requires fusee so I installed Goldleaf 0.9

I can install legal backups of my games no problem, but I was trying to install a backup that requires fw 12.2.0 and I'm currently on 12.1.0, I get the following error:

Invalid NCA (might mean missing sigpatches or too low firmware) (4518)

I'm running latest sigpatches (afaik) and I checked Goldleaf's settings and "Ignore required firmware version for installs" is set to yes.

I get exactly the same error when trying to install goldleaf 0.5 nsp https://github.com/XorTroll/Goldleaf/releases/tag/0.5

Oly thing I can think of is switching to fusee and trying Tinfoil but I'm pretty happy with my set-up the way it is, any ideas?
 
Last edited by echan42,

Kallrkyle

Well-Known Member
Member
Joined
Jul 23, 2021
Messages
190
Trophies
0
Age
50
XP
176
Country
Denmark
Tinfoil have no problem running on ams booted from hekate, you would know that if you read the release info provided with tinfoil

Why not just update to 12.1, its the latest ams is supporting atm
 

Reploid

Well-Known Member
Member
Joined
Jan 20, 2010
Messages
2,145
Trophies
1
Website
Visit site
XP
3,963
Country
Serbia, Republic of
Latest tinfoil doesn't have those biases, update manually if you have to.

Make sure you did this

Some users sometimes hnadle their setup in the wrong order, which ends up in some key files needed for signature patches to work properly being missing in the setup.
This can be caused if you download the sigpatches first, and then you try to update Hekate, which can overwrite the "hekate_ipl.ini" file from the sigpatches pack, which has a important config line to make the sigpatches work on boot properly.

This can be easily resolved by opening the file called "hekate_ipl.ini" inside the /bootloader/ folder, and check if it has a line that says "kip1patch=nosigchk".
Make sure that line is added into whatever CFW you are booting into, be it sysNAND or emuNAND.
If said line is there, then this might most lkely not be the issue, but if it isn't, be sure to add it right undr the payload=**** line.
Or give it a read https://gbatemp.net/threads/guide-how-to-fix-switch-games-not-booting-after-a-fw-cfw-update.563960/

Make sure you have latest atmos, I personally recommend using Deepsea package. There is also Kefir as an alternative.
 
Last edited by Reploid,

echan42

Well-Known Member
Newcomer
Joined
Oct 3, 2013
Messages
64
Trophies
0
Age
30
XP
200
Country
Why not just update to 12.1, its the latest ams is supporting atm
Messed up while typing my post. Corrected fw versions.

Thanks for your insight, please bare in mind I came from SXOS so I've got some catching up to do.

Tinfoil applet works ,it installed the .nsp I was having trouble with but it gave me a corrupted game on my homescreen and if I use tinfoil applet to install tinfoil it gives me a blank square on my homescreen.
 

echan42

Well-Known Member
Newcomer
Joined
Oct 3, 2013
Messages
64
Trophies
0
Age
30
XP
200
Country
I personally recommend using Deepsea package.
I have an applet called AIOupdater that includes Deepsea installer, it comes pre-loaded with tinWoo but since my setup seems to be working I didn't install it.

I installed everything yesterday using this https://nh-server.github.io/switch-guide/user_guide/emummc/sd_preparation/ guide and I've checked my hekate_ipl.ini file and that line was missing, after adding it to me emu Fss0 block Tinfoil.nsp installed flawlessly and the game backup I was having trouble with installed fine too.

Thanks for your help!
 
  • Like
Reactions: Reploid

Reploid

Well-Known Member
Member
Joined
Jan 20, 2010
Messages
2,145
Trophies
1
Website
Visit site
XP
3,963
Country
Serbia, Republic of
I have an applet called AIOupdater that includes Deepsea installer, it comes pre-loaded with tinWoo but since my setup seems to be working I didn't install it.

I installed everything yesterday using this https://nh-server.github.io/switch-guide/user_guide/emummc/sd_preparation/ guide and I've checked my hekate_ipl.ini file and that line was missing, after adding it to me emu Fss0 block Tinfoil.nsp installed flawlessly and the game backup I was having trouble with installed fine too.

Thanks for your help!
Everybody gets one.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: Lol Veho