Just got my son a DSI, couple of easy questions

Discussion in 'Acekard' started by mrwienerdog, Oct 14, 2010.

  1. mrwienerdog
    OP

    mrwienerdog GBAtemp Regular

    Member
    155
    0
    Nov 1, 2007
    Canada
    So, like the topic says, I just got my son a DSI for his birthday. My wife and I both have regular old NDS's with Acekard 2.1. So here are my questions:

    1. Not sure what firmware his machine shipped with (haven't charged the battery yet), but what is the safest f/w that is okay with AKAIO 1.71? I assume that it is AKAIO that I use?
    2. How does the machine update? I will never hook it up to wireless, so I'm not concerned about that. Do the games force updates? Will I be prompted so I can decline?

    I think that's it. I'm sure if I searched I could find these answers, but as with most of my questions, you guys always seem helpful, and that in turn saves me a lot of time. Time I don't seem to have to exhaustively search for answers.

    So......Thanks in advance for any help. It is appreciated.
     
  2. Demonstryde

    Demonstryde GBAtemp Fan

    Member
    373
    6
    Aug 22, 2010
    United States
    not sure if the acekard 2.1 is the same as the acekard 2i wich is what you will need for a dsi.
    on the matter of it updating , it will only update if you click the buttons and make it update.. check the system menu thing for the firm version.
     
  3. mrwienerdog
    OP

    mrwienerdog GBAtemp Regular

    Member
    155
    0
    Nov 1, 2007
    Canada
    Sorry, I meant A/K 2i. That is what I have for his. I have the 2.1. Got all befuckticated and confused. Old. Me.
     
  4. mylitomutalisk

    mylitomutalisk Member

    Newcomer
    21
    0
    May 21, 2010
    United States
    If you recently bought the DSi, chances are its on the latest firmware..which is bad, since acekard 2i must be patched to run on fw 1.4E and above. The current FW version is 4.XX ( I dunno it, I haven't ever updated my dsi)

    The DSi's FW is only updated through wifi.

    If you need help on patching the acekard so it works on 1.4 fw and above read this guide :

    http://dsi-xl.org/2009/08/28/the-complete-...1-4u-1-4a-1-4x/
     
  5. tk_saturn

    tk_saturn GBAtemp Psycho!

    Member
    3,327
    14
    Jan 26, 2010
    The odds are it will come with FW 1.4

    Follow my guide to update the firmware http://gbatemp.net/index.php?showtopic=231410 not the one linked above.

    No games require you to update the DSi's firmware, although you may be required to updatre the firmware if you want to use the DSi Browser or DSi ware.
     
  6. thieves like us

    thieves like us chaos personified

    Member
    1,057
    16
    Jul 17, 2003
    United States
    left of the pond
    you'll need a DSi compatible flash cart to use with the DSi system. the acekard 2.1 will not work with it. additionally, with the acekard 2i, you may need to run an update (which you can easily do on one of your DS lite systems) so that it will work with the DSi system (any DSi with a firmware version 1.4.1 or high requires that you "patch" the cartridge so that it works). after you patch it, definately grab AIAIO 1.7.1 (or 1.8 when it becomes available) for the best compatibility.

    you won't have to worry about updates via cartridges. nintendo hasn't done anything like that so far, and unless you set it up for use via wi-fi you won't have to worry about any other updates as well. most of the updates that nintendo has been pushing out for the DSi have to do with features and enhancements with their store shop and the DSiware titles.

    I hope that answers your questions [​IMG]
     
  7. mrwienerdog
    OP

    mrwienerdog GBAtemp Regular

    Member
    155
    0
    Nov 1, 2007
    Canada
    Yeah....just checked...It's 1.4U. Thanks for the link.
     
  8. mrwienerdog
    OP

    mrwienerdog GBAtemp Regular

    Member
    155
    0
    Nov 1, 2007
    Canada
    Thanks for all the help so far...Will post any possible questions in regards to the patching of the card.
     
  9. jurassicplayer

    jurassicplayer Completionist Themer

    Member
    4,351
    489
    Mar 7, 2009
    United States
    Pantsuland
    I think you are kind of mixing together two different things. For flashcarts, the main idea is that there is the firmware which is used to get the flashcart to work on a DSPhat/DSL/DSi and then there is the kernel (which many people call the firmware, but technically it is the OS or kernel) such as AKAIO.

    The latest DSi firmware is 1.4.1 (or 1.4.2 for China) and the firmware update allowing the AK2i to work on the DSi is available from this guide: http://gbatemp.net/t218103-updated-n00b-gu...up-your-acekard

    As AKAIO is a kernel/OS it works for whatever AK products it claims to support (AK2i and AK2) and so long as the firmware on the AK2i has been updated, AKAIO will be able to run on the firmware that the update claims to fix.

    The DSi asks if you want to update and it is not mandatory to update unless you want to visit the DSi store (and maybe some other online stuff...). I'm pretty sure none of the DSi games force an update to play.

    -edit-
    lol I got ninja'd by so many posts.
     
  10. mylitomutalisk

    mylitomutalisk Member

    Newcomer
    21
    0
    May 21, 2010
    United States
    Wait, you have an acekard 2.1? That's not DSi compatible.
     
  11. tk_saturn

    tk_saturn GBAtemp Psycho!

    Member
    3,327
    14
    Jan 26, 2010
    No, he has an Acekard 2i. He also has Acekard 2.1's for his DS Lite's.
     
  12. mrwienerdog
    OP

    mrwienerdog GBAtemp Regular

    Member
    155
    0
    Nov 1, 2007
    Canada
    Thanks for having my back there tk_saturn. I'm too old to fight (like Miyagi). Anyways, thanks to all of you for your input, I have everything finished and ready for his birthday tomorrow. Yayyy!!!

    Thanks again.