Just dusted off my softmodded PSP1000, can I update?

Discussion in 'PSP - Games & Content' started by MrMrMr, Aug 23, 2010.

  1. MrMrMr
    OP

    Newcomer MrMrMr Member

    Joined:
    Apr 26, 2010
    Messages:
    29
    Country:
    United States
    Hi

    I have just found my trusty old PSP1000 (brick). It was softmodded ages ago by a friend who I dont see now. So it has version 5.50 GEN-D2 on? It runs games off mem stick. So what can I do to get it updated? I now have a PS3, and keen to see how they sync together

    any guides for noobs? to help me please? is it possible on PSP1000? is the latest PSP FW allowed on mine?

    cheers
     
  2. Blaze163

    Member Blaze163 The White Phoenix's purifying flame.

    Joined:
    Nov 19, 2008
    Messages:
    3,767
    Location:
    Coventry, UK
    Country:
    United Kingdom
    Check the 'how to softmod your PSP' thread for update instructions, you can upgrade to various settings from where you are.
     
  3. MrMrMr
    OP

    Newcomer MrMrMr Member

    Joined:
    Apr 26, 2010
    Messages:
    29
    Country:
    United States
    Pandora battery that rings a bell he mentioned something about that, so I'll have to get one of them to do anything?

    So what can my PSP1000 do in regard with my PS3 then?
     
  4. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    Latest CFW is 5.50 Prometheus AFAIK. Slighly better than 5.50 GEN I believe. Allows you to play I think all currently released games from UMD or ISO.

    Latest OFW is 6.31.

    Both will work fine on your PSP.

    EDIT: And you won't need Pandora to install either. Just run the updater for whichever it is you want to install (wasn't sure if you wanted OFW or CFW from your post, I guess probably CFW)
     
  5. MrMrMr
    OP

    Newcomer MrMrMr Member

    Joined:
    Apr 26, 2010
    Messages:
    29
    Country:
    United States
    Thanks for that, CFW allows me to run my games off Mem stick yes, So is this the one I need? OFW will just make it stock PSP yes and not allow this?

    So how come CFW is still at v5.50 whereas OFW is now v6.31? I thought they used to keep up with each other?

    Is the updated freely available and it's just run from the mem stick? Is there any point if I already have CFW v5.50?

    Cheers

    Also if I have CFW on and I connect to my unmodded PS3 will there be any effect? Should I not? I don't want to jeperdise my PSN account.
     
  6. SifJar

    Member SifJar Not a pirate

    Joined:
    Apr 4, 2009
    Messages:
    6,022
    Country:
    United Kingdom
    Most people who used to make and maintain CFWs have stopped now, and it takes time to develop a CFW anyway. With the little interesting features added to OFW, people didn't bother.

    If all games are working for you now, theres no need to upgrade. 5.50 Prometheus just works with newer games GEN has troubles with I believe. If it ain't broke, don't fix it [​IMG]

    As for connecting to the PS3, there's a plugin called USB Version Spoofer which will allow you to connect to your PS3 and make it think that you're using the latest OFW.
     
  7. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    A lot of the features added to OFW either don't matter to a majority of people, or have been available via plugins in CFW for a while (such as game categories).
     
  8. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
  9. RyuKisargi

    Member RyuKisargi GBAtemp Regular

    Joined:
    Feb 7, 2009
    Messages:
    141
    Country:
    United States
    Stick with 5.50 GEND3, Prometheus has too many problems with older titles.
     
  10. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
    So does 5.50 GEN D3....
     

Share This Page