Just an FYI in case your Menuhax suddenly stops working for no reason

Discussion in '3DS - Flashcards & Custom Firmwares' started by archnachoofthepi, Mar 8, 2016.

  1. archnachoofthepi
    OP

    archnachoofthepi Advanced Member

    Newcomer
    79
    17
    Aug 4, 2007
    United States
    This has probably been posted, and is probably old, but since I ask for help here so often and I figured out how to fix a weird new problem I had I thought I would give back to the community and post my findings.

    While I was trying to figure out my weird Final Fantasy Tactics Advance issue (I "fixed it" by switching to the European rom), out of the blue my Menuhax stopped working. I started to worry that my L trigger was somehow suddenly bad, but no, Menuhax was just like "Nah" out of nowhere.

    I saw that my firmware was still properly on 9.2, so I used Browserhax and verified that my precious Emunand was still working. So, after some digging, here's what I found:

    *All credit goes to colombient of reddit, modified for how I deviated from their instructions and did my own thing*

    1. Download your ropbin that matches your SYSNAND firmware and 3DS version (new or old) from http://smealum.github.io/3ds/#otherapp and rename it to menuhax_ropbinpayload.bin

    2. Consider downloading the apps from https://smealum.github.io/ninjhax2/starter.zip just in case.

    3. Replace the ropbinpayload on your card with the one you downloaded (ignore whatever name the ropbin on your card has)

    4. Go into the homebrew launcher however you can, browserhax worked well for me, and use menuhax installer to delete and uninstall your current menuhax. Exit the installer, and then turn off your 3DS.

    5. Go back into the homebrew launcher and reinstall menuhax however you please. I set mine to launch unless I held the A button.

    6. Go ahead and give it a whirl! Enjoy!

    Again, this is probably old news to you veterans out there, but I still have no idea what broke my menuhax, only that this fixed it. So, thought I'd share the info for anyone else who might find themselves in this situation!

    Best of luck and happy gaming!
     
  2. duwen

    duwen Old Man Yoshi

    Member
    1,165
    649
    Sep 6, 2013
    United States
    Bullet Hell
    You could probably have skipped steps 1-3, unless you'd previously verified that the payload had somehow corrupted.
     
  3. squee666

    squee666 Advanced Tech Pleb

    Member
    1,591
    895
    Sep 17, 2010
    Belfast
    1: Menuhax Not Working
    2:Try Reinstalling it
    3: Profit


    aka you someone corrupted your payload which seems to be the bigger issue since it means someone tampered with it or your card went bad
     
    TheKawaiiDesu likes this.
  4. Margen67

    Margen67 Dirty entited pirate

    Banned
    1,100
    4,587
    Nov 3, 2014
    United States
    1. Remove Menuhax
    2. Install Arm9loaderhax
    3. Join the master race
    4. Be glad you never have to deal with menuhax's instability ever again
     
    mungry, Scarlet and TheKawaiiDesu like this.
  5. archnachoofthepi
    OP

    archnachoofthepi Advanced Member

    Newcomer
    79
    17
    Aug 4, 2007
    United States
    Edit *I should clarify that this was in response to squeee666*

    That didn't come to pass, and reinstalling menuhax did not work. I tried that several times and it did not resolve the issue, and I'm the only person who touches my 3DS. I can confirm that all I did was uninstall one version of the gba emulator, install a new version of the gba emulator, delete the USA final fantasy tactics rom, copy over the European copy of the final fantasy tactics advance rom. After that, it booted up fine once, and then stopped working thereafter.

    I deleted and reinstalled menuhax multiple times, so that was not the fix, and my card being tampered with was not the problem.
     
  6. Margen67

    Margen67 Dirty entited pirate

    Banned
    1,100
    4,587
    Nov 3, 2014
    United States
    If you want a more reliable method of coldboot CFW then you should try arm9loaderhax
     
  7. TheKawaiiDesu

    TheKawaiiDesu Ball of Kawaiiness

    Member
    1,430
    1,502
    Aug 23, 2015
    Korea, North
    Lowee
    You should update the NNSPA image :^)
     
  8. Margen67

    Margen67 Dirty entited pirate

    Banned
    1,100
    4,587
    Nov 3, 2014
    United States
    I will Soon™
     
    TheKawaiiDesu likes this.
  9. leerz

    leerz GBAtemp Advanced Fan

    Member
    528
    133
    Jan 11, 2015
    Makati
    thanks for this intel.

    does this mean, I can easily fix my menuhax from 10.6emunand, and downgrading to 9.2 to make menuhax work again?
     
    archnachoofthepi likes this.
  10. archnachoofthepi
    OP

    archnachoofthepi Advanced Member

    Newcomer
    79
    17
    Aug 4, 2007
    United States
    If your sysnand is on 9.2 and your emunand is 10.6, you shouldn't need to downgrade :) The above steps should work for you just fine. I didn't create a new Emunand (I can't; it's got all of my eshop purchases and the like haha), I just made a new ropbinpayload and that worked for me. If it gives you any troubles, I'd be very happy to help!
     
  11. leerz

    leerz GBAtemp Advanced Fan

    Member
    528
    133
    Jan 11, 2015
    Makati
    sorry let me rephrase my sentence earlier, I meant sysnand


    sysnand 10.5/6 with menuhax working
    dged to 9.2 menuhax, obviously this will not work,
    we follow your process and it should work without reinstalling everything again, just replacing the ropbin?
     
  12. archnachoofthepi
    OP

    archnachoofthepi Advanced Member

    Newcomer
    79
    17
    Aug 4, 2007
    United States
    Unfortunately I'm not too familiar with menuhax on higher Sysnand, but if your menuhax worked previously on 10.5/10.6 it's plausible that replacing the ropbin would work without having to reinstall your data. You can always backup your card to be sure, but it shouldn't adversely affect anything.
     
  13. leerz

    leerz GBAtemp Advanced Fan

    Member
    528
    133
    Jan 11, 2015
    Makati
    I thought that was the point of the guide, sorry like most of the guys trolling, it was tldr. but good thought and good find :)

    BR

    lrz
     
  14. archnachoofthepi
    OP

    archnachoofthepi Advanced Member

    Newcomer
    79
    17
    Aug 4, 2007
    United States
    The trolls are unfortunate since I was genuinely trying to be helpful. I didn't think it was that long, but if someone is looking for info and feels that it is, they can always just skip to the numbers. It should work on your 10.5/10.6; I'd be curious to know if it worked out for you. Hope it helps!
     
    leerz likes this.
  15. squee666

    squee666 Advanced Tech Pleb

    Member
    1,591
    895
    Sep 17, 2010
    Belfast
    4. Go into the homebrew launcher however you can, browserhax worked well for me, and use menuhax installer to delete and uninstall your current menuhax. Exit the installer, and then turn off your 3DS.

    5. Go back into the homebrew launcher and reinstall menuhax however you please. I set mine to launch unless I held the A button.


    But hey apparently it was the Payloads issue

    But you also said you tried reinstalling Menuhax multiple times


    Aka the conclusion is the payload was working fine because you could access Homebrew loader in the first place to try this

    So either menuhax was broken aka reinstall or payload was faulty (but worked normally lol)
    Or your card is causing some magic fuckery or its having its own corruption issues

    Either way its one of those or your story is inconsistant (which it is lol)
     
  16. archnachoofthepi
    OP

    archnachoofthepi Advanced Member

    Newcomer
    79
    17
    Aug 4, 2007
    United States
    My story isn't inconsistent, it seems you're not understanding what's being said. Menuhax stopped loading through holding the L trigger at startup. I re-installed it multiple times before doing the numbered steps I outlined, and holding L to start menuhax still did not work, after re-installing it multiple times before making and copying a new ropbinpayload.

    When that did not work, I found the steps I outlined below. I performed those steps, and it worked thereafter. Re-installing menuhax from that list of steps only occurred after reinstalling the ropbinpayload.