Jak and Daxter - First mission's cutscene won't play

Discussion in 'PSP - Games & Content' started by Neo Draven, Jan 23, 2012.

  1. Neo Draven
    OP

    Member Neo Draven End Boss of the Entire Internet

    Joined:
    May 3, 2010
    Messages:
    815
    Country:
    United States
    I cannot get Jak and Daxter - The Lost Frontier to work properly. It boots and there are no freezes, but when I am trying to get back to the crash site with the green eco crystals, the cutscene with Keira NEVER starts. Nothing I have tried works. I've tried every driver configuration (ME, M33, SONY, OE), every possible ISO build (untouched, update removed, CSO'd, untouched CSO, etc), every clock speed and every combination thereof.

    Does anyone know a solution? I am running this on a PSP Slim 2000 with 6.39 ME-9.2, using a PhotoFast CR5400 adapter with a 16GB SanDisk microSDHC card.

    If not, can anyone give me a save file from the very first mission, after that cutscene has played? I'd really appreciate it.
     
  2. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    I had memory stick issues with The Lost Frontier - it needed the fastest stick i had to run without jitters. I'd suggest you try a smaller Sandisk Pro Duo (one which is as fast as you can get). Heck, just try a genuine Pro Duo and see if you get any further.

    Quick Edit - You've tried both EU and US versions too?
    (I also really liked the game.... :wub:)
     
  3. TheHaxForU

    Member TheHaxForU GBAtemp Regular

    Joined:
    Jan 19, 2012
    Messages:
    171
    Country:
    United States
    try running it on 6.39PRO-B10? i have it on 6.20PRO-B9 and it works fine :P
     

Share This Page