Hacking Issues with FBI/AGB_firm on sysnand

kyomagi

Well-Known Member
Member
Joined
Feb 28, 2009
Messages
214
Trophies
0
XP
195
Country
United States
so i am having issues, when i try to play gba cia's i get the black screen. i realized i have agb firm on the emunand installed but not the system nand. when i try to install fbi or the gba cia to system nand, it does not show up.

Now what gets me is, when i try to follow the guide to install on system nand, i have to hold B to turn off rx tools auto boot. I get into sysnand, go in the HBL, start pasta, hold B again and go back into hbl, fbi and install, nothing happens. not sure how to fix this
 

CrispyYoshi

Well-Known Member
Member
Joined
Mar 20, 2010
Messages
1,539
Trophies
0
XP
1,014
Country
United States
so i am having issues, when i try to play gba cia's i get the black screen. i realized i have agb firm on the emunand installed but not the system nand. when i try to install fbi or the gba cia to system nand, it does not show up.

Now what gets me is, when i try to follow the guide to install on system nand, i have to hold B to turn off rx tools auto boot. I get into sysnand, go in the HBL, start pasta, hold B again and go back into hbl, fbi and install, nothing happens. not sure how to fix this
Official Firmware likes to hide unsigned .cias when you're in SysNAND: You have to run pasta and get back into sysnand homemenu in order to see the unsigned .cias

And yes, AGB_FIRM must be installed to SysNAND NAND for it to work in either of the NANDs. The game must be installed to SysNAND SD, too
 
  • Like
Reactions: NoNAND

kyomagi

Well-Known Member
Member
Joined
Feb 28, 2009
Messages
214
Trophies
0
XP
195
Country
United States
ok so i tried to install without running pasta first and it gave me an error with the tag "invalid signature" when i tried to install. When i opened pasta from HBL and held b to stop the cfw auto boot, i went into ofw but non of the cia's i installed were there.

and im thinking 16gb is not enough. time to get a 32gb.


edit - So i see FBI and the gba game on sysnand with pasta on, gba game works on that, but not emunand. when i try to install the agb_firm to SD (not nand) it gives me an invalid combination error. when i try to install it to nand while in rxtools, it installs fine.
 
Last edited by kyomagi,

CrispyYoshi

Well-Known Member
Member
Joined
Mar 20, 2010
Messages
1,539
Trophies
0
XP
1,014
Country
United States
ok so i tried to install without running pasta first and it gave me an error with the tag "invalid signature" when i tried to install. When i opened pasta from HBL and held b to stop the cfw auto boot, i went into ofw but non of the cia's i installed were there.

and im thinking 16gb is not enough. time to get a 32gb.


edit - So i see FBI and the gba game on sysnand with pasta on, gba game works on that, but not emunand. when i try to install the agb_firm to SD (not nand) it gives me an invalid combination error. when i try to install it to nand while in rxtools, it installs fine.
Yes, even though you already set it up for sysnand, you must also set it up for emunand if you want to run GBA on EmuNAND.

You should install AGB_FIRM to EmuNAND NAND and you should install your games to EmuNAND SD as well.
 

kyomagi

Well-Known Member
Member
Joined
Feb 28, 2009
Messages
214
Trophies
0
XP
195
Country
United States
so while in RX tools i need to install the agb_firm while in rx tools to Nand and the game while in rxtools to SD?

ok, did that, still black screen
 
Last edited by kyomagi,

Site & Scene News

General chit-chat
Help Users
  • No one is chatting at the moment.
    kenenthk @ kenenthk: https://youtube.com/shorts/jcrzFVc8LFw?feature=share