Gaming Issues in Star Wars Battlefront Elite Squadron and Jak and Daxter movi

planetofthemage

Well-Known Member
OP
Newcomer
Joined
Dec 6, 2008
Messages
95
Trophies
0
XP
278
Country
United States
I updated to 5.50gen-d2 to play both of these, and upon starting the campaign of Elite Squadron, I noticed the first video had very bad audio video syncing issues and it would play for a second, and then freeze, and then play for a second then freeze.

I started Jak and Daxter and it did the same thing.

Anyone know what's wrong with my PSP?
 

MZ EXE.

Well-Known Member
Member
Joined
Mar 14, 2009
Messages
110
Trophies
0
Age
31
Location
Some place you won't know.
Website
Visit site
XP
142
Country
United States
Are you running them as CSOs try playing them as ISOs.

They seem to get very glitchy as CSOs but not as ISOs. I've tested Star Wars Battlefront Elite Squadron as CSO and ISO. When played as CSO I did get bad audio/video lag but when I played it as an ISO it ran at full speed with no audio/video lag.

I'm guessing the same could be said with Jak and Daxter. (I haven't test it with Jak and Daxter and I don't plan on testing it.)
 

Evilmaster1985

Well-Known Member
Member
Joined
Nov 23, 2008
Messages
456
Trophies
0
Location
Middle of nowhere
XP
109
Country
United States
Is your game in: *.CSO format?
If so this could cause trouble in movies and under very heavy loading times.
I suggest you uncompress the *.CSO file to: *.ISO

As you might have noticed the GEN-D2 firmware has no memstick speed up function.
I had some problem playing some of my backups in *.CSO format after swapping from M33 to GEN.
I converted the back to *.ISO and they seem to be working just fine so far.

If this is not the case could you give some more info on:
- In what format the games are.
- What type of PSP you use.
- What plugins are enabled.
- And the type of memstick.
 

prowler

Sony
Member
Joined
Jul 14, 2009
Messages
9,475
Trophies
0
Location
Ragol
XP
3,294
Country
Zimbabwe
hmm...
I played Jak and Daxter CSO, and tried Star Wars CSO on GEN D2 and nothing was laggy, or stuff like that.
plus i have a fake memory card to
rofl2.gif
 

Yuan

Well-Known Member
Member
Joined
Oct 1, 2007
Messages
1,291
Trophies
0
XP
371
Country
Brazil
I'm playing Jak and Daxter @ ISO. It's running flawlessly. Doesn't even need to raise cpu clock speed.
 

Evilmaster1985

Well-Known Member
Member
Joined
Nov 23, 2008
Messages
456
Trophies
0
Location
Middle of nowhere
XP
109
Country
United States
planetofthemage said:
Both are already in ISO. I'm going to redump and pray.

What options are there for speeding up MS access in gen?

As far as I know there is no way to speed up the MS in 5.50 GEN-D2.

Not that we really need to do so as over here everything runs correct.
(Some minor slow downs using newwer games as *.CSO on multiplayer)

Not that it helps to tell you everything works over here.
But that should alteast tell you there are no major problems known with these games.

Another side question: How did you upgrade your PSP from 5.00 M33-6 to 5.50 GEN-D2?
 

You may also like...

General chit-chat
Help Users
    M4x1mumReZ @ M4x1mumReZ: Seen Pentium IVs cook pasta so it should be possible to do the same with that.