Issue with the Micro SD Port on my console, do i need a new one?

Discussion in 'Switch - Console, Accessories & Hardware' started by SilentOne1994, Apr 26, 2019.

  1. linuxares

    linuxares I'm not a generous god!

    Moderator
    16
    Aug 5, 2007
    Sweden
    For the little knowledge I have with soldering. Use proper heat, always clean up the joints (with a solder wick) before applying new solder (probably unnessary), USE FLUX!!!, and take your time!
    Magnifying glass and a card holder is a nice thing to have.

    https://www.build-electronic-circuits.com/soldering-tools/ a list you can use to buy things.


    EDIT: Got a multi meter? Maybe you can just find the bad pin instead?
     
    Last edited by linuxares, Apr 26, 2019
    SilentOne1994 likes this.
  2. SilentOne1994
    OP

    SilentOne1994 SilentOne2k94

    Member
    2
    Feb 5, 2016
    Australia
    Australia

    thats an idea, i'll check around the house
    should have one somewhere
     
  3. Dave_Chad

    Dave_Chad GBAtemp Advanced Fan

    Member
    6
    Jun 29, 2016
    Sounds like a job for tiny soldering guy. Where is he?

    Sent from my VOG-L09/Huawei P30 Pro
     
  4. SilentOne1994
    OP

    SilentOne1994 SilentOne2k94

    Member
    2
    Feb 5, 2016
    Australia
    Australia

    i'd literally pay someone to do the Micro-soldering work for me lol
     
  5. Brayton

    Brayton GBAtemp Regular

    Member
    4
    Feb 6, 2016
    United States
    What about cloud backup?
     
  6. SilentOne1994
    OP

    SilentOne1994 SilentOne2k94

    Member
    2
    Feb 5, 2016
    Australia
    Australia

    Not sure if the switch has cloud backup without Nintendo Online
     
  7. Brayton

    Brayton GBAtemp Regular

    Member
    4
    Feb 6, 2016
    United States
    Have you used your trial?
     
  8. SilentOne1994
    OP

    SilentOne1994 SilentOne2k94

    Member
    2
    Feb 5, 2016
    Australia
    Australia
    Yeah back when Nintendo online first released
    Unsure if i backed up my data with it though.
    My switch has mainly been in airplane mode since I hacked it
     
  9. Brayton

    Brayton GBAtemp Regular

    Member
    4
    Feb 6, 2016
    United States
    Is your account set to region Japan?
     
  10. SilentOne1994
    OP

    SilentOne1994 SilentOne2k94

    Member
    2
    Feb 5, 2016
    Australia
    Australia
    Nope, set to Australia
     
  11. Brayton

    Brayton GBAtemp Regular

    Member
    4
    Feb 6, 2016
    United States
    Well, then I don't have a code you can use. Sorry. You can transfer accounts and individual saves between consoles in 8.0.
     
  12. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    I think that might just be an optical illusion due to the lighting. It almost looks like some upscaling effect was applied (something like HQx) when he zoomed in with his phone camera, because the edges of everything look smoothed out. The port looks damaged but maybe not melted, but the image is so grainy it's hard to tell.
    You can make a NAND backup over USB with HacDiskMount (do not actually mount the partition in Windows as it may corrupt the NAND, just use it to dump the USER partition which has your saves, you can dump the others as well if you like), which once decrypted/extracted with your own keys allows you to retrieve the save files.

    Also can you get better pictures? Try holding the phone/camera as close as possible with it still being able to focus.
     
    Last edited by The Real Jdbye, Apr 26, 2019
  13. linuxares

    linuxares I'm not a generous god!

    Moderator
    16
    Aug 5, 2007
    Sweden
    Hmm what you can do to extract your keys and saves.

    1) Use some RCM software to boot biskeydump
    2) Scan the QR code with your phone or such, save them to keys.txt
    3) Again run a RCM software and boot memloader
    4) Download hacdiskmount, mount physical device, click that you wish to mount USER partition to like A:\
    5) Use biskey nr 3 (I think it was), you need half of it for the first part, and the remainder for the bottom part. You will see when you click USER.
    6) Use this tool: https://gbatemp.net/threads/extract-save-from-nand-backup.514261/#post-8299285 and it will extract the saves from the partition.
    7) Yaaay you got your game saves!
     
    SilentOne1994 likes this.
  14. Agim iljazi

    Agim iljazi Member

    Newcomer
    2
    May 5, 2016
    Have sent my switch back to nintendo twice because of the sd card reader .
     
  15. Brayton

    Brayton GBAtemp Regular

    Member
    4
    Feb 6, 2016
    United States
    Yeowch.
     
    SilentOne1994 likes this.
  16. SilentOne1994
    OP

    SilentOne1994 SilentOne2k94

    Member
    2
    Feb 5, 2016
    Australia
    Australia
    I seem to get this error when pushing Memloader.bin and the switch doesn't show up in HacDiskMount
    15562892620608673128907660958024.





    Yeah I found out it was HQx that was causing the blur look
    This is possibly the best I can get it to look on a google pixel 3 xl
    IMG_20190427_003945.
     
    Last edited by SilentOne1994, Apr 26, 2019
  17. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    18
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    That looks more normal, it does look like half the pins are missing though. Are you sure they weren't ripped out and are still in the SD reader module? They can't just disappear.

    I think that error is normal if you don't have a SD card. Check device manager if the device shows up, you may have to install the driver again.
     
    Last edited by The Real Jdbye, Apr 26, 2019
  18. SilentOne1994
    OP

    SilentOne1994 SilentOne2k94

    Member
    2
    Feb 5, 2016
    Australia
    Australia

    I already have the device installed as "APX" under my devices in Zadig and its my current libusbK (v3.0.7.0) driver but it still doesn't show up as a device in HacDiskMount for some reason
    IMG_20190427_014455. IMG_20190427_014506. IMG_20190427_014520.
    "generic" is my micro sd that's currently in a microsd adapter on the side of my computer and the other is my C drive


    Also, I had a look at my old reader that I took out and replaced with this new one and there's no pins attached to it or any trace of pins anywhere.. So they must have fallen off somehow while I was doing something or rather with my switch.
     
    Last edited by SilentOne1994, Apr 26, 2019
Loading...