Issue I'm having with B9S and my SD card

Discussion in '3DS - Flashcards & Custom Firmwares' started by sniper_x002, May 23, 2017.

  1. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    Edit: Just realized this is probably in the wrong section.
    Not sure if this is just a problem for me, or others too.

    Way back some time ago while I was using A9LH I posted about an issue with my SD card. (actually can't find it here maybe it was a different site) Sometimes, for who knows why (I think it's caused by using a specific app, no idea which though), launching anything from the home menu would yield a SD card is removed error, and powering off the console took a lot more time than usual.

    I'm also confused why it starts because sometimes I'll go for months before I see it again.
    But the thing is, with A9LH I discovered a fix that always made the issue go away.
    I simply kept a backup arm9loaderhax.bin somewhere, and when the issue started happening I loaded up godmode9 and replaced the bin with my backup (even if it was the same exact file)

    Now I'm having this issue with B9S, only I have no arm9loaderhax.bin to replace (obviously). Is this a known (but maybe rare) issue?
     
    Last edited by sniper_x002, May 23, 2017
  2. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,502
    5,465
    Mar 17, 2010
    Norway
    Alola
    Sounds like a SD card issue, maybe corrupted or faulty.
     
  3. SonicMC

    SonicMC GBAtemp Regular

    Member
    201
    58
    Dec 6, 2007
    United States
    Have you tried running h2testw on the sd card to make sure it's not the cause of the issue?
     
    Quantumcat and sniper_x002 like this.
  4. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    Not necessarily saying you're wrong, but it doesn't make sense as this is the only problem I've ever had with it, it first starting many months ago (only popping up sometimes).

    I'll try this, does it require an empty SD card?

    Also I should probably have mentioned it is a 128GB microSD.
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    12,502
    5,465
    Mar 17, 2010
    Norway
    Alola
    It works best with an empty card. It can't test any space that's in use. It might be a good idea to reformat it anyway, so you can copy the files off it then test the card and reformat it.
    You should also run Check Disk to make sure it's not corrupted.
     
    sniper_x002 likes this.
  6. Xiphiidae

    Xiphiidae

    Member
    2,085
    1,022
    Sep 13, 2009
    Australia
    If anything, that is evidence for it being an SD issue.

    What program did you use to format it to FAT32? It might be worth reformatting it (with a cluster size of 32K), and then checking it with H2testw.
     
    Last edited by Xiphiidae, May 23, 2017
    sniper_x002 likes this.
  7. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    Can't remember, probably rufus.

    I guess I'll go ahead and get everything off of it, format it, test it, and update here.
    What's the end result between choosing 32k or 64k? I don't remember what I set mine to.
     
  8. SonicMC

    SonicMC GBAtemp Regular

    Member
    201
    58
    Dec 6, 2007
    United States
    pixelmasher likes this.
  9. noX1609

    noX1609 B9S freak ;)

    Member
    276
    25
    Aug 30, 2016
    Germany
    I would also recommend you to check the SDCard with the tool.
    The problem you have sounds like an issue with the card for me also if the payload is the only problem you have. It could be one corrupted sector where the payload is saved.
     
  10. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    The tool is running right now. It says it has 1h ~ remaining. It's also formatted to exFat right now, I'm gonna put it back to fat32 later hopefully that's OK.

    Edit: Still 1 hr left because it's verifying instead of writing now.
     
    Last edited by sniper_x002, May 23, 2017
  11. pixelmasher

    pixelmasher Gaming Gamer

    Member
    1,633
    671
    Dec 12, 2016
    United States
    Near N3DS
    You might have mentioned it was in exFAT in OP. 3DS ONLY supports FAT32.
     
  12. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    Nono, I was using it fat32 while on my N3DS. Then I got everything off, and format it with Windows to exFat (temp., since you can't format it to fat32 by default). Once it's done I'll switch it back to fat32.

    Like I said, everything worked great about it except the one bug that happened occasionally, which I was able to easily fix when using A9LH.
     
  13. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    [​IMG]
    No errors?

    Using rufus to format it to fat32 again, then I'll put the files back on & try it in the 3DS again.
    I'm also having rufus check for bad blocks just to be sure.
     
    Last edited by sniper_x002, May 23, 2017
  14. Classicgamer

    Classicgamer GBAtemp Advanced Fan

    Member
    517
    138
    Aug 20, 2012
    United States
    I had a very similar issue (copied CIA files would fail to install) intermittently which turned out to be a faulty micro sd adapter used to interface to the computer.

    Needless to say it fried the msd partially even though I could still boot up and load games. I sent it to sandisk and they replaced it (5yrs old/8yr warranty) with a higher class speed too LoL - just make sure you have the receipt and hit up their website.

    Also the recommended tool for formatting is GUI format I think. I had to run h2test a few times before it errored out. These cards are pretty resilient and when they die they keep on holding on!!
     
    Last edited by Classicgamer, May 23, 2017
  15. V0ltr0n

    V0ltr0n GBAtemp Fan

    Member
    467
    267
    Jan 5, 2016
    United States
    Dafuq is rufus? Try guiformat. It has helped ppl in the past that have issues. Also, it may not be the sd card but the contacts. You may want to try a different sd just to see if the problem persists. When you run the h2 test, I'm not sure if it matters, but i would think you should test it in the format you will be using it instead of changing to exfat, testing, then back to fat32.
     
  16. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    I wasn't able to test fat32 at the time, so I'm probably going to have it do another test afterward. Just wish it wasn't so time consuming, this has been an all day thing so far. I don't think I'll have any issues with rufus, I've used it a lot in the past for other things.
    I'm still not sure this is a hardware issue. Any tests I've done show no issues, my #1 thought is that it's a certain app on my 3DS that causes this to happen but honestly I have no idea, I'm just speculating.

    I also dislike how unpredictable this is. I cannot reliably get it to show the error message, but when it does it's hard to get rid of now.

    Edit: Once this is all done I think I'm gonna look through the activity log (unless it's possible to without an SD card in, then I can do it now) and see what apps I've used today to see if maybe I'm right.
     
    Last edited by sniper_x002, May 23, 2017
  17. V0ltr0n

    V0ltr0n GBAtemp Fan

    Member
    467
    267
    Jan 5, 2016
    United States
    @sniper_x002 i wish u luck. Sounds like a real pain in the ass. If all else fails, give gui format a try.
     
  18. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    Thanks I'll keep it in mind.
     
  19. Classicgamer

    Classicgamer GBAtemp Advanced Fan

    Member
    517
    138
    Aug 20, 2012
    United States
    Those were my thoughts exactly during my issue. I wanted to believe it was FBI's fault and then other CIA installers because anything installed via eshop was fine.
    Intermittent BS is the worst. During your card testing perhaps use another card in the system and see how it reacts?
     
  20. sniper_x002
    OP

    sniper_x002 GBAtemp Fan

    Member
    475
    112
    Jan 13, 2016
    If I can't (purposely) reproduce the error on the supposedly faulty SD card I don't know how I would do the same with a different SD.

    I might add that the error was never specific to one app.

    Assuming the error starts from boot, it'd go to the home menu like normal (themes, apps, everything loaded fine) but if I try to launch something (excluding NAND things like system settings IIRC) then it stays black a few seconds then switches to the SD card has been removed. That is when, previously, I would replace the arm9loaderhax.bin using godmode9 and it would work fine and dandy for either a little bit of time or months.

    Edit: Also I forgot about something interesting I noticed. Since I can use System Settings while the console is "bugged", I can still use SD Management to transfer files off and on of the SD card. However, I have to launch it twice before I see files on the PC, always (when bugged). The first time will 100% always show no files in the SD even if refreshed while looking at it through my PC.

    Update: Just finished making it fat32 with Rufus, it also checked for errors and found none. I'm using h2testw.exe one final time before restoring all my files. Hopefully it was fixed after the initial format (assuming it was a problem with the card), anyway I'm gonna go to bed now so I'll update this later.

    As for applications I used today, the only one that really stood out as something I don't normally use was a restart 3DS application (it has a green icon with an arrow pointing in a circle). Later I'll try using it again to see if it remakes the error.

    Update 2: I'm up, no errors on the test thingy again now that it's fat32. Going to put my files on it now.[​IMG]

    Update 3 (Hopefully final): It works now in the N3DS, though due to the nature of the issue I can't say for sure if the issue is permanently fixed. Hopefully. I went ahead and uninstalled the power off & restart 3DS homebrew just in case they were the cause of this mess. Thanks for the help guys.
     
    Last edited by sniper_x002, May 24, 2017
    SonicMC likes this.