iso problem

Discussion in 'Sony PlayStation 1 & 2' started by pizzaman2893, Jun 5, 2008.

Jun 5, 2008

iso problem by pizzaman2893 at 9:11 PM (969 Views / 0 Likes) 4 replies

  1. pizzaman2893
    OP

    Member pizzaman2893 GBAtemp Regular

    Joined:
    Apr 15, 2007
    Messages:
    253
    Country:
    United States
    I just ripped a few iso's from these games sonic riders and shadow the hedgehog but every time I tried it on the emulator they are in japanese even though they are usa games. Does anybody know how to fix it?
     
  2. Youkai

    Member Youkai Demon

    Joined:
    Jul 1, 2004
    Messages:
    1,988
    Location:
    Germany , NRW
    Country:
    Germany
    dunno what emulator you use but maybe you have japanese playstation bios ?
     
  3. MystikEkoez

    Member MystikEkoez GBAtemp Fan

    Joined:
    Sep 5, 2006
    Messages:
    346
    Location:
    Georgia
    Country:
    United States
    How is that even physically possible?
    Are you SURE you're ripping your own games and that they're actually in english in the first place?
     
  4. Joe88

    Member Joe88 [λ]

    Joined:
    Jan 6, 2008
    Messages:
    11,188
    Location:
    NYC
    Country:
    United States
    yea, that what im thinking

    most likely, where you "RIPPED" [​IMG] your ISO you got a JP version
     
  5. pizzaman2893
    OP

    Member pizzaman2893 GBAtemp Regular

    Joined:
    Apr 15, 2007
    Messages:
    253
    Country:
    United States
    Thats what I was wondering but it happend. and yes they are english games, bought them from gamestop and i play them on ps2 all the time
     

Share This Page