Is there a way to play newer UMDs on a psp with 5.00 M33-6 ?

Discussion in 'PSP - Games & Content' started by Kamina84, Aug 15, 2010.

  1. Kamina84
    OP

    Kamina84 Advanced Member

    Newcomer
    60
    0
    Feb 13, 2009
    United States
    Just found out Bandai is coming out with Kamen Rider: Climax Heroes OOOs for Wii and PSP. I intend on buying both versions. As I'm dusting off my PSP 2000, I realize I'm on M33. Is the a program that will skip the update check and play newer UMDs with M33 ? Don't want to update to GEN because I gotta have my pops. [​IMG] Thanks for you time. [​IMG]
     
  2. Lily

    Lily One Scary Lady

    Former Staff
    5,727
    391
    Jun 18, 2004
    Canada
    British Columbia
    Sure, you need the M33 6.20 plugin by Torky. You can get it here. (FYI: I visit the site using Chrome, as it will auto-translate the page from German to English.) It's very easy to install and use. Keep that thread bookmarked, as updates will always show up there first, and the guy is really adamant about the file not being hosted anywhere else.
     
  3. Kamina84
    OP

    Kamina84 Advanced Member

    Newcomer
    60
    0
    Feb 13, 2009
    United States
    Awesome !! Thanks man !! [​IMG] Gonna install it as soon as I get home. [​IMG]
     
  4. Vladimir

    Vladimir Advanced Member

    Newcomer
    68
    10
    Aug 4, 2010
    Mexico
    Guadalajara, Mexico
  5. thedicemaster

    thedicemaster GBAtemp Addict

    Member
    2,428
    15
    Apr 26, 2008
    Netherlands
    what would be the problem with GEN and pops?
    just get the GEN popsloader, works exactly like the one for m33 as far as i know.
     
  6. Vladimir

    Vladimir Advanced Member

    Newcomer
    68
    10
    Aug 4, 2010
    Mexico
    Guadalajara, Mexico
    A lot of people are still loyal to Dark-Alex (like me), also GEN D3 has many bugs and its not very stable on many things, i had it myself for months and decided to go back M33-6.
     
  7. KingVamp

    KingVamp Great... AETHER!

    Member
    10,027
    1,791
    Sep 13, 2009
    United States
    Never had a problem with GEN [​IMG]
     
  8. prowler

    prowler Sony

    Member
    9,473
    2,816
    Jul 14, 2009
    Ragol
    Wrong.
    GEN can't fully port the popsloader to 5.50 therefore M33 is the best for playing PS1 games.
     
  9. jalaneme

    jalaneme Female Gamer

    Member
    6,248
    195
    Nov 27, 2006
    London
    +1
     
  10. Kamina84
    OP

    Kamina84 Advanced Member

    Newcomer
    60
    0
    Feb 13, 2009
    United States
    Sorry to revive an old topic; however, this may require 6.31 now. :\ I haven't seen him update his topic in a while. [​IMG] Is there a way to play newer newer UMDs games and still stay on M33. Again, thanks alot !! [​IMG]
     
  11. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,102
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Prometheus has been getting various updates (Prome-3 is the latest) to play the latest games.
     
  12. xist

    xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Member
    5,861
    863
    Jul 14, 2008
    M33 will require you to dump and patch your UMD's...you won't be able to play them from disc.
     
  13. Kamina84
    OP

    Kamina84 Advanced Member

    Newcomer
    60
    0
    Feb 13, 2009
    United States
    Thanks. [​IMG] How's Prometheus's compatabilty with Popsloader (More concerned) and 1.50 emulators (Not really concerned. [​IMG]) ?
     
  14. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,102
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    It's just an addon for Gen D3, it's the same as D3.
     
  15. DarkShinigami

    DarkShinigami #1 strongest Shinigami BANKAI

    Member
    1,842
    83
    Sep 12, 2009
    United States
    Soul Society
    yes rydian prome-3 is the same as gen only ten times better
     
  16. insidexdeath

    insidexdeath .

    Member
    1,120
    448
    Apr 13, 2010
  17. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,102
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Prome-3 just affects the loading of the latest games, it's the same a D3 for the stuff he was asking about (which is not the loading of the latest games).